Community discussions

MUM Europe 2020
 
simonkizi
newbie
Topic Author
Posts: 45
Joined: Mon Jan 30, 2006 10:38 pm

Mikrotik Load Balancing Setup

Wed Mar 08, 2006 3:19 pm

Hi There.

Can anyone provide us with a proper setup to load balance 2 internet feeds.

1st Senario:
Mikroitik load balancing two gateways


2nd Senario:
Mikrotik Load Balances over two PPPoE connections where the Mikrotik is the PPPoE client running through two ADSL Modems set to ATM-to-Ethernet Bridge only.

Thx in advance
 
User avatar
fatonk
Member
Member
Posts: 439
Joined: Tue Feb 22, 2005 11:06 am
Location: Mitrovica/Kosova

Sun Mar 12, 2006 12:26 pm

Hi,

Are the both links equal, or one has higher capacity than the other.


Regards.
 
simonkizi
newbie
Topic Author
Posts: 45
Joined: Mon Jan 30, 2006 10:38 pm

Wed Mar 15, 2006 7:45 am

Yes they are.

Found out ECMP can help for multiple gateways. But need help for the second senario.

Thx
 
User avatar
mag
Member
Member
Posts: 378
Joined: Thu Jul 01, 2004 12:32 pm
Location: Cologne, NRW, Germany
Contact:

Wed Mar 15, 2006 9:45 am

Where's the difference? PPPoE sets a Gateway too. Read it from /ip route print and set it. See scripting examples in the manual.

something like:
 :local DefGw1 ""
 :local DefGw2 ""

 :set DefGw1 [/ip route get [find /ip route prefsrc=<ip-isp1>] dst-address]
 :set DefGw2 [/ip route get [find /ip route prefsrc=<ip-isp2>] dst-address]

 /ip route set [/ip route find dst-address=0.0.0.0/0] gateway=($DefGw1.,.$DefGw2)

Who is online

Users browsing this forum: xgasset and 28 guests