Page 1 of 1

Connection List question(RB435G)

Posted: Tue Jul 30, 2013 2:01 pm
by Roy
I have problem to set "connection List" Signal Strength Limit setup.

For example, RB435G is not connected Antenna. And Two RB435G wireless connection is good to ping reply(indoor test). Received signal is -75dBm.
I set signal strength -90..-60 dBm in connect list and press ‘apply’ button, And client disconnected and no ping reply. It means Limitation is working well.
In that time, I install antenna and received signal is changed to -30dBm. So ping reply And I removed antenna and received signal is -75dBm.
But ping still reply well. I think it must be disconnected. So,,, I tried connection list ‘apply’ button again, and then ping disconnected.


I don’t know why only limitation work only ‘apply’ button. :(

Re: Connection List question(RB435G)

Posted: Wed Jul 31, 2013 5:35 pm
by Ibersystems
Hi,


this is not for that.

This limit is to avoid connections grom -X to -x dbm.. BUT if you are connected and your signal drops, you wont be kicked out. This parameter is only read when you try to connect.

Re: Connection List question(RB435G)

Posted: Wed Jul 31, 2013 6:46 pm
by Roy
Hi,


this is not for that.

This limit is to avoid connections grom -X to -x dbm.. BUT if you are connected and your signal drops, you wont be kicked out. This parameter is only read when you try to connect.
(Road Side Equipment)---------------(RSE)--------------------(RSE)

CAR moving===========> this way.

I want to connect good signal RSE in mesh mode.
To do that, no way to change RSE connection?
Basically, I wish to disconnect low signal RSE.

or Access list work for that?

Re: Connection List question(RB435G)

Posted: Wed Jul 31, 2013 6:49 pm
by Ibersystems
Nope.

Make a script in the APs that kickoff your users when they have low CCQ or low throughtput.


If your client is kicked, it will try to reconnect to best signal AP, that will be one of next APs.

Re: Connection List question(RB435G)

Posted: Wed Jul 31, 2013 6:53 pm
by Ibersystems
NOTE: If the car is moving fast, you need to have 2 antennas in client, connected to 2 different APs. I don't know how to make it!


Scripts for do the other stuff:

-Kick when less than 4000 P-throughput
/system script
add name=chequear-throughput policy=\
    ftp,reboot,read,write,policy,test,winbox,sniff,sensitive source="/interfac\
    e wireless registration-table\r\
    \n:foreach i in=[ /interface wireless registration-table find ap=no] do={\
    \r\
    \n:if ([get \$i p-throughput] < 4000) do={\r\
    \n:log warning ([get \$i mac-address] . \" @ \" . [get \$i last-ip] . \" s\
    e ha desconectado debido a la baja calidad de throughput\")\r\
    \n/interface wireless registration-table remove \$i\r\
    \n:delay 150ms\r\
    \n}\r\
    \n}"


-kick when less than 50% CCQ

/interface wireless registration-table
:foreach i in=[ /interface wireless registration-table find ap=no] do={
:if ([get $i tx-ccq] < "50") do={
:log warning ([get $i mac-address] . " was disconnected due to low CCQ - Tx: " . [get $i tx-ccq] . "% / Rx: " . [get $i rx-ccq] . "%")
/interface wireless registration-table remove $i
:delay 5s
}
}
Scheduler each X seconds.

Re: Connection List question(RB435G)

Posted: Thu Aug 01, 2013 9:19 am
by Roy
NOTE: If the car is moving fast, you need to have 2 antennas in client, connected to 2 different APs. I don't know how to make it!


Scripts for do the other stuff:

-Kick when less than 4000 P-throughput
/system script
add name=chequear-throughput policy=\
    ftp,reboot,read,write,policy,test,winbox,sniff,sensitive source="/interfac\
    e wireless registration-table\r\
    \n:foreach i in=[ /interface wireless registration-table find ap=no] do={\
    \r\
    \n:if ([get \$i p-throughput] < 4000) do={\r\
    \n:log warning ([get \$i mac-address] . \" @ \" . [get \$i last-ip] . \" s\
    e ha desconectado debido a la baja calidad de throughput\")\r\
    \n/interface wireless registration-table remove \$i\r\
    \n:delay 150ms\r\
    \n}\r\
    \n}"


-kick when less than 50% CCQ

/interface wireless registration-table
:foreach i in=[ /interface wireless registration-table find ap=no] do={
:if ([get $i tx-ccq] < "50") do={
:log warning ([get $i mac-address] . " was disconnected due to low CCQ - Tx: " . [get $i tx-ccq] . "% / Rx: " . [get $i rx-ccq] . "%")
/interface wireless registration-table remove $i
:delay 5s
}
}
Scheduler each X seconds.
Hello,
Thank you very much for your script example.
Can you give me "signal Strength limit script"?

Re: Connection List question(RB435G)

Posted: Thu Aug 01, 2013 9:25 am
by Ibersystems
I don't have it. Sorry but we are not scripting pros..