Community discussions

MikroTik App
 
Rolfieo
just joined
Topic Author
Posts: 9
Joined: Sun Mar 10, 2013 10:16 pm

P2P Unstable

Tue Sep 17, 2013 10:09 pm

I have a P2P connection with 2 SXT G-5HnD. Both are running RouterOS 5.24 version.
They are about a 150meter apart. So this is not a big distance that needs to be transmitted.

The LOS is pretty good. Its on a small harbor and some masts of the boots are in the LOS. But no sails at this moment.

On the P2P connection I have an MPLS connection for from VLAN's that transfer 2 VLAN's to the other side. My MGMT VLAN and the "Internet" vlan.

My issue is that the P2P connection is unstable. I get a lot of disconnects in the WiFi, and at this moment I have no idea anymore exactly where to troubleshoot.
Can somebody point me in some directions. I think the AccesPoints are pretty good aligned, but they are not very good accessible for me to really check. I'm using the 5GHz range. There are no other access points sending in the same signal.

But the second accesspoints keeps disconnecting. Sometimes the connection works for hours (or well the connection is up. But it will probably not mean that the the DHCP requests will be send over it.
I get a lot of complains that there is no Internet on the behind the P2P connection.

ros code

/interface wireless
set 0 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 area="" \
    arp=enabled band=5ghz-a/n basic-rates-a/g=6Mbps bridge-mode=enabled \
    channel-width=20/40mhz-ht-above compression=no country=no_country_set \
    default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=\
    0 default-forwarding=yes dfs-mode=none disable-running-check=no disabled=\
    no disconnect-timeout=3s distance=dynamic frame-lifetime=0 frequency=5180 \
    frequency-mode=manual-txpower frequency-offset=0 hide-ssid=yes \
    ht-ampdu-priorities=0 ht-amsdu-limit=8192 ht-amsdu-threshold=8192 \
    ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 \
    ht-guard-interval=any ht-rxchains=0,1 ht-supported-mcs="mcs-0,mcs-1,mcs-2,\
    mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-\
    14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23" \
    ht-txchains=0,1 hw-fragmentation-threshold=disabled hw-protection-mode=\
    none hw-protection-threshold=0 hw-retries=7 l2mtu=2290 mac-address=\
    00:0C:42:F2:40:2C max-station-count=2007 mode=bridge mtu=1500 \
    multicast-helper=default name=wlan1 noise-floor-threshold=default \
    nv2-cell-radius=30 nv2-noise-floor-offset=default nv2-preshared-key="" \
    nv2-qos=default nv2-queue-count=2 nv2-security=disabled \
    on-fail-retry-time=100ms periodic-calibration=default \
    periodic-calibration-interval=60 preamble-mode=both \
    proprietary-extensions=post-2.9.25 radio-name=000C42F2402C \
    rate-selection=advanced rate-set=default scan-list=default \
    security-profile=profile1 ssid=dragt-mpls station-bridge-clone-mac=\
    00:00:00:00:00:00 supported-rates-a/g=\
    6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps tdma-period-size=2 \
    tx-power-mode=default update-stats-interval=disabled wds-cost-range=\
    50-150 wds-default-bridge=none wds-default-cost=100 wds-ignore-ssid=no \
    wds-mode=disabled wireless-protocol=any wmm-support=disabled
/interface wireless manual-tx-power-table
set wlan1 manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9M\
    bps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:\
    17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,H\
    T40-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-\
    7:17"
You do not have the required permissions to view the files attached to this post.
 
ditonet
Forum Veteran
Forum Veteran
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: P2P Unstable

Tue Sep 17, 2013 11:52 pm

You have to lower transmitting power on your devices.
Signal strenght should be -60 to -50 dBm for best results.

HTH,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert
 
Rolfieo
just joined
Topic Author
Posts: 9
Joined: Sun Mar 10, 2013 10:16 pm

Re: P2P Unstable

Wed Sep 18, 2013 10:13 pm

Thank you.

I have lowered on both my AccessPoints the power:

local AccessPoint:

ros code

set wlan1 manual-tx-powers="1Mbps:7,2Mbps:7,5.5Mbps:7,11Mbps:7,6Mbps:7,9Mbps:7\
    ,12Mbps:7,18Mbps:7,24Mbps:7,36Mbps:7,48Mbps:7,54Mbps:7,HT20-0:7,HT20-1:7,H\
    T20-2:7,HT20-3:7,HT20-4:7,HT20-5:7,HT20-6:7,HT20-7:7,HT40-0:7,HT40-1:7,HT4\
    0-2:7,HT40-3:7,HT40-4:7,HT40-5:7,HT40-6:7,HT40-7:7"
Remote Accesspoint:

ros code

set wlan2 manual-tx-powers="1Mbps:6,2Mbps:6,5.5Mbps:6,11Mbps:6,6Mbps:6,9Mbps:6\
    ,12Mbps:6,18Mbps:6,24Mbps:6,36Mbps:6,48Mbps:6,54Mbps:6,HT20-0:6,HT20-1:6,H\
    T20-2:6,HT20-3:6,HT20-4:6,HT20-5:6,HT20-6:6,HT20-7:6,HT40-0:6,HT40-1:6,HT4\
    0-2:6,HT40-3:6,HT40-4:6,HT40-5:6,HT40-6:6,HT40-7:6"
I'm a little bit scared of lowering it to a lower value. Because i'm doing it remote. So if it set it to low, and I don't have a connection anymore, i have a big issue.

I see some improvements. The strengt is a lot more stable and better if I understand you advice correctly.
But still the remote access point link is very unstable. I notice now even more disconnects of the wifi link. So in a way, its even more unstable. It link yes to be run sometimes for yours. Now its disconnecing every few minutes.

The Log File

ros code

21:06:25 wireless,info 00:0C:42:F1:49:8F@wlan1: disconnected, too many poll timeouts
21:06:28 wireless,debug wlan1: 00:0C:42:F1:49:8F attempts to associate
21:06:28 wireless,debug wlan1: 00:0C:42:F1:49:8F not in local ACL, by default accept
21:06:28 wireless,info 00:0C:42:F1:49:8F@wlan1: connected
21:08:31 wireless,info 00:0C:42:F1:49:8F@wlan1: disconnected, too many poll timeouts
21:08:34 wireless,debug wlan1: 00:0C:42:F1:49:8F attempts to associate
21:08:34 wireless,debug wlan1: 00:0C:42:F1:49:8F not in local ACL, by default accept
21:08:34 wireless,info 00:0C:42:F1:49:8F@wlan1: connected
21:09:47 wireless,info 00:0C:42:F1:49:8F@wlan1: disconnected, too many poll timeouts
21:09:50 wireless,debug wlan1: 00:0C:42:F1:49:8F attempts to associate
21:09:50 wireless,debug wlan1: 00:0C:42:F1:49:8F not in local ACL, by default accept
21:09:50 wireless,info 00:0C:42:F1:49:8F@wlan1: connected
You do not have the required permissions to view the files attached to this post.
 
h3ll1
just joined
Posts: 16
Joined: Thu Mar 31, 2005 11:34 am

Re: P2P Unstable

Thu Sep 19, 2013 12:43 am

/interface wireless set wlan1 wireless-protocol=nv2 hw-retries=12
 
Rolfieo
just joined
Topic Author
Posts: 9
Joined: Sun Mar 10, 2013 10:16 pm

Re: P2P Unstable

Thu Sep 19, 2013 10:56 pm

At the moment i have changes yesterday evening the connection to 802.11 and i did not see any disconnects any more on the link.

I have a feeling the P2P connection is not stable yet, because i lose pings to the otherside. I have a ping running every min that pings some switches on the other side. And this sometimes get no answer. What is strange. Because local P2P (SXT G-5HnD) is sending a ping to the remote P2P device. And i don't have lose on that one. But the MicroTik Switch behind that remote P2P connection, can't be pinged alwayes.

And still get some complains about no DHCP IPs on the other side.

I'm going first for a local vist, before i modify this on what you say (hardware retry)

ros code

/interface wireless
/interface wireless
set 0 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 area="" arp=enabled band=5ghz-a/n basic-rates-a/g=6Mbps bridge-mode=enabled channel-width=20/40mhz-ht-above \
    compression=no country=no_country_set default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 default-forwarding=yes dfs-mode=none disable-running-check=no \
    disabled=no disconnect-timeout=3s distance=dynamic frame-lifetime=0 frequency=5180 frequency-mode=manual-txpower frequency-offset=0 hide-ssid=yes ht-ampdu-priorities=0 \
    ht-amsdu-limit=8192 ht-amsdu-threshold=8192 ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-guard-interval=any ht-rxchains=0,1 ht-supported-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23 ht-txchains=0,1 \
    hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-threshold=0 hw-retries=7 l2mtu=2290 mac-address=00:0C:42:F2:40:2C max-station-count=2007 mode=bridge mtu=\
    1500 multicast-helper=default name=wlan1 noise-floor-threshold=default nv2-cell-radius=30 nv2-noise-floor-offset=default nv2-preshared-key="" nv2-qos=default nv2-queue-count=2 \
    nv2-security=disabled on-fail-retry-time=100ms periodic-calibration=default periodic-calibration-interval=60 preamble-mode=both proprietary-extensions=post-2.9.25 radio-name=\
    000C42F2402C rate-selection=advanced rate-set=default scan-list=default security-profile=profile1 ssid=dragt-mpls station-bridge-clone-mac=00:00:00:00:00:00 supported-rates-a/g=\
    6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps tdma-period-size=2 tx-power-mode=manual-table update-stats-interval=disabled wds-cost-range=50-150 wds-default-bridge=none \
    wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wireless-protocol=802.11 wmm-support=disabled

Who is online

Users browsing this forum: Google [Bot] and 33 guests