Community discussions

MikroTik App
 
Staj
just joined
Topic Author
Posts: 18
Joined: Tue Jun 04, 2013 9:35 am

RB951Ui-2HnD: Poor WLAN performance in domestic environment

Fri Oct 11, 2013 3:46 am

Hello,
I have two RB951Ui-2HnD running 6.4 I'm using to trial for our staff housing (each house has an internet connection) but I've gotten universal feedback of poor wireless performance compared with our old cheap and nasty TP-Link wireless routers.
Setup is fairly simple, Mikrotik acts as a PPPoE client through the ISP provided bridge equipment and provides wireless access to the people in the household (802.11b/g/n 20/40MHz, WPA2 AES). The surrounding air is fairly quiet (Only about 3 other SSIDs in the area) and noise floor is -101, client get between -40 and -70 but at the very most get Rx speeds of 72Mbps with Tx speeds usually around 1Mbps. Devices consist of a variety of phones and laptops, all have the same issue (No Macbooks though). About 5 to 10 devices are connected to the AP at any one time. One user reported they couldn't even connect with their laptop.

Don't have access to the unit at the moment (so no screenshots or config) but wireless settings are basically unchanged since factory then upgrade. I've got some scripts running (CPU and RAM usage are fine) and simple queues (for statistics only, no throttling) but the performance problems occur before those stages.

Does anyone have any general Mikrotik performance tuning or wireless debugging advise?
 
Metalspawn
just joined
Posts: 9
Joined: Tue Jan 12, 2010 4:15 pm

Re: RB951Ui-2HnD: Poor WLAN performance in domestic environm

Mon Oct 14, 2013 4:32 pm

Well last time i didn't enable WMM which made a difference :) try that
 
StNick
just joined
Posts: 17
Joined: Wed Oct 02, 2013 10:14 am

Re: RB951Ui-2HnD: Poor WLAN performance in domestic environm

Tue Oct 15, 2013 12:05 pm

I just logged in to post a thread asking for "general wifi" tips and tricks on my RB951G-2HnD myself, so rather than posting a duplicate, I hope you don't mind me hijacking yours! :P

I've noticed that my wifi signal (essentially serving two Android phones) is perfect throughout my house, with the exception of our main bedroom which is quite literally only 5 metres away from the router. The signal has to pass through two walls and a cubboard full of clothes to reach the bedroom which shouldn't really be an issue unless they are lined with lead-paint. Like you, I am running default settings for the most part (after a reset-configuration).

Have you tried turning on Adaptive Noise Immunity? I read that it helped others (though not me).

I am going to try enabling WMM as recommended by Metalspawn, although I can't tell if he's recommending AGAINST doing so, haha. In any event, default is disabled, so its worth a shot.
WMM (Wi-Fi Multimedia) is an automated, built-in QoS technology that is specifically designed to keep the integrity of multimedia: video, voice and audio. Typically, you just enable or disable it in a router with no further configuration.
Enabling WMM on a router is not a guarantee that you will gain any performance improvements. In fact, sometimes WMM can degrade performance, especially if you have QoS already configured. Still, if you are having performance issues, WMM is worth testing out to see there is any effect on performance.
 
jasongt
just joined
Posts: 21
Joined: Sun Sep 18, 2005 5:24 am

Re: RB951Ui-2HnD: Poor WLAN performance in domestic environm

Tue Oct 15, 2013 3:10 pm

I had very poor signal when the unit was laying on a flat surface about 6 ft off the floor, once I hung it on the wall with ports facing the floor at about 6.5 ft from the floor the unit has performed way better than expected. Going through 5 walls I have pretty much a -48 on 2 MBP, 2 MB, 2 iPads, 1 iPhone and 1 Nexus 4 droid. The only device that has lower signal is a Samsung Galaxy 2 Skyrocket which has had terrible Wifi signal of -74 or worse on most access points and it gets around -68 to -72 now. Looks odd but works great, prior to putting on it's side I was ready to send it back.
 
Staj
just joined
Topic Author
Posts: 18
Joined: Tue Jun 04, 2013 9:35 am

Re: RB951Ui-2HnD: Poor WLAN performance in domestic environm

Fri Oct 18, 2013 7:13 am

I think there could be something wrong with quickset in v6.4? I factory reset one of them, did a /interface wireless export and applied that over to the other one and I seem to be getting the expected performance in a lab setting, can't testify to stability though.

Who is online

Users browsing this forum: No registered users and 28 guests