Community discussions

MUM Europe 2020
 
derdigge
just joined
Topic Author
Posts: 9
Joined: Fri Jul 19, 2013 11:05 am

Strange problem with "some" single threaded connections

Thu Nov 28, 2013 4:11 am

Dear community.

I just switched my ptp bridge from SXTG-2HnD to SXTG-5HPnD-SAr2 because of the quiter Band.

On both sides there are powerfull linux machines.
With the G 2Hnd i had ~200mbits no matter if i use single or multithreaded Connections between them.
Iperf results something about 200mbits, usenet about 200mbit, iperf, wget everything is about the 200mbits +- 10.

I switched them to SXTG-5HPnD-SAr2 to use the quiter band. Especialy in the evenings 2ghz is a problem here in
urban area. Now things are getting strange. Iperf does singlethreded 190mbits, usenet also. iperf multithreaded is hitting 210 mbits. But wget is hardnailed at 30mbits. Whats the reason for this? I tried ros 5.25 and latest 6.6 with device firmware 3.08 to 3.10. Everyone has the same result.

Its driving me crazy.

Anyone has an idea for this?

I allready tried those typical tips here, reduce signal strenght, play with tdma period and so on. same result no matter what i do. Help on this is verry welcome.

Regards
derdigge

settings for client:
# jan/02/1970 03:10:45 by RouterOS 5.26
# software id = 3JZE-XJPZ
#
/interface bridge
add l2mtu=1600 name=bridge1 protocol-mode=rstp
/interface wireless
set 0 band=5ghz-a/n channel-width=20/40mhz-ht-above country=germany disabled=no frequency=5240 ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=\
    station-bridge name=wlan1-gateway noise-floor-threshold=-110 ssid=MikroTik tx-power=10 tx-power-mode=all-rates-fixed wireless-protocol=\
    nv2-nstreme-802.11 wmm-support=enabled
/interface ethernet
set 0 name=ether1-local
/interface wireless nstreme
set wlan1-gateway enable-nstreme=yes
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk group-ciphers=tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik unicast-ciphers=\
    tkip,aes-ccm wpa-pre-shared-key=***** wpa2-pre-shared-key=****
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=ether1-local name=default
/queue type
add kind=pcq name=pcq-upload-default pcq-classifier=src-address
add kind=pcq name=pcq-download-default pcq-classifier=dst-address
/system logging action
set 0 memory-lines=1000
set 1 disk-lines-per-file=1000
/interface bridge port
add bridge=bridge1 interface=ether1-local
add bridge=bridge1 interface=wlan1-gateway
/ip address
add address=192.168.88.10/24 comment="default configuration" interface=ether1-local
/ip dhcp-client
add comment="default configuration" interface=bridge1
/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=192.168.88.100
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add chain=input comment="default configuration" in-interface=wlan1-gateway
add chain=forward comment="default configuration" connection-state=established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" connection-state=invalid
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" disabled=yes out-interface=wlan1-gateway
/ip ipsec peer
add
/ip route
add distance=1 gateway=192.168.88.100
/ip service
set api disabled=no
set "" disabled=no port=8729
/system identity
set name=Easy
/system leds
add interface=wlan1-gateway leds=led1,led2,led3,led4,led5 type=wireless-signal-strength
/tool bandwidth-server
set authenticate=no
/tool mac-server
add disabled=no interface=ether1-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether1-local
settings for ap:
# jan/02/1970 03:08:23 by RouterOS 5.26
# software id = NHZE-N1PX
#
/interface bridge
add l2mtu=1600 name=bridge1 protocol-mode=rstp
/interface wireless
set 0 band=5ghz-a/n channel-width=20/40mhz-ht-above country=germany disabled=no frequency=5240 ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=bridge \
    name=wlan1-gateway noise-floor-threshold=-110 nv2-cell-radius=10 ssid=MikroTik tdma-period-size=1 tx-power=10 tx-power-mode=all-rates-fixed \
    wireless-protocol=nv2
/interface ethernet
set 0 name=ether1-local
/interface wireless nstreme
set wlan1-gateway enable-nstreme=yes framer-policy=best-fit
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk group-ciphers=tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik unicast-ciphers=\
    tkip,aes-ccm wpa-pre-shared-key=**** wpa2-pre-shared-key=****
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=ether1-local name=default
/queue type
add kind=pcq name=pcq-upload-default pcq-classifier=src-address
add kind=pcq name=pcq-download-default pcq-classifier=dst-address
/system logging action
set 0 memory-lines=1000
set 1 disk-lines-per-file=1000
/interface bridge port
add bridge=bridge1 interface=ether1-local
add bridge=bridge1 interface=wlan1-gateway
/ip address
add address=192.168.88.20/24 comment="default configuration" interface=ether1-local
/ip dhcp-client
add comment="default configuration" interface=bridge1
/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=192.168.88.100
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add action=drop chain=input comment="default configuration" in-interface=wlan1-gateway
add chain=forward comment="default configuration" connection-state=established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" connection-state=invalid
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" disabled=yes out-interface=wlan1-gateway
/ip ipsec peer
add
/ip route
add distance=1 gateway=192.168.88.100
/ip service
set api disabled=no
set "" disabled=no port=8729
/system identity
set name=Stephan
/system leds
add interface=wlan1-gateway leds=led1,led2,led3,led4,led5 type=wireless-signal-strength
/tool bandwidth-server
set authenticate=no
/tool mac-server
add disabled=no interface=ether1-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether1-local
 
User avatar
Belyivulk
Member Candidate
Member Candidate
Posts: 285
Joined: Mon Mar 06, 2006 10:53 pm
Location: Whangarei, New Zealand
Contact:

Re: Strange problem with "some" single threaded connections

Thu Nov 28, 2013 7:49 am

Ahem, you are bridging interfaces directly, on a MIPSBE processor. in this situation bridging in ROS appears to tap out at about 30mbps no matter what you do. We have hit Mikrotik up about this in the past and got no where.

Beccara might have a suggestion or two - i think using MPLS, or Routing if you can, works around this; where we dont bridge we have no issues at all. As soon as we bridge...30mbps is about it.

EDIT: Oh yeah, and try and download something from 200ms or higher away from you, while maxing out the bridge :) It will do about 30k/sec MAX.
 
derdigge
just joined
Topic Author
Posts: 9
Joined: Fri Jul 19, 2013 11:05 am

Re: Strange problem with "some" single threaded connections

Thu Nov 28, 2013 3:51 pm

Thanks for Your reply.
I tried this
http://wiki.mikrotik.com/wiki/Transpare ... using_MPLS

And it did not work. There is no ping then between the points (arpping does) .

I did direct bridging because "quick set" is forcing me to do so.
The alternate routing method is "slow" 100mbit ist the Limit because the CPU is
hogging then at 100%.

Any other dugestions?

EDIT.
I tried Routing now. The networks are connected using static routes, without NAT.
The Result is the same. You can set your watch on these valaues.
They really do match. Routing and Bridge are singlethreaded 30Mbits and multithreaded 200Mbits.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: Strange problem with "some" single threaded connections

Thu Nov 28, 2013 6:22 pm

what speeds you are getting if you try to use nstreme or 802.11 instead of nv2?
Also I suggest to use the noise-floor-threshold=default
 
User avatar
Belyivulk
Member Candidate
Member Candidate
Posts: 285
Joined: Mon Mar 06, 2006 10:53 pm
Location: Whangarei, New Zealand
Contact:

Re: Strange problem with "some" single threaded connections

Thu Nov 28, 2013 7:44 pm

Do you want to post your routed config in an export compact?
 
derdigge
just joined
Topic Author
Posts: 9
Joined: Fri Jul 19, 2013 11:05 am

Re: Strange problem with "some" single threaded connections

Fri Nov 29, 2013 12:14 am

Your help is verry welcome!

The Routed config has allready been resetted, sorry.

I really often found this mpls sugestion.
Is there a fix for that wiki entry?
http://wiki.mikrotik.com/wiki/Transpare ... using_MPLS


TXQ/RXQ is allways pending 98% - 100%
Results in iperf:
Image

Results in wget:
Image

These messueres are made with following settings:

ptp AP
[admin@MikroTik] > export compact
# jan/02/1970 07:15:16 by RouterOS 5.26
# software id = 3JZE-XJPZ
#
/interface bridge
add l2mtu=1600 name=bridge1 protocol-mode=rstp
/interface wireless
set 0 band=5ghz-a/n channel-width=20/40mhz-ht-below country=\
    "germany 5.8 fixed p-p" dfs-mode=no-radar-detect disabled=no frequency=\
    5850 ht-ampdu-priorities=0 ht-guard-interval=long ht-rxchains=0,1 \
    ht-txchains=0,1 l2mtu=2290 mode=bridge mtu=2290 name=wlan1-gateway \
    nv2-preshared-key=****** nv2-security=enabled ssid=Bumsbude tx-power=10 \
    tx-power-mode=all-rates-fixed wireless-protocol=nv2
/interface ethernet
set 0 name=ether1-local
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=ether1-local name=default
/interface bridge port
add bridge=bridge1 interface=ether1-local
add bridge=bridge1 interface=wlan1-gateway
/ip address
add address=192.168.88.10/24 comment="default configuration" interface=\
    ether1-local
/ip dhcp-client
add comment="default configuration" interface=bridge1
/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" dns-server=\
    192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=192.168.88.100
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add action=drop chain=input comment="default configuration" in-interface=\
    wlan1-gateway
add chain=forward comment="default configuration" connection-state=\
    established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" \
    connection-state=invalid
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" disabled=\
    yes out-interface=wlan1-gateway
/ip neighbor discovery
set wlan1-gateway disabled=yes
/ip route
add distance=1 gateway=192.168.88.100
/tool mac-server
add disabled=no interface=ether1-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether1-local
ptp client
# jan/02/1970 07:12:17 by RouterOS 5.26
# software id = NHZE-N1PX
#
/interface bridge
add l2mtu=1600 name=bridge1 protocol-mode=rstp
/interface wireless
set 0 adaptive-noise-immunity=ap-and-client-mode band=5ghz-a/n channel-width=20/40mhz-ht-above country="germany 5.8 fixed p-p" disabled=no distance=\
    indoors frequency=5770 ht-ampdu-priorities=0 ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=station-bridge mtu=2290 name=wlan1-gateway \
    nv2-preshared-key=****** nv2-security=enabled ssid=Bumsbude tx-power=5 tx-power-mode=all-rates-fixed wireless-protocol=nv2-nstreme-802.11
/interface ethernet
set 0 name=ether1-local
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=ether1-local name=default
/interface bridge port
add bridge=bridge1 interface=ether1-local
add bridge=bridge1 interface=wlan1-gateway
/ip address
add address=192.168.88.20/24 comment="default configuration" interface=ether1-local
/ip dhcp-client
add comment="default configuration" interface=bridge1
/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add action=drop chain=input comment="default configuration" in-interface=wlan1-gateway
add chain=forward comment="default configuration" connection-state=established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" connection-state=invalid
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" disabled=yes out-interface=wlan1-gateway
/ip neighbor discovery
set wlan1-gateway disabled=yes
/system identity
set name=Stephan
/tool mac-server
add disabled=no interface=ether1-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether1-local
I have an still old screenshot from 2,5ghz band.
The screenshot was made in the middle of the night when all those mobiles are quiet.
It was routeros 5.25 with fw 3.06?(not sure anymore) on SXTG-2HnD. So something must have changed since then
im ros or fw. Anything near that would be more than fine.
Image
 
Beccara
Long time Member
Long time Member
Posts: 606
Joined: Fri Apr 08, 2005 3:13 am

Re: Strange problem with "some" single threaded connections

Fri Nov 29, 2013 4:24 am

Ok now we're getting somewhere.

Rather than the MPLS example can you try using NO bridging at all and just IP routes? If that gives you single stream TCP above 30mbit then you are hitting the bridging limits
 
derdigge
just joined
Topic Author
Posts: 9
Joined: Fri Jul 19, 2013 11:05 am

Re: Strange problem with "some" single threaded connections

Fri Nov 29, 2013 9:04 am

Now i have tried these "Bridgefree" Settings:

AP:
# jan/02/1970 00:20:12 by RouterOS 6.6
# software id = 3JZE-XJPZ
#
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-onlyn bridge-mode=disabled channel-width=20/40mhz-ht-above country="germany 5.8 fixed p-p" disabled=no frequency=5850 ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge name=wlan1-gateway ssid=Bumsbude wireless-protocol=nv2
/interface ethernet
set [ find default-name=ether1 ] name=ether1-local
/ip neighbor discovery
set wlan1-gateway discover=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-server
add interface=wlan1-gateway name=dhcp1
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=ether1-local name=default
/ip address
add address=192.168.88.10/24 comment="default configuration" interface=ether1-local network=192.168.88.0
add address=192.168.89.10/24 interface=wlan1-gateway network=192.168.89.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid interface=wlan1-gateway
/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=192.168.88.100
/ip dns static
add address=192.168.88.1 name=router
/ip settings
set accept-redirects=yes
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add chain=input comment="default configuration" in-interface=wlan1-gateway
add chain=forward comment="default configuration" connection-state=established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" connection-state=invalid
/ip firewall nat
add action=masquerade chain=srcnat disabled=yes out-interface=ether1-local
/ip route
add distance=1 gateway=192.168.88.100
add distance=1 dst-address=192.168.90.0/24 gateway=192.168.89.20
/system identity
set name=Easy
/system leds
set 0 interface=wlan1-gateway
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether1-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether1-local
Client:
# jan/02/1970 00:21:20 by RouterOS 6.6
# software id = NHZE-N1PX
#
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-a/n channel-width=20/40mhz-ht-above country="germany 5.8 fixed p-p" disabled=no frequency=5850 ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 name=wlan1-gateway ssid=Bumsbude
/interface ethernet
set [ find default-name=ether1 ] name=ether1-local
/ip neighbor discovery
set wlan1-gateway discover=no
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=ether1-local name=default
/ip address
add address=192.168.90.20/24 comment="default configuration" interface=ether1-local network=192.168.90.0
add address=192.168.89.20/24 interface=wlan1-gateway network=192.168.89.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=no interface=wlan1-gateway
/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" dns-server=192.168.88.1 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add chain=input comment="default configuration" in-interface=wlan1-gateway
add chain=forward comment="default configuration" connection-state=established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" connection-state=invalid
/ip route
add distance=1 gateway=192.168.89.10
/system leds
set 0 interface=wlan1-gateway
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether1-local
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether1-local
Thee Networks are "clean" connectd using static routes.
No Masquarading on any hop BUT still with same Result ;(

I dont think that its bridge/route related.
No matter what i do i get the same Numbers.
Did i missed something here??

Regards

Who is online

Users browsing this forum: dmcdon and 21 guests