Community discussions

 
n21roadie
Forum Guru
Forum Guru
Topic Author
Posts: 1889
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Internet access or network down customer notification

Mon Jan 20, 2014 6:51 pm

Is it possible rather than redirecting all web requests to an webpage on a web server (using web-proxy) but to use each AP, to inform customers internet or network service is down and the issue is being worked on, or could webfig on each AP be configured to display a service message, be run off scheduler and script to activate routing while access to www or internal network is down. I would hope to avoid calls/texts from customers when this issue(s) occurs
N21roadie,
Network 100% MT for Now?
 
User avatar
rickfrey
Trainer
Trainer
Posts: 610
Joined: Sun Feb 14, 2010 11:41 pm
Location: Van, Texas
Contact:

Re: Internet access or network down customer notification

Tue Jan 21, 2014 9:35 pm

Use can use Netwatch and web-proxy on the CPE. That would be a pretty easy and lightweight solution. There are some great webpages on the Internet that have "Network Up/ Down" that you could use as a template.
Launch your company forward with professional training!
http://rickfreyconsulting.com/product-c ... raining-2/
 
n21roadie
Forum Guru
Forum Guru
Topic Author
Posts: 1889
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Internet access or network down customer notification

Thu Jan 23, 2014 12:05 am

Use can use Netwatch and web-proxy on the CPE. That would be a pretty easy and lightweight solution. There are some great webpages on the Internet that have "Network Up/ Down" that you could use as a template.
I have web-proxy to a webserver for redirect (payment reminder) but how do I configure ROS to act as webserver for my project?
N21roadie,
Network 100% MT for Now?
 
User avatar
rickfrey
Trainer
Trainer
Posts: 610
Joined: Sun Feb 14, 2010 11:41 pm
Location: Van, Texas
Contact:

Re: Internet access or network down customer notification

Fri Jan 24, 2014 6:30 am

When you enable the Webproxy, there will be a directory in the Files folder called "webproxy". The webpage "error.html" is editable. I created a very simple webpage as an example of one to replace it with, but this is just for proof of concept. The webpage that is attached here should be cleaned up and made presentable before it is used in a production setting.

So...here is what we want to do... We want the CPE to determine that it is offline and change the rules to send the web traffic to this internal webpage that says, "The Internet is down. We know and and we're working on it." Then when the Internet comes back up, we want normal service to be restored.

We'll start with the Netwatch settings:
/tool netwatch
add down-script=\
    "/ip firewall nat\r\
    \nset [find comment=Redirect] disabled=no\r\
    \n" host=8.8.8.8 interval=5s up-script=\
    "/ip firewall nat\r\
    \nset [find comment=Redirect] disabled=yes"
Next, we'll add the redirect rule to the firewall to send the traffic to the webproxy:
/ip firewall nat
add action=redirect chain=dstnat comment=Redirect disabled=yes port=80,443 \
    protocol=tcp src-address=0.0.0.0/0 to-ports=8080
Next, we'll turn on the Webproxy:
/ip proxy
set cache-administrator=Admin enabled=yes parent-proxy=0.0.0.0
/ip proxy access
add action=deny dst-address=0.0.0.0/0
These are the settings I used in ROS 6.7. Please, let me know what you think about it :-)
You do not have the required permissions to view the files attached to this post.
Launch your company forward with professional training!
http://rickfreyconsulting.com/product-c ... raining-2/
 
User avatar
rickfrey
Trainer
Trainer
Posts: 610
Joined: Sun Feb 14, 2010 11:41 pm
Location: Van, Texas
Contact:

Re: Internet access or network down customer notification

Fri Jan 24, 2014 6:47 am

You can also enable the SMB Settings and redirect them to a local share.
Launch your company forward with professional training!
http://rickfreyconsulting.com/product-c ... raining-2/
 
n21roadie
Forum Guru
Forum Guru
Topic Author
Posts: 1889
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Internet access or network down customer notification

Thu Jan 30, 2014 11:03 pm

When you enable the Webproxy, there will be a directory in the Files folder called "webproxy". The webpage "error.html" is editable.

These are the settings I used in ROS 6.7. Please, let me know what you think about it :-)
Thanks but using 5.26, with webproxy enabled there is no directory in files called webproxy only pub and skins?
N21roadie,
Network 100% MT for Now?
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: Internet access or network down customer notification

Fri Jan 31, 2014 9:06 am

Do you try Reset HTML in web proxy?
This option will create default html.

Form wiki
Customizing error pages
To customize the page web proxy shows on error:

[admin@MikroTik] > /ip proxy reset-html
Current html pages will be lost! Reset anyway? [y/N]
Answer 'y'. Now HTML files are accessible for editing. (Currently there is only one file: error.html, that contains the error message.)
 
n21roadie
Forum Guru
Forum Guru
Topic Author
Posts: 1889
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Internet access or network down customer notification

Thu Apr 17, 2014 11:23 pm

When you enable the Webproxy, there will be a directory in the Files folder called "webproxy". The webpage "error.html" is editable. I created a very simple webpage as an example of one to replace it with, but this is just for proof of concept. The webpage that is attached here should be cleaned up and made presentable before it is used in a production setting.

So...here is what we want to do... We want the CPE to determine that it is offline and change the rules to send the web traffic to this internal webpage that says, "The Internet is down. We know and and we're working on it." Then when the Internet comes back up, we want normal service to be restored.

We'll start with the Netwatch settings:
/tool netwatch
add down-script=\
    "/ip firewall nat\r\
    \nset [find comment=Redirect] disabled=no\r\
    \n" host=8.8.8.8 interval=5s up-script=\
    "/ip firewall nat\r\
    \nset [find comment=Redirect] disabled=yes"
Next, we'll add the redirect rule to the firewall to send the traffic to the webproxy:
/ip firewall nat
add action=redirect chain=dstnat comment=Redirect disabled=yes port=80,443 \
    protocol=tcp src-address=0.0.0.0/0 to-ports=8080
Next, we'll turn on the Webproxy:
/ip proxy
set cache-administrator=Admin enabled=yes parent-proxy=0.0.0.0
/ip proxy access
add action=deny dst-address=0.0.0.0/0
These are the settings I used in ROS 6.7. Please, let me know what you think about it :-)
Only port 80 webpages are redirected, No https pages are redirected unable to resolve so they just hang, I cleared cache but no luck,
N21roadie,
Network 100% MT for Now?
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: Internet access or network down customer notification

Fri Apr 18, 2014 4:01 pm

netwatch trigger script that enable dst-nat to stub ?
and when uplink back online - netwatch use different script to disable it back ?
 
n21roadie
Forum Guru
Forum Guru
Topic Author
Posts: 1889
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Internet access or network down customer notification

Fri Apr 18, 2014 9:29 pm

netwatch trigger script that enable dst-nat to stub ?
and when uplink back online - netwatch use different script to disable it back ?
Could you explain or give a example how this can be setup for testing?
N21roadie,
Network 100% MT for Now?

Who is online

Users browsing this forum: No registered users and 20 guests