Community discussions

 
achmed
just joined
Topic Author
Posts: 9
Joined: Fri Sep 30, 2011 10:00 pm

Default route unreachable after 10sec

Fri Feb 28, 2014 8:04 pm

I Have a strange problem, and I'm not sure how to troubleshoot it.

Setup:
Mikrotik RB750 <Ethernet cable> Switch - With PCs connected <Ethernet cable> Linksys WRT54GL <Wireless link> Huwei 3G Router

Configuration:
Mikrotik has an IP of 192.168.2.94/24 ,
and a static route 0.0.0.0/0 pointing to Huwei 3G Router at 192.168.2.2
All PCs and the Linksys are in the 192.168.2.0/24 range.

Problem:
PCs use the Mikrotik as Default Gateway.
This works for about 10sec then stops working.
Mikrotik reports "192.168.2.2 Unreachable" under routes and can no longer ping the Huwei router.
Without restarting anything, I change my PCs gateway address to 192.168.2.2 and the internet works again, but the Mikrotik can still not ping the Huwei router.
Restarting the Mikrotik or Huwei Router makes no difference.
But when restarting the Linksys with the PCs still pointing to the Huwei Router, the route on the Mikrotik becomes reachable again.
This then stays fine again for about 10sec, during which I can ping the Huwei Router from the Mikrotik and then fails again.

Any help will be appreciated.
Thanks
 
User avatar
shahbazian
Trainer
Trainer
Posts: 166
Joined: Fri Sep 09, 2011 6:22 pm
Location: Iran
Contact:

Re: Default route unreachable after 10sec

Sat Mar 01, 2014 12:00 am

Hi

You set check-gateway=ping in default route (dst-address=0.0.0.0/0) and your router can't ping 192.168.2.2, Evry 10sec your router do ping 192.168.2.2 and wait for reply but don't receive that ,So reports "192.168.2.2 Unreachable".

You can set check-gateway=arp or do not using check-gateway option.
Learn MikroTik to improve your network.
( MTCNA, MTCRE, MTCWE, MTCTCE, MTCUME, MTCIPv6E, MTCINE )
MikroTik Certified Trainer & Consultant
RIPE NCC Trainer
 
achmed
just joined
Topic Author
Posts: 9
Joined: Fri Sep 30, 2011 10:00 pm

Re: Default route unreachable after 10sec

Mon Mar 03, 2014 8:58 pm

Ok. Removed the "Check Gateway" Option. but this does not fix the problem.
Mikrotik Router can still not ping the 3G router and therefore cant supply internet access to the PCs using it as default gateway.
What doesn't make sense to me is the fact that my PCs can access the 3G Router and use it as default gateway, but the Mikrotik cant even ping it.
It's almost like there is a data loop or network conflict between the Mikrotik and 3G router.
 
achmed
just joined
Topic Author
Posts: 9
Joined: Fri Sep 30, 2011 10:00 pm

Re: Default route unreachable after 10sec

Fri Mar 21, 2014 7:57 pm

Some new info on the problem.

I Have figured out that if I disable the static route 0.0.0.0/0 pointing to Huwei 3G Router at 192.168.2.2, the problem goes away.
The Mikrotik can then ping the 3G Router without any issue.
But as soon as I enable the route again, the 3G router becomes unpingable, and remains that way even if I disable the route again.

Who is online

Users browsing this forum: No registered users and 22 guests