Community discussions

 
iNs
just joined
Topic Author
Posts: 6
Joined: Tue Aug 19, 2014 5:36 pm
Location: Poland

Yet another WiFi connectivity issues

Tue Sep 23, 2014 12:44 pm

I am most definitely aware that there have been similar issues, some of them might have been solved, some not, but since there is no golden solution for this I am quite desperately (to be honest right now) in need of assistance or some kind of help/guidance.

I've seen so many approaches to improving wifi stability that I've got kinda lost in all of this. I did achieve some slight improvement (better CCQ + less disconnects) after lowering the transmit power (setting regulatory domain for my country + all-rates-fixed for my atheros9300 chip and a few other changes like rts/cts settings) but it is still far from gratifying.

It is a single RB2011UiAS-2HnD-IN, with 3 subnets, 2 of them actually in use atm. The client count is around 35 40 generally. Every subnet has its own VAP. If there is a need to post some more information than following, please let me know.

Generally, wifi clients get reassociated and therefore drop the connection, sometimes even every couple of mins. Occasionaly they get group key exchange timeout (they used to get it more often but i changed it to 30mins back then). Sometimes deauth + station leaving occurs. There are quite a few other wifi stations around (office area) but the noise floor level seems to stay around 103 most of the time. The quality of client links varies from ~65 (the ones that have the highest distance to AP) to 40, which isn't that bad after all (is it?).

The chart below shows ccq from last ~12h, the negative spikes are also the moments of client disconnects, however, it doesn't always affect the same clients. (more or less corelated with group key share exchange?!)

Image
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-ht-above \
    country=poland disabled=no distance=indoors frequency=2437 frequency-mode=\
    regulatory-domain hide-ssid=yes hw-protection-mode=rts-cts \
    hw-protection-threshold=256 hw-retries=15 l2mtu=2290 mode=ap-bridge \
    periodic-calibration=disabled ssid="" tx-power-mode=all-rates-fixed
add disabled=no l2mtu=2290 mac-address=xxx master-interface=wlan1 \
    name=wlan2 ssid=xxx wds-cost-range=0 wds-default-cost=0
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" \
    group-key-update=30m mode=dynamic-keys wpa-pre-shared-key=xxx \
    wpa2-pre-shared-key=xxx
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=\
    "xxx" wpa-pre-shared-key=xxx wpa2-pre-shared-key=\
    xxx
add authentication-types=wpa2-psk eap-methods="" group-key-update=30m mode=\
    dynamic-keys name="xxx" supplicant-identity="" \
    wpa2-pre-shared-key=xxx
/interface wireless
add disabled=no l2mtu=2290 mac-address=xxx master-interface=wlan1 \
    name=wlan3 security-profile="xxx" ssid="xxx" \
    wds-cost-range=0 wds-default-cost=0
add disabled=no l2mtu=2290 mac-address=xxx master-interface=wlan1 \
    name=wlan4 security-profile="xxx" ssid="xxx" \
    wds-cost-range=0 wds-default-cost=0
/interface wireless access-list
add ap-tx-limit=2000000 client-tx-limit=1000000 disabled=yes interface=wlan3 \
    time=0s-1d,sun,mon,tue,wed,thu,fri,sat
As I stated before, if someone feels like giving it a thought and needs some further config/stat info please post here and I'll provide it right away.

Thanks in advance.

edit:

another observation is that once dropped, clients cant see any of these VAPs for a brief moment which obviously stops them from reconnecting
 
User avatar
jacekes
Member Candidate
Member Candidate
Posts: 167
Joined: Tue Aug 30, 2011 9:34 am
Location: Poznan, Poland
Contact:

Re: Yet another WiFi connectivity issues

Tue Sep 23, 2014 9:28 pm

Do all the clients disconnect at the same time from all VAP's?
Are there many other networks broadcasted in the surrounding area?
Some details about the place? Office/house/warehouse? How many m^2?

In general, 35 to 40 clients is quite a lot for one radio interface. I would try using a different board with >1 radio interface, for example a RB493. 2 radio interfaces on 2,4 GHz band, first using 1+5 (Ce) channels, second using 9+13 (also Ce). The third radio interface on the 5 GHz band. The same SSID's broadcasted on each interface via VAPs, bridged to proper IP interfaces.
I was certified a long time ago:
MTCNA# 1210NA193 MTCTCE# 1210TCE056 MTCWE# 1211WE010

ONE NETWORK DIAGRAM IS WORTH MORE THAN A THOUSAND WORDS!
 
lambert
Long time Member
Long time Member
Posts: 533
Joined: Fri Jul 23, 2010 1:09 am

Re: Yet another WiFi connectivity issues

Wed Sep 24, 2014 6:43 am

What is the CPU utilization of the RB2011? The bandwidth flowing across the wireless interface? Other interfaces?

My thinking is that it could be too busy to get to the group key renegotiation in time. Just a wild guess based on no real data. I don't do much MikroTik wireless.

Have you tried setting the distance to something other than indoors? In my house, the distance is set to dynamic. It seems to work for my 6 devices.

Have you tried not hiding the ssid? Have you tried letting one of the networks be on the physical card, wlan1, rather than a VAP? I have always used the card for my primary network and only use VAPs for secondary networks.

If you do not utilize more than 50Mbps on the wireless, you may want to go to a 20MHz wide channel and take the extra 3 dB of signal increase from your client devices.
 
iNs
just joined
Topic Author
Posts: 6
Joined: Tue Aug 19, 2014 5:36 pm
Location: Poland

Re: Yet another WiFi connectivity issues

Wed Sep 24, 2014 11:10 am

Thank you for replies.
Do all the clients disconnect at the same time from all VAP's?
Are there many other networks broadcasted in the surrounding area?
Some details about the place? Office/house/warehouse? How many m^2?

In general, 35 to 40 clients is quite a lot for one radio interface. I would try using a different board with >1 radio interface, for example a RB493. 2 radio interfaces on 2,4 GHz band, first using 1+5 (Ce) channels, second using 9+13 (also Ce). The third radio interface on the 5 GHz band. The same SSID's broadcasted on each interface via VAPs, bridged to proper IP interfaces.
Amount of clients disconnecting varies. Sometimes it's basically all of them, sometimes just a few. There are also clients that hardly ever disconnect.
In terms of location, it is office area (my wifi has to cover around 90 m^2) and there are at least 10 other 2,4ghz networks. After reading quite a lot about the subject, I came to a similar conclusion - more than 1 access point, but, what if I combined 2011 + AP per room, for example? Benchmarks suggest it would probably handle that. What do you think?

What is the CPU utilization of the RB2011? The bandwidth flowing across the wireless interface? Other interfaces?

My thinking is that it could be too busy to get to the group key renegotiation in time. Just a wild guess based on no real data. I don't do much MikroTik wireless.

Have you tried setting the distance to something other than indoors? In my house, the distance is set to dynamic. It seems to work for my 6 devices.

Have you tried not hiding the ssid? Have you tried letting one of the networks be on the physical card, wlan1, rather than a VAP? I have always used the card for my primary network and only use VAPs for secondary networks.

If you do not utilize more than 50Mbps on the wireless, you may want to go to a 20MHz wide channel and take the extra 3 dB of signal increase from your client devices.

Here is the CPU load from the same period as the CCQ graph.

Image

The wireless bandwith varies - depending on the activity, whether it is internet traffic (8 mbps for now - I know it's not a lot :P) or internal traffic (filesharing).

Testing indoors/dynamic didn't really make a difference forme. The SSID's are not hidden and the combination with primary wifi and one sub-vap is a no go for me. I have separate, isolated subnets with bridges. In terms of bandwith utilization, you might have missed something in the post, but there is around 40 devices at the moment, at least half have of them share data either between themselves or through our internal filesharing server - so yes - we do utilize the internal bandwith.
 
lambert
Long time Member
Long time Member
Posts: 533
Joined: Fri Jul 23, 2010 1:09 am

Re: Yet another WiFi connectivity issues

Wed Sep 24, 2014 11:42 am

The wireless bandwith varies - depending on the activity, whether it is internet traffic (8 mbps for now - I know it's not a lot :P) or internal traffic (filesharing).

Testing indoors/dynamic didn't really make a difference forme. The SSID's are not hidden and the combination with primary wifi and one sub-vap is a no go for me. I have separate, isolated subnets with bridges. In terms of bandwith utilization, you might have missed something in the post, but there is around 40 devices at the moment, at least half have of them share data either between themselves or through our internal filesharing server - so yes - we do utilize the internal bandwith.
Your primary interface can be on one of those isolated bridges as easily as a VAP can. But that may be immaterial to your problem. It was just a thought.

If your users are passing enough traffic in and out of the wireless interface, there could simply be too much traffic at random intervals leading to dropped packets and timeouts. Without graphs of wireless interface utilization, this is more guessing. That would not be a MikroTik problem, just a wireless problem. More APs might be able to reduce the traffic per AP to allow them to take care of the housekeeping. But with file sharing activity, more bandwidth might simply be sucked up by the activity of the users.

Running an AP per room could work if you plan your frequencies very carefully and reduce power by enough. That will be difficult with 40MHz wide channels. But the client devices will still be hearing each other's traffic if they can all talk to the AP now. Two or three APs, at remote corners of the field with direction antennas to ignore outside noise, might be easier to manage. A faraday cage around each AP's coverage area would help performance within the area. :-)
 
iNs
just joined
Topic Author
Posts: 6
Joined: Tue Aug 19, 2014 5:36 pm
Location: Poland

Re: Yet another WiFi connectivity issues

Wed Sep 24, 2014 12:20 pm

The wireless bandwith varies - depending on the activity, whether it is internet traffic (8 mbps for now - I know it's not a lot :P) or internal traffic (filesharing).

Testing indoors/dynamic didn't really make a difference forme. The SSID's are not hidden and the combination with primary wifi and one sub-vap is a no go for me. I have separate, isolated subnets with bridges. In terms of bandwith utilization, you might have missed something in the post, but there is around 40 devices at the moment, at least half have of them share data either between themselves or through our internal filesharing server - so yes - we do utilize the internal bandwith.
Your primary interface can be on one of those isolated bridges as easily as a VAP can. But that may be immaterial to your problem. It was just a thought.

If your users are passing enough traffic in and out of the wireless interface, there could simply be too much traffic at random intervals leading to dropped packets and timeouts. Without graphs of wireless interface utilization, this is more guessing. That would not be a MikroTik problem, just a wireless problem. More APs might be able to reduce the traffic per AP to allow them to take care of the housekeeping. But with file sharing activity, more bandwidth might simply be sucked up by the activity of the users.

Running an AP per room could work if you plan your frequencies very carefully and reduce power by enough. That will be difficult with 40MHz wide channels. But the client devices will still be hearing each other's traffic if they can all talk to the AP now. Two or three APs, at remote corners of the field with direction antennas to ignore outside noise, might be easier to manage. A faraday cage around each AP's coverage area would help performance within the area. :-)

I agree it looks like 'rather wireless than mikrotik' issue, since beside wireless i really like the platform itself and it works well.
If, and i say IF, AP per room considered, any suggestions what gear in particular would/could do the job? Lets say i want to go a little futureproof mode, and handle at least 20 devices per AP?

ps. Faraday cage, in my dreams :(
 
User avatar
jacekes
Member Candidate
Member Candidate
Posts: 167
Joined: Tue Aug 30, 2011 9:34 am
Location: Poznan, Poland
Contact:

Re: Yet another WiFi connectivity issues

Wed Sep 24, 2014 4:01 pm

After reading quite a lot about the subject, I came to a similar conclusion - more than 1 access point, but, what if I combined 2011 + AP per room, for example? Benchmarks suggest it would probably handle that. What do you think?
I guess it's a good idea.
I was certified a long time ago:
MTCNA# 1210NA193 MTCTCE# 1210TCE056 MTCWE# 1211WE010

ONE NETWORK DIAGRAM IS WORTH MORE THAN A THOUSAND WORDS!
 
lambert
Long time Member
Long time Member
Posts: 533
Joined: Fri Jul 23, 2010 1:09 am

Re: Yet another WiFi connectivity issues

Thu Sep 25, 2014 3:07 am

I agree it looks like 'rather wireless than mikrotik' issue, since beside wireless i really like the platform itself and it works well.
If, and i say IF, AP per room considered, any suggestions what gear in particular would/could do the job? Lets say i want to go a little futureproof mode, and handle at least 20 devices.
The number of devices per AP depends, mostly on the devices and usage habits of the users. I have a lot of towers where 35 connections per AP work well. On others, 10 users can fully utilize the airtime.

Who is online

Users browsing this forum: Google [Bot] and 23 guests