Page 1 of 1

RB112 useless after upgrade to 2.9.25 broken package I guess

Posted: Sat Jun 10, 2006 8:15 pm
by boardman
I upgraded one RB112 from 2.9.24 to 2.9.25 and now its not working any suggestions how to fix this mess?

I guess the package was broken, now how do I fix it?

Here's the terminal output

Reboot, yes? [y/N]:
system will reboot shortly

Rebooting...
Stopping services...
ERROR: installation of routeros-rb500-2.9.25 failed: broken package132
WARNING: package system-2.9.25 onuninstall script failed
11 packets tra
/etc/rc.d/rc.stop: 34: /etc/rc.d/rc.postinstall: not found
round-trip m
/etc/rc.d/rc.stop: 36: /bin/umount: not found

Now it keeps rebooting:
RouterBOOT booter 1.13

RouterBoard 112

CPU frequency: 175 MHz
Memory size: 16 MB

Press any key within 1 seconds to enter setup.
kernel not found
trying bootp protocol..........................................................d
kernel loading failed
C¡HHõÕÑ•É ==Q

Posted: Sat Jun 10, 2006 8:34 pm
by sergejs
try to reinstall your board using netinstall.

Thks sergejs that did the trick

Posted: Sat Jun 10, 2006 11:36 pm
by boardman
Thks a lot sergejs, that did the trick.

Why mikrotik does not ZIP the .npk?

Posted: Sun Jun 11, 2006 6:09 pm
by boardman
Does anybody has an idea why Mikrotik guys does not ZIP .npk files in order to avoid this "damaged" packages downloads in the future?

Is a lot easier to re-download a damaged ZIP that netinstall again a router, dont you think so?

Best

Jorge

Posted: Sun Jun 11, 2006 7:23 pm
by sergejs
Jorge, there are alreade zip package for both version x86 and 'ns'.

Posted: Mon Jun 12, 2006 7:59 am
by DirectWireless
I had to netinstall 3 2.9.18 to 2.9.25 upgrades this week on RB112's. I did not change the file or redownload it, it worked on 3 of them, and 3 of them it failed on. Some I used FTP, others I used Winbox drag and drop, and it didn't seem to matter (3 good ones were combinations of both also), and 1 was lost with a direct ethernet connection.

All the same downloaded file. Does MT have a checksum on the NPK file, or does it blindly install it?

Posted: Mon Jun 12, 2006 8:44 pm
by boardman
Thks sergejs, but I guess you mean the "all packages" file isnt it?

And I guess the file that is or was damaged was the one hosted at Mikrotiks USA server; because I downloaded it again and upgrade again the RB112 and had the same result, then I tried to netinstall that same .npk and netinstall crashed, then I downloaded the .npk from Latvia server and everything just went OK.


Best

Jorge

Posted: Mon Jun 12, 2006 11:08 pm
by DirectWireless
That does make sense, I think I might have redownloaded the file after I had a problem from the first one now that you mention it.

Posted: Tue Jun 13, 2006 1:48 pm
by nowoxi
well personnally i usually upgrade with ftp clients like smartftp other methods always give me some sort of error or the other. you guys should try that out too

Posted: Tue Jun 13, 2006 6:54 pm
by boardman
Well ... it was upgraded using a FTP client....
The Netinstall method was used after the routerOS got screwed up by the damaged .npk file.

Best

Jorge Boardman