Community discussions

 
vsabolc
just joined
Topic Author
Posts: 5
Joined: Fri Dec 12, 2014 10:06 am

Wireless speed issue on RB2011UiAS-2HnD

Fri Dec 12, 2014 10:34 am

Hi,

I have a RB2011UiAS-2HnD mikrotik with RouterOS 6.23. My internet connection is 100MBit and when using LAN I'm getting the correct speed, but when connected via wireless, the speed is not higher than 35MBit.

Connected a Dlink wireless router and with this router got 60Mbit, but with Mikrotik wireless got max 35mbit.

Tried to connect with many devices which are supporting the wireless N standard, but the speed was the same, not higher than 35Mbit.
Checked the forum about the similar issues with wireless, and tried everything what was there, but still no better speed over wifi.

In Registration table there are TX/RX rates like; 115Mbps/117Mbps, 58.5Mbps/58.5Mbps,and lower values

Here is my wireless setup

# dec/12/2014 09:18:53 by RouterOS 6.23
# software id = K3PG-JWND
#
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n basic-rates-a/g=\
6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b=\
1Mbps,2Mbps,5.5Mbps,11Mbps channel-width=20/40mhz-ht-above country=serbia \
disabled=no frequency=2432 l2mtu=2290 mode=ap-bridge ssid=#########
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
dynamic-keys wpa-pre-shared-key=######### wpa2-pre-shared-key=\
#########

Can anybody help what can I change to get higher wireless speed?

Thanks.
 
Quindor
Member
Member
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: Wireless speed issue on RB2011UiAS-2HnD

Fri Dec 12, 2014 2:51 pm

- Can you check if you have enabled both chains for send and receive on the wireless properties?
- Can you check if you client actually connects with 40Mhz and not just 20Mhz? You can see this at registration and then the channel and type it select
- In the same window you should be able to see Signal to Noise ratio, this value is interesting too
- Did you do a channel survey to see which channel could best be used?

With an RB2011 I have been able to achieve around 110Mbit/s to 120Mbit/s of actual throughput. This is the absolute max though. But something like 80Mbit/sec or more should be easily achievable, even with some walls, etc.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
vsabolc
just joined
Topic Author
Posts: 5
Joined: Fri Dec 12, 2014 10:06 am

Re: Wireless speed issue on RB2011UiAS-2HnD

Fri Dec 12, 2014 3:07 pm

- Can you check if you have enabled both chains for send and receive on the wireless properties?
- Can you check if you client actually connects with 40Mhz and not just 20Mhz? You can see this at registration and then the channel and type it select
- In the same window you should be able to see Signal to Noise ratio, this value is interesting too
- Did you do a channel survey to see which channel could best be used?

With an RB2011 I have been able to achieve around 110Mbit/s to 120Mbit/s of actual throughput. This is the absolute max though. But something like 80Mbit/sec or more should be easily achievable, even with some walls, etc.

1 - Both chain is enabled
2 - I think the client connects with 20Mhz, not with 40 Mhz - I'm not sure with this
3 - Signal to Noise: values from 15 to 40dB
4 - using the channel not used by other networks

Checked the wireless connection inside the same room where is the RB2011 and in different location(1 wall), got the same result.
 
Quindor
Member
Member
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: Wireless speed issue on RB2011UiAS-2HnD

Tue Dec 16, 2014 1:19 pm

Hmm, that signal to noise ratio is pretty low. In the same room you should at least be able to achieve something like 60dB. It could be the cause that your client is not connecting any stronger.

Do all your devices share the same low speed and Signal to noise? Things like your smartphone, etc.?

About the 20Mhz and 40Mhz. When you check in the routerboard under wireless --> registration --> click on client. In that window you can see bars and "last used" and it says either 20Mhz or 40Mhz, etc.. But there seems to be another reason why your client isn't connecting very fast. Better speeds require a better signal to noise ratio.

In room or with 1 wall in between should not make too big of a difference with 2.4Ghz.

Please check with different clients and see if you still get such low Signal to noise values.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
vsabolc
just joined
Topic Author
Posts: 5
Joined: Fri Dec 12, 2014 10:06 am

Re: Wireless speed issue on RB2011UiAS-2HnD

Tue Dec 16, 2014 2:33 pm

Thanks for the reply!

All devices has low values of the Signal to noise, values from 10 to 45 max(smartphones, laptops).

As I can see they are connected on 20MHz.
 
Bonz123
just joined
Posts: 15
Joined: Tue Dec 02, 2014 8:26 pm
Location: LV

Re: Wireless speed issue on RB2011UiAS-2HnD

Tue Dec 16, 2014 3:00 pm

i think it works on b or g standatrt Just change to n only. speed will bee aprox 80.
 
vsabolc
just joined
Topic Author
Posts: 5
Joined: Fri Dec 12, 2014 10:06 am

Re: Wireless speed issue on RB2011UiAS-2HnD

Tue Dec 16, 2014 3:05 pm

Changed to N only, but nothing was changed, it does not give better results, got the same values.
 
Bonz123
just joined
Posts: 15
Joined: Tue Dec 02, 2014 8:26 pm
Location: LV

Re: Wireless speed issue on RB2011UiAS-2HnD

Tue Dec 16, 2014 3:34 pm

save backup and try to reset.
 
Quindor
Member
Member
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: Wireless speed issue on RB2011UiAS-2HnD

Tue Dec 16, 2014 3:39 pm

Hmm, odd, if all your devices seem to get a bad signal to noise ratio it would suggest maybe you RB2011 is faulty in some way. Maybe you could try opening it up and unplugging and then re-plugging in the antenna's to see if that might make a difference.

Setting to only-N should make no difference in this situation. You could try a reset as suggested, but that won't do much for your Signal to noise either I'm afraid.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
vsabolc
just joined
Topic Author
Posts: 5
Joined: Fri Dec 12, 2014 10:06 am

Re: Wireless speed issue on RB2011UiAS-2HnD

Tue Dec 16, 2014 3:44 pm

Thanks for reply!

I will try to reset the device in day or two and will come back with the results!

Thanks!
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: Wireless speed issue on RB2011UiAS-2HnD

Wed Dec 17, 2014 12:41 pm

Try enabling the wireless-fp package and also try to align the RB2011 antennas differently so each antenna would be in different polarization.

Who is online

Users browsing this forum: No registered users and 35 guests