Community discussions

MUM Europe 2020
 
kenth
just joined
Topic Author
Posts: 18
Joined: Sun Oct 05, 2014 8:17 am

Apple wifi issues: data from unknown device, sent deauth

Fri Dec 26, 2014 12:29 pm

I'm having wifi issues with Apple devices (ipads and iphones). I believe the Apple devices enters some micro-sleep causing Mikrotik to disconnect them. A typical log looks like the following:

10:48:01 wireless,info xx:xx:xx:xx:xx:xx@wlan1: connected
10:48:51 wireless,info xx:xx:xx:xx:xx:xx@wlan1: disconnected, extensive data loss
10:52:00 wireless,info wlan1: data from unknown device xx:xx:xx:xx:xx:xx, sent deauth
10:52:00 wireless,info wlan1: data from unknown device xx:xx:xx:xx:xx:xx, sent deauth
10:52:00 wireless,info wlan1: data from unknown device xx:xx:xx:xx:xx:xx, sent deauth
10:52:00 wireless,info wlan1: data from unknown device xx:xx:xx:xx:xx:xx, sent deauth
10:52:00 wireless,info wlan1: data from unknown device xx:xx:xx:xx:xx:xx, sent deauth
10:52:00 wireless,info wlan1: data from unknown device xx:xx:xx:xx:xx:xx, sent deauth
10:52:01 wireless,info xx:xx:xx:xx:xx:xx@wlan1: connected

This happens for all versions of Mikrotik 6.x that I have tried. The iOS devices are running 7.x and 8.x.

I have tried to adjust various settings, but none of them have improved the situation. The following tuning parameters have been adjusted:

adaptive-noise-immunity
hw-retries
signal-range
distance
disconnect-timeout
preamble (long)

Can Mikrotik support recommend settings that will work well with Apple devices?
 
plisken
Forum Guru
Forum Guru
Posts: 2433
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Apple wifi issues: data from unknown device, sent deauth

Fri Dec 26, 2014 2:50 pm

Take export from your wireless settings and paste this on this forum please.

which SSID do you use?
 
kenth
just joined
Topic Author
Posts: 18
Joined: Sun Oct 05, 2014 8:17 am

Re: Apple wifi issues: data from unknown device, sent deauth

Fri Dec 26, 2014 3:13 pm

/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode band=2ghz-b/g/n channel-width=20/40mhz-ht-above \
default-authentication=no disabled=no disconnect-timeout=10s distance=indoors hw-protection-mode=rts-cts \
l2mtu=2290 mode=ap-bridge ssid=xxx wireless-protocol=802.11
/interface wireless security-profiles
add authentication-types=wpa2-psk mode=dynamic-keys name=wlan-lan-profile wpa2-pre-shared-key=xxx
add authentication-types=wpa2-psk mode=dynamic-keys name=wlan-guest-profile wpa2-pre-shared-key=xxx
/interface wireless
add disabled=no l2mtu=2290 mac-address=xx:xx:xx:xx:xx:xx master-interface=wlan1 name=wlan1-guest security-profile=\
wlan-guest-profile ssid=xxx
add default-authentication=no disabled=no l2mtu=2290 mac-address=xx:xx:xx:xx:xx:xx master-interface=wlan1 name=wlan1-lan \
security-profile=wlan-lan-profile ssid=xxx

The SSIDs are standard names (A-z), no special characters.

Note: we have other wifi devices on the network (Android, Windows, Linux), but none of them show this symptom.
 
plisken
Forum Guru
Forum Guru
Posts: 2433
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Apple wifi issues: data from unknown device, sent deauth

Fri Dec 26, 2014 3:33 pm

Weird, everything seems to be fine
 
User avatar
maximan
Trainer
Trainer
Posts: 549
Joined: Sat May 29, 2004 12:10 am
Location: Rio Cuarto, Argentina
Contact:

Re: Apple wifi issues: data from unknown device, sent deauth

Fri Dec 26, 2014 4:28 pm

are you using aes or tkip? what is the group update key?

check at the final of this topic

http://forum.mikrotik.com/viewtopic.php ... 0&start=50

M.
MKE Solutions > Professional Support IT (Spanish / English)
FastNetMon / FNM Manager: DDoS Detection Tools.
 
kenth
just joined
Topic Author
Posts: 18
Joined: Sun Oct 05, 2014 8:17 am

Re: Apple wifi issues: data from unknown device, sent deauth

Fri Dec 26, 2014 5:03 pm

I'm using aes-ccm. The group key update interval is 5 minutes.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3428
Joined: Mon May 31, 2004 2:55 pm

Re: Apple wifi issues: data from unknown device, sent deauth

Mon Dec 29, 2014 4:47 pm

please try to enable the wireless-fp package.
 
kenth
just joined
Topic Author
Posts: 18
Joined: Sun Oct 05, 2014 8:17 am

Re: Apple wifi issues: data from unknown device, sent deauth

Mon Jan 05, 2015 5:48 pm

Can I keep my existing wireless settings and just enable wireless-fp? Is it possible to revert the change by disabling the package (e.g. system package disable wireless-fp)?
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: Apple wifi issues: data from unknown device, sent deauth

Fri Jan 09, 2015 11:11 pm

Can I keep my existing wireless settings and just enable wireless-fp? Is it possible to revert the change by disabling the package (e.g. system package disable wireless-fp)?
yes and yes
 
kenth
just joined
Topic Author
Posts: 18
Joined: Sun Oct 05, 2014 8:17 am

Re: Apple wifi issues: data from unknown device, sent deauth

Mon Jan 12, 2015 5:55 pm

It seems as this appen for newer Apple IOS devices. iPhone 4s does not give this problem, but iPhone 5s and iPad Mini v2 does. Perhaps a newer wifi chipset with new power save functionality gives problem with Mikrotik implementation?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24366
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Apple wifi issues: data from unknown device, sent deauth

Tue Jan 13, 2015 1:07 pm

It seems as this appen for newer Apple IOS devices. iPhone 4s does not give this problem, but iPhone 5s and iPad Mini v2 does. Perhaps a newer wifi chipset with new power save functionality gives problem with Mikrotik implementation?
we have not seen such issues with our "newer apple devices", so please enable wireless-fp and debug logs, and see what is going on in there when you use the new package
No answer to your question? How to write posts
 
kenth
just joined
Topic Author
Posts: 18
Joined: Sun Oct 05, 2014 8:17 am

Re: Apple wifi issues: data from unknown device, sent deauth

Sun Sep 20, 2015 11:39 am

I still see logs fill up with these messages with wireless-fp as well. I can see it appearing with iOS 8.4 as well as 9.0 and RouterOS 6.31.
 
gryphraff
just joined
Posts: 12
Joined: Tue Apr 01, 2014 6:14 pm

Re: Apple wifi issues: data from unknown device, sent deauth

Mon Jul 11, 2016 3:26 pm

I've seen this too - it happens every time an iOS device goes to sleep. In this case, I'm running an iPod Touch and an iPad Air with iOS7, connecting to a new RB951G with the latest OS. It's running as a switch with wireless AP, as routing is provided by a RB2011 in another rack. Syslog fills up with this:
2 192.168.1.42 wireless,info B0:34:95:xx:xx:xx@wlan1: disconnected, extensive data loss
39 192.168.1.42 wireless,info wlan1: data from unknown device B0:34:95:xx:xx:xx, sent deauth
1 192.168.1.42 wireless,info B0:34:95:xx:xx:xx@wlan1: connected
In the example, there were 39 deauth requests sent within a few minutes, which completely shut down the wireless portion of my network.

Interestingly enough, when I watch the signal indicators in Webfig/Quick Set, I see the Apple devices actually drop off the network - that is, IP address disappears from the list. The lease is still good - they have static DHCP leases assigned by a remote router. Other devices, such as an android phone, will sleep but do not reject their address. All wireless devices are in ACL, and ACL is in use.

I seem to remember something from the original iPad days where networks would be flooded with address requests from devices, perhaps this has something to do with it? In any event, I can't use the device as is. It's currently boxed up for return, but I'd love to keep it. Is there a fix?
 
kenth
just joined
Topic Author
Posts: 18
Joined: Sun Oct 05, 2014 8:17 am

Re: Apple wifi issues: data from unknown device, sent deauth

Fri Jul 22, 2016 9:01 pm

I still see these kind of logs as well. I'm running 6.35.4 with wireless-cm2 package. 

Who is online

Users browsing this forum: No registered users and 28 guests