Community discussions

 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

High packet loss on WiFi interface in ROS 6.24

Thu Jan 08, 2015 2:58 pm

I've noticed that after an upgrade to 6.24 I've got a pretty annying packet loss in the WiFi network. They reach up to 20% percent!
I'm testing in parallel from a Linux machine and from another Mikrotik router, connected to the Access Point (RB951G-2HnD).
In the log I see that both wireless clients are loosing packets at the very same time. It's like something is happening on the AP and it stops servicing traffic for a while, than it resumes.
Otherwise the router is reachable from the outside interface, the utilization is pretty low, so it does not seem to be an issue with a router too busy to service wireless requests.
How to troubleshoot this?
I have a server behind the Mikrotik router that I use regularly, and it's kind of annoying as my connecting getts stuck every now and then. And again, the lost packet ration is up to 20%! That's really high!
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: High packet loss on WiFi interface in ROS 6.24

Thu Jan 08, 2015 3:10 pm

I forgot to mention that the ping reply times are horible too! The jitter is way beyond 30ms!
The response times are between 0 and 80ms. For a small, not utilized WiFi network I believe this is pretty high. And again, it's only the WiFi interface that is showing this problem. Everyhing else is working just fine.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: High packet loss on WiFi interface in ROS 6.24

Thu Jan 08, 2015 3:22 pm

could you tell us from what RouterOS you upgraded to v6.24?
What wireless package are you using - regular wireless or wireless-fp package?
Could you try to reset the wireless interface configuration and use the default settings from the wireless interface?
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: High packet loss on WiFi interface in ROS 6.24

Thu Jan 08, 2015 3:29 pm

Thank you for your quick responce udilis.
1. I update regularly, so the previous version of the RouterOS was 6.23
2. I use just the regular wireless package.
3. Regarding the settings, I didn't really messed with them when I first installed the router. I set it to 802.11n, set SSID and a password.
Here's an output of my configuration:
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-ht-above comment=LAN country=bulgaria disabled=no \
distance=indoors frequency=2462 l2mtu=2290 mode=ap-bridge ssid=prostor wds-default-bridge=bridge-local wds-mode=static \
wireless-protocol=802.11
/interface wireless manual-tx-power-table
set wlan1 comment=LAN
/interface wireless nstreme
set wlan1 comment=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk group-ciphers=tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=<password-hidden> wpa2-pre-shared-key=<password-hidden>
add authentication-types=wpa2-psk group-ciphers=tkip,aes-ccm mode=dynamic-keys name=profile supplicant-identity=MikroTik_main \
unicast-ciphers=tkip,aes-ccm wpa-pre-shared-key=guestWiFipassword wpa2-pre-shared-key=guestWiFipassword
/interface wireless
add disabled=no l2mtu=2290 mac-address=D6:CA:6D:99:F5:5B master-interface=wlan1 name=wlan2 security-profile=profile ssid=\
prostor_guest
/interface wireless access-list
add ap-tx-limit=128 interface=wlan2

Is there a way to reset the wireless interface with a command, to make sure that it's really resetted to the default settings?
I could do that...
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: High packet loss on WiFi interface in ROS 6.24

Thu Jan 08, 2015 3:42 pm

in v6.23 it was working ok? There are no big changes in the regular wireless packages between v6.23 and v6.24.

First suggestion is to use ht-below setting as 2462 can't be used for above setting:
http://en.wikipedia.org/wiki/IEEE_802.1 ... 4.C2.A0GHz

Second suggestion is to disable the TKIP option and use only AES option.

Other configuration looks ok.

Are you using WDS for the clients?
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: High packet loss on WiFi interface in ROS 6.24

Thu Jan 08, 2015 4:34 pm

Yes, I didn't notice such drops in version 6.23.
I tried both suggestions, no luck. It's the same, the drop rate is around 16-17%
No I do not use WDS at the moment, it's a residual configuration, that I used in the past. I disabled WDS.
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: High packet loss on WiFi interface in ROS 6.24

Thu Jan 08, 2015 4:36 pm

I forgot, here are the current settings:
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-ht-below comment=LAN country=bulgaria disabled=no \
distance=indoors frequency=2462 l2mtu=2290 mode=ap-bridge ssid=prostor wds-default-bridge=bridge-local wireless-protocol=\
802.11
/interface wireless manual-tx-power-table
set wlan1 comment=LAN
/interface wireless nstreme
set wlan1 comment=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=<pasword-hidden> \
wpa2-pre-shared-key=<password-hidden>
add authentication-types=wpa2-psk mode=dynamic-keys name=profile supplicant-identity=MikroTik_main wpa-pre-shared-key=\
guestWiFipassword wpa2-pre-shared-key=guestWiFipassword
/interface wireless
add disabled=no l2mtu=2290 mac-address=D6:CA:6D:99:F5:5B master-interface=wlan1 name=wlan2 security-profile=profile ssid=\
prostor_guest
/interface wireless access-list
add ap-tx-limit=128 interface=wlan2
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: High packet loss on WiFi interface in ROS 6.24

Thu Jan 08, 2015 4:43 pm

And one thing that strikes me is that in the parallel tests I run constantly, whenever there's are packets lost/unserviced/or whatever the reason, it all happens simultaineasly on both clients! Is this normal to have such a behaviour in situations like this?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: High packet loss on WiFi interface in ROS 6.24

Thu Jan 08, 2015 4:57 pm

could you please write to support@mikrotik.com with a support output file which is made during the time you have the packet loss?
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: High packet loss on WiFi interface in ROS 6.24

Thu Jan 08, 2015 5:13 pm

uldis,
I'm not sure that I'll catch the exact time when the drop happens to generate the suppout file.
1. It is sporadic
2. It briefly happens. So when I start continious pings to the router from the clients, I've got 3-4 pings lost here and there.
3. I'm also wirelesslly connected to the router, so at the brief times there's a connection outage - I cannot control the router. Well I can overcome that by generating the suppout file while I'm in the office and access the router from the outbound interface. But again, it would be hard to hit the exact moment the packet drops are happening...

Would it suffice to have a suppout file genarated while the continious ping is running?
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: High packet loss on WiFi interface in ROS 6.24

Fri Jan 09, 2015 9:12 am

Just a quick update on this.
Last night I did a more extensive troubleshooting on this. I used the WiFi Analyser application on my phone to check how the channels are used, and boy, it's quite crowded! I changed the channel several times with very little improvement of the overal packet drops, so I settled for the last available channel at the very end of the spectrum - 13. The improvement is tangable:
1. The response times have improved considerably. Now the average rtt is about 2ms. Maximum rtt around 50ms.
2. The packet drops are up to 3%
And all of this figures I've got after extensive pings overnight, to get a more statistically sound result.

I don't think that the software upgrade is to be blamed, it's more or less a coinsidence that after the upgrade new noise sources were available.
I still want to improve the figures though. I belive that the packet drops should be below 1%, or maximum 1%. In order to achieve that though, unfortunatelly I have to reposition the router :(
Right now the router is in the doorway, right above the front door of my appartment. I could move it closer to the center of the appartment and the end hosts, it's about 5 meters.
Could you guys comment on what kind of a performance you have in your home WiFi environments? I'm interested to see whether the goal I'm setting 1% packet loss or less is achieveable. I hope it is :)
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: High packet loss on WiFi interface in ROS 6.24

Fri Jan 09, 2015 10:36 am

usually there are no packet drops just the ping response is more than 1000ms.
The latency could also increase then the wireless client is in a powersaving mode.
Try to use only 20mhz channel width so you would not be affected by the wireless interference from the nearby APs.
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: High packet loss on WiFi interface in ROS 6.24

Fri Jan 09, 2015 5:06 pm

I will certainly try that. One question though. Wouldn't using a strictly 20MHz channel limit the performance? As theory goes, the wider the band, the higher the achieveable speed... I guess in my case I do not get too much of an improvement, as the nearby channels are already quite congested.
Also, another point. As I mentioned, I plan in the recent days to move the router closser to the center of my flat, and in that way - closer to the end clients. This should improve the performance, as it will increase the SNR, or at least I hope so...:)
 
BAND1C00T
just joined
Posts: 13
Joined: Sun Jan 18, 2015 4:49 am

Re: High packet loss on WiFi interface in ROS 6.24

Sun Jan 18, 2015 5:24 am

I have the same problem but from day1 using, firmware was 5.** and still very bad.
after 3-5seconds after connection it starts to loss packets and 1000+ms ping
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: High packet loss on WiFi interface in ROS 6.24

Mon Jan 19, 2015 6:44 pm

Have you by any chance looked at the spectrum? Nowadays the 2.4Ghz spectrum is just too crowded!
Fortunatelly you have a very convenient option - WiFi Analysier Android App.
With it, you can scan the spectrum and analyse where it's less crowded. Than you'll just have to move the channel. This is what I did, and with that I was able to minimize the latency and packet loss (at the moment less than 1%).
I want to improve it even further, so I'll reposition the router and by the end of the month I'll add a 5GHz router, my IntelNUC has a dual band WiFi card, so I would like to see how it would work in the 5GHz band. Hopefully it will be less crowded.
 
BAND1C00T
just joined
Posts: 13
Joined: Sun Jan 18, 2015 4:49 am

Re: High packet loss on WiFi interface in ROS 6.24

Mon Jan 19, 2015 8:16 pm

on my channel is only 1-2 AP.
even if i come close to AP nothing happened, its AP problem.
 
lz1dsb
Member Candidate
Member Candidate
Topic Author
Posts: 222
Joined: Wed Aug 07, 2013 11:48 am

Re: High packet loss on WiFi interface in ROS 6.24

Wed Jan 21, 2015 2:19 pm

Well, than it's a different scenario. It could be a faulty radio module.

Who is online

Users browsing this forum: No registered users and 19 guests