Community discussions

MikroTik App
 
m0kct
just joined
Topic Author
Posts: 17
Joined: Sat Mar 17, 2012 1:55 am

Cisco wifi phone issues

Sat Jan 17, 2015 1:31 am

Hello,

I have a RB751U-2HnD running 6.23 which I'm using as a wifi AP. I have recently acquired a Cisco WIP-310 wifi SIP phone and I'm having some interesting problems.

It connects to a virtual-AP interface on the 751, with WPA2-PSK. When it tries to make or receive a call, its network seems to disappear: as soon as I see lots of RTP traffic going to it in tcpdump, I can no longer ping the phone, except for some occasional short bursts (when audio also appears briefly) with huge latency (many seconds). As soon as I hang up, pings go back to normal. I have also seen some occasional dupes when pinging it for an extended period of time.

I have put a laptop on the same SSID and making calls from it via the same voice server works fine. I have also put the phone on a different wifi network (a Linux box running hostapd with a USB wifi dongle, also with WPA2-PSK) and on this network, it works fine!

The latter suggests to me that there is some kind of wifi incompatibility between the phone and the 751, or some other RouterOS issue. I have other wireless devices using the 751 as their AP, and they seem to work fine.

I have upgraded the phone to the latest firmware and I have tried changing the channel and disabling 802.11n on the 751. None of this has had any effect.

Has anyone seen anything similar? Are there any options I can tweak on the wireless interface on the 751 to try and fix this? (There are no wifi options on the phone beyond the basic settings.)

Let me know if you need more information.

Thanks in advance!


Alex

-----
Wireless config:
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-eap mode=dynamic-keys name=ssid1 \
    radius-eap-accounting=yes radius-mac-accounting=yes
add authentication-types=wpa2-psk mode=dynamic-keys name=ssid2 \
    radius-mac-accounting=yes wpa2-pre-shared-key=PSK2
add authentication-types=wpa2-psk mode=dynamic-keys name=ssid3 \
    radius-mac-accounting=yes wpa2-pre-shared-key=PSK3
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country="united kingdom" \
    disabled=no frequency=2437 hw-retries=15 l2mtu=1600 mode=ap-bridge \
    security-profile=ssid1 ssid=SSID1 wireless-protocol=802.11
add disabled=no l2mtu=1600 mac-address=02:0C:42:DC:E7:23 master-interface=\
    wlan1 name=wlan2 security-profile=ssid2 ssid=SSID2
add disabled=no l2mtu=1600 mac-address=02:0C:42:DC:E7:24 master-interface=\
    wlan1 name=wlan3 security-profile=ssid3 ssid=SSID3
The phone is on SSID3.
 
troffasky
Member
Member
Posts: 416
Joined: Wed Mar 26, 2014 4:37 pm

Re: Cisco wifi phone issues

Sat Jan 17, 2015 11:56 pm

Do any other stations on this AP experience connectivity problems when the phone is having a fit?
 
m0kct
just joined
Topic Author
Posts: 17
Joined: Sat Mar 17, 2012 1:55 am

Re: Cisco wifi phone issues

Sun Jan 18, 2015 12:21 am

Just did a test, and it looks like it's just the phone that has problems.
 
lb9ve
just joined
Posts: 6
Joined: Sat Jan 14, 2012 8:23 pm

Re: Cisco wifi phone issues

Sun Jan 18, 2015 4:13 pm

I have a Cisco WIP320 phone. It is not the same phone as yours, but I my experience is that it is nearly useless. I have only got it to work with WPA and TKIP, not WPA2 and AES.
 
m0kct
just joined
Topic Author
Posts: 17
Joined: Sat Mar 17, 2012 1:55 am

Re: Cisco wifi phone issues

Mon Jan 19, 2015 5:35 pm

Tried with WPA and TKIP. The phone re-associates, I can ping it, get to the web GUI, etc., but it doesn't register with the SIP server! As soon as I change the ciphers back to AES, it registers. I think I'd have to agree with you that this phone is a piece of crap. There's also tons of jitter in ping RTTs even when it's right next to the AP with no other wifi devices active.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3443
Joined: Mon May 31, 2004 2:55 pm

Re: Cisco wifi phone issues

Mon Jan 19, 2015 5:48 pm

If you want to use the TKIP then disable the N mode and use only B/G mode. As the TKIP will not work if you will try to use it together with N mode.
 
m0kct
just joined
Topic Author
Posts: 17
Joined: Sat Mar 17, 2012 1:55 am

Re: Cisco wifi phone issues

Mon Jan 19, 2015 5:59 pm

Thanks, tried that. The phone now registers, but the original problem is still there.

Who is online

Users browsing this forum: SpartanX and 73 guests