Community discussions

 
ryansturmer
just joined
Topic Author
Posts: 6
Joined: Tue Jan 27, 2015 2:52 pm

RB2011 Slow Wireless Performance

Tue Jan 27, 2015 3:15 pm

My new RB2011 (RouterOS 6.18) gives excellent performance over its GigE ports, but performs very poorly over wireless. Just using an online bandwidth testing tool, I get 10Mb on my hardwired machines, but 0.7Mb or so with my wireless link. (I'm sure there's a better way to do a link test, but this was quick and easy)

The signal strength seems good in any case, and placement of the client relative to the access point seems not to make any difference. In all cases, I have 30-50dB over the noise floor.

I'm new to the Mikrotik forums, so I'm not sure what the most relevant information to provide is, but I'll start with a printout of my wireless interface:
[admin@MikroTik] > /interface wireless print
Flags: X - disabled, R - running 
 0  R name="wlan1" mtu=1500 mac-address=4C:5E:0C:C4:EB:0B arp=enabled 
      interface-type=Atheros AR9300 mode=ap-bridge ssid="creampuffstarship" 
      frequency=auto band=2ghz-b/g/n channel-width=20/40mhz-ht-above 
      scan-list=default wireless-protocol=802.11 wds-mode=disabled 
      wds-default-bridge=none wds-ignore-ssid=no bridge-mode=enabled 
      default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 
      default-client-tx-limit=0 hide-ssid=no security-profile=default 
      compression=no 
This is a pretty typical home network setup, with just the single router/access point. I may add a second access point for my upstairs eventually, but I wanted to see how this one would perform first. Signal integrity wise, it seems much better than the AP it replaced, so it looks like I won't need the second AP anytime soon, if only I could get this bandwidth issue resolved.

Things I have tried:

1) I have attempted just b/g, thinking it was a compatibility issue of my client devices with N (no such luck)
2) I have changed frequencies - I tried several fixed frequencies, including one or two that I found to be unused in any of the networks that are visible from the router. I ultimately settled on "auto" as the safest bet, but it doesn't appear to make a difference in any case.

Any thoughts? I feel as though it has to be something silly I'm doing.

Thanks,

-R
 
KpaBap
just joined
Posts: 7
Joined: Mon Jan 19, 2015 3:13 am

Re: RB2011 Slow Wireless Performance

Tue Jan 27, 2015 5:56 pm

I have the same issue and have spent countless hours changing each and every setting in the wifi config. None of it makes much of a difference.

I've concluded that somethings is severely wrong with the RB2011 wifi. There are countless other posts on this forum with no answers from people experiencing the same issue.

Frankly, I suggest returning it from where you bought it, if you can.
 
ryansturmer
just joined
Topic Author
Posts: 6
Joined: Tue Jan 27, 2015 2:52 pm

Re: RB2011 Slow Wireless Performance

Wed Jan 28, 2015 1:52 am

FYI:

I have upgraded to ROS 6.25 and retested, with the same performance.

The signal strengths that I see reported from my devices under test range from -60-75dB

Still tinkering...
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: RB2011 Slow Wireless Performance

Wed Jan 28, 2015 5:14 pm

Please enable the wireless-fp package and check again.
How are you testing the wireless performance?
 
ryansturmer
just joined
Topic Author
Posts: 6
Joined: Tue Jan 27, 2015 2:52 pm

Re: RB2011 Slow Wireless Performance

Thu Jan 29, 2015 7:18 am

Wireless-fp installed and rebooted router. Similar performance, perhaps a marginal improvement, but still essentially within the noise.

As a check for speed, I am simply going to speedtest.net and checking my up/down rates. Obviously this is checking the quality of my incoming/outgoing internet connection as well, but in each instance in testing the wireless, I am checking against results from one of my machines that is connected to one of the ethernet ports. The results are consistent: Wireless performance at roughly 1Mbps while ethernet reporting just over 10Mbps for the same tests.

-R
 
ryansturmer
just joined
Topic Author
Posts: 6
Joined: Tue Jan 27, 2015 2:52 pm

Re: RB2011 Slow Wireless Performance

Thu Jan 29, 2015 7:23 am

I have gone through and checked the fast-path prerequisites here:

http://wiki.mikrotik.com/wiki/Manual:Fast_Path

I seem to have everything configured correctly to allow fast path.

Considering returning the device, the wired interfaces seem fine, but the wireless performance is very disappointing.

-R
 
ryansturmer
just joined
Topic Author
Posts: 6
Joined: Tue Jan 27, 2015 2:52 pm

Re: RB2011 Slow Wireless Performance

Thu Jan 29, 2015 7:39 am

You guys aren't going to f** believe this.

On a whim, I decided to actually take the bonding lug on the back of the unit and strap it to earth ground. I'm an electrical engineer, and have had my share of EMC related failures that were related to poor bonding.

My wireless connection (again, tested by just doing a speed test to an external server) jumped from 0.9Mbps to 16.08Mbps!
My *wired* connections, which were holding steady at 10Mbps are now at 16 as well.

!!!!

This is a confirmed effect. I have disconnected the bonding wire several times at this point, and have observed a marked drop in speed when the unit is not properly earthed.

So, ! I have not attempted to disable the fast path on the wireless to see what effect it has, but I will report back.

-R
 
thasser
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Mon Sep 23, 2013 8:28 pm

Re: RB2011 Slow Wireless Performance

Thu Jan 29, 2015 10:42 pm

Hmm. I could see how grounding could affect your speed but that seems very dramatic just for not having a proper ground.

What is your internet speed you pay for? What would be better- plug directly into your modem and run speedtest.net to get yourself a baseline. From there we can start to really see how much speed you are losing. Do that and report back.

For MT routers you really get them for the software capabilities, but the experience that you get out of them typically is heavily influenced by the familiarity of the user with networking protocols and linux (RouterOS is linux based).
 
User avatar
koolandrew
just joined
Posts: 18
Joined: Tue Dec 06, 2011 7:20 pm
Location: Toronto
Contact:

Re: RB2011 Slow Wireless Performance

Wed Feb 18, 2015 11:46 pm

HI Everyone, could the engineer please explain further what he did to increase the wireless.

I have lots of Mikrotik devices in the field. They are tremendous products, except for the wireless. I am starting to lose clients as a result. Using speedtest, i am able to get about 1/3 of the speed of wired, at best. When i test using Mikrotik Bandwidth test, it is about the same even though the connection speed is far higher.

I have tried it in so many different scenarios that i cannot remember. With different configurations in the various forums that i have searched in trying to find something that competes with "crappy store bought routers".

MIkrotik you need to acknowledge and address this issue. Why did you come up with two new wireless AP's with such poor throughput. I have a Mikrotik on the same network as a Meraki, 50mbs download, vs 3 mbs????????????

What can be done about this besides turning the wireless off????????????????????????
 
TomC
just joined
Posts: 1
Joined: Sat Mar 19, 2016 12:14 am

Re: RB2011 Slow Wireless Performance

Mon Mar 21, 2016 6:40 pm

Hello,

I hope that someone can help I am very frustrated and quite close to take a hammer and destroy the entire RB493G routerboard.

I just cannot understand these mikrotik routerboards and what the h***** is going on.
Very poor signals, painful low bandwidth...

A friend of my have just purchased an D-Link DIR-890 Ultra tri-band WiFi router and he only configured the SSID and WPA2 key and simply voila he got almost 300 Mb/ps while I am stuck with mikrotik that costs 3 times more on only 50 Mb/ps. I am not an expert with mikrotik but I understand the basic wireless terms and I have tried almost every combination without any success :(:(:(

This Mikrotik will be used as an "brigde with no router functions" meaning following cable connection:

"RB493G" - mikrotik router CRS125" - FiberOptic Media Converter (internet)

so the CRS125 is running DHCP and the RB493G wil only bridge users..

I have following hardware configuration:

RB493G
R52HN Wireless with two antennas connected (Dual Band ML-2452-APA2-01)
R52 Wireless with one antenna connected (Dual Band ML-2452-APA2-01)

And following software installed:

Firmware: 3.24
RouterboardOS: 6.34.3

does anyone have perhaps copy paste ready wireless configuration that ONLY and SIMPLY works out of the box ?

Thank You and sorry for my frustration

Best regards
Tom
 
thasser
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Mon Sep 23, 2013 8:28 pm

Re: RB2011 Slow Wireless Performance

Thu Jun 09, 2016 8:10 pm

open the terminal and past this:

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no distance=indoors \
frequency=2437 frequency-mode=superchannel mode=ap-bridge preamble-mode=\
short ssid=My Wireless Network wireless-protocol=802.11
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=\
mikrotik

In my experience the short preamble setting increases 802.11 speeds drastically.
 
smaritz
just joined
Posts: 5
Joined: Tue Jul 18, 2017 10:17 pm

Re: RB2011 Slow Wireless Performance

Sat Dec 23, 2017 10:00 am

open the terminal and past this:

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no distance=indoors \
frequency=2437 frequency-mode=superchannel mode=ap-bridge preamble-mode=\
short ssid=My Wireless Network wireless-protocol=802.11
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=\
mikrotik

In my experience the short preamble setting increases 802.11 speeds drastically.
This did it for me, thanks!

Who is online

Users browsing this forum: No registered users and 14 guests