Community discussions

MUM Europe 2020
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Apple devices won't connect

Mon May 04, 2015 2:41 pm

I have several 2,4Ghz AP (SXT or other routerboard units) all connected via a vlan network to one dhcp server.

Several people are allowed to use this network to go online.
Tablet's, PC's (laptops) and smartphones (windows/androids) all connect and get an IP with default gateway etc. and can browse the internet.

Except for Apple devices. Sometimes an apple device works but 80% of the case we seem not to be able to find why they won't...

The are associated to the AP, good signals even, better sometimes than a android phone beside it, but no IP exchange.

When I try to connect Apple device to local Wifi (MT router) that has local dhcp server (just my office wifi router) it connects and gets an IP inmediately.
If I now compare my local wifi and the remote 2,4Ghz AP's (I call them hotspot, but they are just simple AP's in a bridge network where an dhcp server is found at distant and also the border gateway will be found at distance.) I see no real differences apart from the SSID and the fact that the local AP has its local dhcp-server and is routed to the internet where the bridge AP's are having a vlan interconnecting them towards a central dhcp-server and a remote internet gateway.

But why is this happening ONLY with Apple devices? All other brands have no issues......
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Apple devices won't connect

Mon May 04, 2015 2:45 pm

Well, the topic should read "won't be assigned an IP" the do connect....
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Apple devices won't connect

Mon May 04, 2015 2:50 pm

If I look in the log of the dhcp-server the message generated by the dhcp-server reads;

"Server client xx.xx.xx.xx.xx.xx. declines IP address 20.20.20.xxx"

(My dhcp-pool is 20.20.20.100-20.20.20.254 where my network is 20.20.20.0/24)

Any other device is just assigned with an IP...

Is this anything to do with the Apple OS?
In this instance its relates an Ipad and an Iphone.

But I do have clients that CAN connect with their Iphone or Ipad. So to be honest I am clueless.
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Apple devices won't connect

Mon May 04, 2015 3:17 pm

According the log it is the Apple devices that actually send a 'decline' message to server... (see picture) why?
Screenshot 2015-05-04 14.14.23.png
You do not have the required permissions to view the files attached to this post.
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Apple devices won't connect

Mon May 04, 2015 3:49 pm

What's your DHCP Server > DHCP authoritative setting? try setting it to "yes".
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Apple devices won't connect

Mon May 04, 2015 4:32 pm

What's your DHCP Server > DHCP authoritative setting? try setting it to "yes".
Although I would not know what if would differ, I tried it anyway.... it doesn't help.
DHCP-server status stays now 'offered' for a some minute or so until the request disappears to be renewed again after a sec.

In the original setting; "Authoritative: after 2s delay" the status went from 'offered' to 'bound' to 'waiting' and back to 'offered' again.
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Apple devices won't connect

Mon May 04, 2015 5:26 pm

There are any differences between the ios devices that actually connect and those who doesn't?

IOS devices use some sort of algorithm to confirm a lease faster, maybe is related to the VLAN setup, so capturing the traffic from device showing this issue (esp. ARP) can lead you to a clue...

suerte!
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Apple devices won't connect

Mon May 04, 2015 5:39 pm

There are any differences between the ios devices that actually connect and those who doesn't?

IOS devices use some sort of algorithm to confirm a lease faster, maybe is related to the VLAN setup, so capturing the traffic from device showing this issue (esp. ARP) can lead you to a clue...

suerte!
Well, don't know. On the moment have no other ios devices at hand that can connect.
But I also suspect its the vlan having something to do with it. But I'm not going to change my network because some ios devices won't get an IP. It works fine for several hundreds of other devices.....

What do you mean with "(esp. ARP)" ?
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Apple devices won't connect

Mon May 04, 2015 5:57 pm

sorry, I meant ARP Protocol.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: Apple devices won't connect

Sat May 09, 2015 2:16 pm

Not sure wether it is relevant. We have found some Apple devices to be troublesome on 80211a/b when non Apple devices are already connected to the same AP. Turned out to be the security authentication type. It seems if an AP is allowed to use WPA2 aes and tkip problems arise. If the AP is forced to only use WPA2 aes then the problems go away. The only other oddity we found with some apple devices is they dont like a Punctuation mark like _ in the SSID.
 
flynno
Member Candidate
Member Candidate
Posts: 242
Joined: Wed Aug 27, 2014 8:11 pm

Re: Apple devices won't connect

Sun May 31, 2015 12:10 am

Turn off TKIP
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Apple devices won't connect

Mon Jun 01, 2015 1:06 pm

Its an open AP.
We just filter clients by mac. authentication... so no encryption takes place.....

Just this morning again, two androids connected without problems, one Iphone connects without problem, one SXT 2,4G connects without problem, but two Ipad can't connect. They see the network but connection is rejected with the message "check your network provider" (haha, that's me!)

Any ideas..?

It ONLY happens with Apple devices. We've had people with Iphones, Ipads and a MacBook that were not allowed.
But others, even with the same kind of devices have no issue...... very, very weird.
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Apple devices won't connect

Mon Jun 01, 2015 1:47 pm

Have a look at this thread
To implement a Wi-Fi popup login page:
1.DNS request for http://www.apple.com must not fail
2.HTTP request for http://www.apple.com/library/test/success.html with special user agent CaptiveNetworkSupport/1.0 wispr must not return Success.
Maybe differences in IOS version are causing the failings? check DNS requests when such a device doesn't connect. I also found that reverse DNS for the router IP should work (insert an static entry in addition to the router FQDN)
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
User avatar
dgnevans
Member
Member
Posts: 463
Joined: Fri Mar 08, 2013 11:24 am
Location: Zimbabwe
Contact:

Re: Apple devices won't connect

Mon Jun 01, 2015 10:33 pm

i had a similar problem where I would have windows and android devices not getting a dhcp address. 1100 ahx2 router and engenius access points. I found that if i went into the settings for each apple device under TCP/ip there is client ID or dhcp Client ID.I copied the mac address and put it into their. They then got an IP straight away. may be worth trying on one of the devices that fails.
 
palmero
just joined
Posts: 3
Joined: Wed Aug 20, 2014 4:21 pm
Location: Madrid
Contact:

Re: Apple devices won't connect

Mon Jun 22, 2015 12:16 pm

Hi,

I am pretty sure it won't solve your issue, but I think you should try to avoid using networks like 20.20.20.0/24 for your local network, unless you have that range assignet to you by IANA.

Use private IP networks instead.

https://en.wikipedia.org/wiki/Private_network

If you use a legal IP for your local network and happens that you have to access a public server and the DNS returns an IP in your local network, you are screwed up.

I would give it a try.

Regards
MTCNA, MTCRE, MTCWE, MTCTCE, MTCINE
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Apple devices won't connect

Tue Jun 23, 2015 1:19 am

Hi,

I am pretty sure it won't solve your issue, but I think you should try to avoid using networks like 20.20.20.0/24 for your local network, unless you have that range assignet to you by IANA.

Use private IP networks instead.

https://en.wikipedia.org/wiki/Private_network

If you use a legal IP for your local network and happens that you have to access a public server and the DNS returns an IP in your local network, you are screwed up.

I would give it a try.

Regards
hmm, that's new to me. I thought 20.20.20.0/24 like 10.10.10.0/24 was for private use too. I used it to distinguish from some other part of my networks. But ok, wikipedia is clear.
Maybe the apple internal network or their servers work on 20.20.20.0/?? range and that is what gives the issue. I can give it a try. Is some work but ok, maybe we are lucky.....
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
BartoszP
Forum Guru
Forum Guru
Posts: 1719
Joined: Mon Jun 16, 2014 1:13 pm
Location: Poland

Re: Apple devices won't connect

Tue Jun 23, 2015 8:06 am

Real admins use real keyboards.
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Apple devices won't connect

Wed Jul 08, 2015 3:07 pm

Finally changed the 20.20.20.0/24 into 192.168.20.0/24 but to no relief. SOME apple devices (so still not all, some work flawless) are not able to pick up an IP from the dhcp-server....
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
spaxton
Member Candidate
Member Candidate
Posts: 175
Joined: Fri Jan 01, 2010 12:18 pm

Re: Apple devices won't connect

Fri Jul 31, 2015 8:16 pm

Finally changed the 20.20.20.0/24 into 192.168.20.0/24 but to no relief. SOME apple devices (so still not all, some work flawless) are not able to pick up an IP from the dhcp-server....

it is happening because apple devices won't renew IP address if went to sleep so they keep the address while DHCP may give it to other device. Actually the device doesn't act like it need an address to be assigned. This may be solved by MKT but I am not sure. I didn't read all the posts but I think this is the problem. I've heard about this problem few days on MUM.

BR.
 
User avatar
djape
Member
Member
Posts: 469
Joined: Sat Nov 06, 2004 7:54 pm
Location: Serbia

Re: Apple devices won't connect

Sat Jun 25, 2016 5:46 pm

I know it is old topic, but after many hours of struggle with 2 MacBook Pro not being able to get IP, complaining about IP already used by another device (when it's not) I was able to solve the problem by changing protocol-mode from rstp to stp:

 /interface bridge> print
Flags: X - disabled, R - running
 0  R name="bridge1" mtu=1500 actual-mtu=1500 l2mtu=1526 arp=enabled
      arp-timeout=auto mac-address=XX:XX:XX:XX:XX:XX protocol-mode=stp
      priority=0x8000 auto-mac=no admin-mac=XX:XX:XX:XX:XX:XX
      max-message-age=20s forward-delay=15s transmit-hold-count=6
      ageing-time=5m

Once changed, everything works like a charm.

Good luck!
I drink like a pirate and smoke like a hippie...
 
User avatar
djape
Member
Member
Posts: 469
Joined: Sat Nov 06, 2004 7:54 pm
Location: Serbia

Re: Apple devices won't connect

Sat Jun 25, 2016 7:29 pm

Was celebrating too soon. Though wifi works now on OSX devices, other devices on Ethernet interface are dropping packets, ping stats are 50% packet loss.
Whatever it is, it has something to do with bridge interface and STP/RSTP setting, so I would like to draw attention to Mirkotik devs.

Thanks.
I drink like a pirate and smoke like a hippie...
 
User avatar
djape
Member
Member
Posts: 469
Joined: Sat Nov 06, 2004 7:54 pm
Location: Serbia

Re: Apple devices won't connect

Sun Jun 26, 2016 1:14 am

More news, bridge protocol-mode setting to stp will work for OSX devices, and wireless, but Ethernet will mostly lose packets.
If you set to rtsp, all devices but OSX will work fine.
This is totally crazy and almost unbelievable that Mikrotik never detected this before.

This is reproducible 100% on all versions of RouterOS.

Now, the only way to avoid this is to remove bridge and work per interface, then it doesn't matter, everything works.

Please Mikrotik, look in to this, this is serious issue.
I drink like a pirate and smoke like a hippie...
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: Apple devices won't connect

Sun Jun 26, 2016 3:39 am

Send your findings and documentation to support. Otherwise they will not take care about it. To write it here is good for informing others but not relevant for mikrotik staff.
 
WirelessRudy
Forum Guru
Forum Guru
Topic Author
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Apple devices won't connect

Mon Jun 27, 2016 11:35 am

yes djape, Please send to support and see what MT is going to do with it. I am dying to see what they'll say...
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
djape
Member
Member
Posts: 469
Joined: Sat Nov 06, 2004 7:54 pm
Location: Serbia

Re: Apple devices won't connect

Sat Jul 09, 2016 1:23 pm

Unfortunately, I don't have time as I am on a vacation with my family, enjoying.
Knowing that Mikrotik is not and open source but commercial product, I find rather inconvenient that Mikrotik doesn't test products in various environments.ou
I've reported a bug, you should not expect your customers to do your work.

Thank you.
I drink like a pirate and smoke like a hippie...
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24315
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Apple devices won't connect

Mon Jul 11, 2016 2:52 pm

I can understand your frustration, but we do test things and we actually use lots of Macbooks here ourselves. This situation has some unique element that others don't have, so we do need the information from you. Others have not complained either. 

Have a nice vacation 
No answer to your question? How to write posts
 
mennowz
Trainer
Trainer
Posts: 84
Joined: Tue Apr 09, 2013 8:50 pm
Location: The Netherlands
Contact:

Re: Apple devices won't connect

Mon Jul 11, 2016 7:34 pm

Hi Rudy,

can you run the packet sniffer while trying to get a lease?, i have a theory.....

Just send it to me via wetransfer.. think something will come out of the sniff.

Best regards,

Menno
Certified Mikrotik trainer in the BeNeLux!. http://www.mikrotiktraining.nl
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Apple devices won't connect

Sat Jul 16, 2016 12:12 pm

Using lots of Apple devices myself, also on hospitality setups more than 50% are Apple devices, never had a problem.

If STP or RSTP is giving you "problems", is because you probably have some kind of either a real network loop, or a "logical" network loop, e.g. you used backups (not exports, i.e. .rsc's) to transfer configurations between routers, and now have duplicated MACs on your network.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
sstyle
newbie
Posts: 34
Joined: Thu Jul 14, 2016 11:53 pm

Re: Apple devices won't connect

Mon Jul 18, 2016 11:12 am

I see that my iPad mini 2 (2.4GHz) takes a long time to connect after I turn on display. About 30 sec to reconnect to wifi. It is too much (
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: Apple devices won't connect

Mon Jul 18, 2016 11:17 am

Set group key update to 1h in security profile.
 
sstyle
newbie
Posts: 34
Joined: Thu Jul 14, 2016 11:53 pm

Re: Apple devices won't connect

Mon Jul 18, 2016 11:29 am

Set group key update to 1h in security profile.
Thanks. I will try. 
 
pe1chl
Forum Guru
Forum Guru
Posts: 5970
Joined: Mon Jun 08, 2015 12:09 pm

Re: Apple devices won't connect

Mon Jul 18, 2016 12:25 pm

Others have not complained either. 
Well, this topic has been discussed in another thread.
I have also witnessed it on our own network, but for specific devices only.  It may be related to some setting on the device,
or to its history.   E.g. there is some indication that when the device got its address from another server, and then is suddenly
faced with the MikroTik router (router has been swapped), it does not want to accept the lease.  That may be a security feature.
 
sstyle
newbie
Posts: 34
Joined: Thu Jul 14, 2016 11:53 pm

Re: Apple devices won't connect

Mon Jul 18, 2016 3:52 pm

Set group key update to 1h in security profile.
Tried. One hour is ok. But if I did not touch it for 1 hour it still takes a long time to connect
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: Apple devices won't connect

Mon Jul 18, 2016 4:25 pm

You cannot set more in mikrotik. Seems like to be badly implemented client features in those devices.
 
benniehier
just joined
Posts: 1
Joined: Sat Oct 15, 2016 4:56 pm

Re: Apple devices won't connect

Sat Oct 15, 2016 5:09 pm

Solved by "Add ARP For Leases" in DHCP (This Authorative I already had set for the clients)

I have an iPhone 6Plus, iPhone 7 and Samsung S7
My son's new iPhone 7 made problems.
wifi was connected, router set, traffic to other internal network devices but not to internet.
When I came home the same was with my iPhone 6Plus. Connected but no internet.
Settings to manual did not work

So after setting this ARP then all worked although I have to admit the iPhone 7 was struggling a little bit. I deleted network and then all was OK.
Maybe this helps others
for now it seems to work.
 
james990
just joined
Posts: 1
Joined: Tue Apr 11, 2017 9:26 am

Re: Apple devices won't connect

Tue Apr 11, 2017 9:31 am

Yes I am facing the issue to also connect Apple device on my iPad pro.
 
coliflower
just joined
Posts: 18
Joined: Mon Aug 21, 2017 1:10 pm

Re: Apple devices won't connect

Sun Sep 10, 2017 12:01 pm

I just bought two new wAP-ac access-points.
Unfortunately I am not able to connect even to the wlan-interface itself nor to the virtual-wlan interface :-(

Any help is highly appreciated.
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Apple devices won't connect

Mon Sep 11, 2017 12:29 am

I just bought two new wAP-ac access-points. Unfortunately I am not able to connect even to the wlan-interface itself nor to the virtual-wlan interface :-(
Any help is highly appreciated.
Plug an ethernet cable into the port. Open up "Winbox" and choose the Neighbors tab.
 
coliflower
just joined
Posts: 18
Joined: Mon Aug 21, 2017 1:10 pm

Re: Apple devices won't connect

Tue Sep 12, 2017 7:08 pm

Sorry, maybe I was not exact enough …

I am able to connect to the wAP itself - no problem so far BUT I am not able to connect with e.g. my iPhone 6s to the SSID as I am able to connect with my old MBP :-(
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Apple devices won't connect

Wed Sep 13, 2017 12:57 am

I am able to connect to the wAP itself - no problem so far BUT I am not able to connect with e.g. my iPhone 6s to the SSID as I am able to connect with my old MBP :-(
Oh, okay. It maybe your configuration then. Try this (change password and SSID of course).
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-eC country="united states" distance=indoors frequency=auto mode=ap-bridge wps-mode=disabled ssid=MYSSID
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40mhz-Ce country="united states" disabled=no distance=indoors frequency=auto frequency-mode=regulatory-domain mode=ap-bridge wireless-protocol=802.11 wps-mode=disabled ssid=MYSSID

/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-key-update=1h mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=PASSWORD1

 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24315
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Apple devices won't connect

Wed Sep 13, 2017 11:24 am

Everyone with this issue, I want to understand the issue here.

With my devices, the WiFi is turned off when they go to sleep and this is normal. The device will enable WiFi only when needed, or when it wakes up and you open the web browser.
This is as it should be. If you think this is a problem, you can increase the DHCP server lease time, because iPhones will disconnect wifi at half of the lease time. Default lease time is 10 minutes, so after 5 minutes of sleeping, WiFi is turned off to save power. This is to be expected. Set it to hours, then WiFi will stay on for longer.

When you wake the device, it will still show 4G, it will only connect to WiFI when you initiate some application that needs it, like if you open Safari.
iPhone will also enable WiFi if it receives a push notification from the push server (via DATA).

Do your phones not have any data at all? Or I misunderstand the issue.
No answer to your question? How to write posts
 
coliflower
just joined
Posts: 18
Joined: Mon Aug 21, 2017 1:10 pm

Re: Apple devices won't connect

Thu Sep 14, 2017 11:31 am

Oh, okay. It maybe your configuration then. Try this (change password and SSID of course).
Thank you first :-)

I had wpa2-psk and wpa2-eap in security-profiles what works with my MBP (2011) but not with an iPhone6s (2017) - why ever (I do not know the background of that ... Maybe someone can explain in more detail).

Her my current configuration what seems to work - I can access the Radio with all my devices I tried ;-)
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
    dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=Passwort
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    management-protection=allowed name=offen supplicant-identity=""
add authentication-types=wpa2-psk eap-methods="" management-protection=\
    allowed management-protection-key=Passwort mode=dynamic-keys name=\
    WPA2-PSK-AES-CCM supplicant-identity=MikroTik wpa2-pre-shared-key=\
    Passwort
/interface wireless
set [ find default-name=wlan1 ] antenna-gain=2 area=Area-AP1-2GHz band=2ghz-g/n \
    country=austria disabled=no distance=indoors frequency=2452 hide-ssid=yes \
    mode=ap-bridge name=wAP2GHz security-profile=WPA2-PSK-AES-CCM ssid=\
    MikroTik1-2GHz wireless-protocol=802.11 wmm-support=enabled wps-mode=\
    disabled
set [ find default-name=wlan2 ] antenna-gain=2 area=Area-AP1-5GHz band=\
    5ghz-a/n/ac channel-width=20/40/80mhz-Ceee country=austria disabled=no \
    distance=indoors frequency=auto hide-ssid=yes mode=ap-bridge name=wAP5GHz \
    radio-name=Radio-AP1-5GHz security-profile=WPA2-PSK-AES-CCM ssid=\
    MikroTik1-5GHz wireless-protocol=802.11 wmm-support=enabled wps-mode=\
    disabled
 
coliflower
just joined
Posts: 18
Joined: Mon Aug 21, 2017 1:10 pm

Re: Apple devices won't connect

Thu Sep 14, 2017 11:50 am

Everyone with this issue, I want to understand the issue here.
... Or I misunderstand the issue.
Hello Normis,

I think I solved my problem as described in post above ... I had to remove psk-eap.
When you wake the device, it will still show 4G, it will only connect to WiFI when you initiate some application that needs it, like if you open Safari.
iPhone will also enable WiFi if it receives a push notification from the push server (via DATA).
I personally can not confirm that ... If I open e.g. my iPhone, than the device always connect the WiFi immediately - of course I do not not the process behind.

One question, I would like to use my iPhone as trigger to recognise my smarth-home me at home ... The problem is the iPhone goes to sleep and the IP is recognise as not on-line or if I come back to home and the iPhone is in sleep modus then the smart-home do not recognise me, either ...

Is there any possibility where MikroTik can "push" some device to check their availability ?

Many thanks for help and for my off-topic-question in advance !!!
 
User avatar
meverest
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Wed Jun 30, 2004 3:27 pm
Location: Geelong, Australia
Contact:

Re: Apple devices won't connect

Wed Sep 20, 2017 10:08 am

Hi folks,

I've been battling with this exact same issue on-and-off for quite some time now over the last several years.

Like other reports here, for me the problem manifests most obviously as DHCP problem for iPhone, but like some other posts in this thread, the problem also tends to present as other strange behaviours too, with ping packet loss, some apparently random IPs intermittently not reachable and so on. Every time I have encountered the problem, I've been looking for network loops from badly configured bridges, and often after tidying up some unusual bridged vlan configs, the problem seems to go away.... for a while ;)

But today, after battling this one for more than a week (not full time, fortunately ;) I think I finally found the culprit: one of the bridges on the broadcast domain was set as proxy-arp. I can only guess that it was set that way at one time when that device was acting as VPN server access for remote access to the connected subnet, but the particular router was not performing that task any more, so it was easy to just change back to arp-enabled - problem immediately resolved! :-)

Investigating further, I've found out that this problem seems to only happen when the proxy-arp bridge has one or more ports that are non-edge. I realize now that this is why in the past when I go playing with bridge configurations to discover that the problem mysteriously goes away, it was only because I happened to fluke on a configuration that put the offending bridge onto an edge somewhere (out of sight, out of mind! ;)

After reading through previous reports in this thread, I can see a LOT of symptoms and apparent solutions that make a great deal of sense with this discovery in mind - there is mention of VLAN and VPN and STP and so on, which are all features that tend to be in play for this problem to happen. From me, big thanks goes to @benniehier who made a post mentioning "add arp for leases" which got me thinking why that would make any difference... and that triggered a memory snippet of seeing some interface with proxy arp enabled - bingo!

I'm posting this update because I reckon I won't be the last to come across this problem, and so adding this outcome as a potential solution to those who follow ;-)

Cheers!

Mike.
------------------------------------------------------------------------------------
Why Choose DuxTel for all your MikroTik needs?
http://duxtel.com/why_duxtel
Follow our tweets for news and updates: twitter.com/duxtel
 
Wyz4k
Member Candidate
Member Candidate
Posts: 197
Joined: Fri Jul 10, 2009 10:23 am

Re: Apple devices won't connect

Thu Nov 22, 2018 2:53 am

Hi all,

To make a long story relatively short. I also encountered this issue. I tried all of the steps above and they did not solve my particular issue. I'm not saying that they don't also solve variants of the issue, but they did not help me.

I did however manage to temporarily solve my issue though and I have reported it to Mikrotik as a bug along with supouts and everything else.
In my case I experience this issue when another Mikrotik device on the network is powered on. The problematic device does run a DHCP server but only on its wifi ports. It is connected to my main network over Ethernet though. I can't explain why it is affecting my main networks DHCP but it clearly does. If I power this device off, the DHCP "client declined IP address" issues go away straight away. If I power it back up it comes back within minutes.

What I have ruled out:
1) proxy-arp - viewtopic.php?t=96472#p619402
2) tkip - viewtopic.php?t=96472#p481272
3) Same failure on both 2.4G and 5G wifi
4) Lease period is set to 3 days - viewtopic.php?t=121207#p595986
4) Authoritative - viewtopic.php?t=121207#p595992
5) Setting the bridge ports as trusted - https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge
6) It is not an Apple issue. I made no change to my apple device and could get it to both work and not work by making the change below. - viewtopic.php?t=121207#p596050 I have a wemo wifi switch which also failed to connect to the wifi.
7) I am running the latest ROS version on all devices.
8) Turning the affected device off and on - did not help
9) Switching the affected device to flight mode - did not help.
10) Switching the affected device's wifi off and back on again after a few seconds.
11) Firewall rules blocking the DHCP broadcasts.

Other people seemingly also affected by this issue:
viewtopic.php?t=67573
viewtopic.php?t=121207
viewtopic.php?t=96472
 
mkx
Forum Guru
Forum Guru
Posts: 3302
Joined: Thu Mar 03, 2016 10:23 pm

Re: Apple devices won't connect

Thu Nov 22, 2018 9:05 am

Please post configuration of "another Mikrotik device on the network" ... it might be that that devices is mis-configured.
BR,
Metod
 
pe1chl
Forum Guru
Forum Guru
Posts: 5970
Joined: Mon Jun 08, 2015 12:09 pm

Re: Apple devices won't connect

Thu Nov 22, 2018 10:23 am

In my case I experience this issue when another Mikrotik device on the network is powered on. The problematic device does run a DHCP server but only on its wifi ports. It is connected to my main network over Ethernet though. I can't explain why it is affecting my main networks DHCP but it clearly does.
Probably your device is leaking broadcasts between ethernet and wifi, e.g. because it is configured in bridge mode instead of in routing mode.
(as would be required when you want to run a DHCP server only on WiFi and not on ethernet)
Make sure there is no bridge interface in that device.
 
Wyz4k
Member Candidate
Member Candidate
Posts: 197
Joined: Fri Jul 10, 2009 10:23 am

Re: Apple devices won't connect

Thu Nov 22, 2018 10:48 am

Please post configuration of "another Mikrotik device on the network" ... it might be that that devices is mis-configured.
I am not at liberty to do that - see the info below. I have sent the supouts to Mikrotik.
Probably your device is leaking broadcasts between ethernet and wifi, e.g. because it is configured in bridge mode instead of in routing mode.
(as would be required when you want to run a DHCP server only on WiFi and not on ethernet)
Make sure there is no bridge interface in that device.
No, there is zero connectivity between the ethernet and wifi. They aren't bridged at all.

In fact the only bridge on that router is a loopback port for routing purposes. This "bridge" has no ports associated to it.
It has a mesh, but the only port on the mesh is the wlan.
DHCP runs on the mesh.

The only potential sticking point is that the ether port of that router had proxy-arp enabled. I have disabled it now and will see if the issue returns.
 
anuser
Member
Member
Posts: 406
Joined: Sat Nov 29, 2014 7:27 pm

Re: Apple devices won't connect

Thu May 02, 2019 11:07 pm

It seems I have a similar problem with an Apple device. Were you able to find the reason in your case?
 
spiazzi
just joined
Posts: 1
Joined: Sat Sep 07, 2019 5:42 pm

Re: Apple devices won't connect

Sat Sep 07, 2019 5:45 pm

Hi all,

I have same issue and I simply resolved disabling WPA2 EAP on security profile.
Menu Wireless-> Tab Security Profiles -> default -> remove check from WPA2 EAP -> apply.

Then it works

Who is online

Users browsing this forum: MSN [Bot] and 50 guests