Community discussions

 
maxsaf
newbie
Topic Author
Posts: 30
Joined: Tue Mar 06, 2018 8:47 pm

Dude 6.41.2 lost SNMP interfaces

Wed Apr 18, 2018 6:51 pm

Do not migrate to Dude 6!!!

After migration from Dude 4 to Dude 6 new dude starts to lose interfaces under DEVICE- SETTINGS - SNMP- INTERFACE.
If device supports RouterOS API - all interfaces presents under DEVICE- SETTINGS - RouterOS- INTERFACE
Link labels sometimes shows RX/TX ??
Dude1.png
If i change Link - Mastering Type to RouterOS instead of SNMP - It shows Ether1. It doesn't work with non-mikrotik devices
Dude2.png
You do not have the required permissions to view the files attached to this post.
 
excession
just joined
Posts: 18
Joined: Mon May 11, 2015 8:16 pm

Re: Dude 6.41.2 lost SNMP interfaces

Thu Aug 16, 2018 2:34 pm

+1
This is still happening in 6.42.6. Any fix / workaround to force re-discovery of interfaces?
 
Juanrri
just joined
Posts: 1
Joined: Mon Jul 30, 2018 9:12 pm

Re: Dude 6.41.2 lost SNMP interfaces

Thu Aug 30, 2018 4:00 pm

I have the same problem, I lose interfaces and it does not allow me to connect devices, this happens with version 6.42.7. Someone knows how to solve this problem.


In the attached image, example, I try to connect to the Gig 1/0/20 interface and it is not shown, several interfaces are lost, this happens to me at a global level.
You do not have the required permissions to view the files attached to this post.
 
Adam84
newbie
Posts: 28
Joined: Mon Mar 26, 2012 8:46 pm

Re: Dude 6.41.2 lost SNMP interfaces

Fri Aug 31, 2018 3:23 pm

On 6.42.7 problem remains. Tested on CHR platform.
 
excession
just joined
Posts: 18
Joined: Mon May 11, 2015 8:16 pm

Re: Dude 6.41.2 lost SNMP interfaces

Fri Aug 31, 2018 5:07 pm

It wouldn’t be such an issue if I could get it to rediscover ports when this happens.

Sometimes quitting dude client and reconnecting seems to help rediscover lost ports; but not reliably.
 
MikrotikOdessa
just joined
Posts: 12
Joined: Wed Feb 14, 2018 11:14 am

Re: Dude 6.41.2 lost SNMP interfaces

Sun Sep 16, 2018 2:06 pm

+1
Have this problem on the 6.42.7

Also have another problem with wlan ifaces while monitoring devices running OpenWrt 18.06 (OIDs discovered by SMNPwalk)
While working few days, this interfaces simultaneosly change their indexes and accumulate own non-working copies ("zombies") in the dropdown list of intefaces
this copies have different indexes like
wlan0(19) - zombie (previous working)
wlan0(20) - zombie (previous working)
wlan0(22) - working
wlan0(30) - zombie (previous working)
wlan0(33) - zombie (previous working)

And that's why correct monitoring going to be impossible ..
Last edited by MikrotikOdessa on Sun Sep 16, 2018 2:18 pm, edited 2 times in total.
 
eddieb
Frequent Visitor
Frequent Visitor
Posts: 89
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: Dude 6.41.2 lost SNMP interfaces

Sun Sep 16, 2018 2:15 pm

running

dude -> vacuum-db

solved this a couple of times for me
 
MikrotikOdessa
just joined
Posts: 12
Joined: Wed Feb 14, 2018 11:14 am

Re: Dude 6.41.2 lost SNMP interfaces

Sun Sep 16, 2018 2:38 pm

Thanks, it works.
I think it will be good to schedule this command for every day running
 
sid5632
Member Candidate
Member Candidate
Posts: 262
Joined: Fri Feb 17, 2017 6:05 pm

Re: Dude 6.41.2 lost SNMP interfaces

Sun Sep 16, 2018 7:50 pm

This is just a coincidence of stopping and restarting the server, which is what really fixes it.
Vacuuming the database has no effect in itself.
 
User avatar
ryny24
just joined
Posts: 10
Joined: Fri Sep 24, 2010 10:39 pm

Re: Dude 6.41.2 lost SNMP interfaces

Wed Oct 10, 2018 5:40 am

Just upgraded from v4 to v6.43.2, and many SNMP interfaces are missing too. Has anyone found a resolution or a way to rediscover?
 
maxsaf
newbie
Topic Author
Posts: 30
Joined: Tue Mar 06, 2018 8:47 pm

Re: Dude 6.41.2 lost SNMP interfaces

Wed Oct 24, 2018 12:55 am

Did you check SNMP V2c instesd of V1?
 
lesnikov
just joined
Posts: 11
Joined: Tue Jul 15, 2014 9:33 pm
Location: Slovenia

Re: Dude 6.41.2 lost SNMP interfaces

Wed Nov 07, 2018 7:32 pm

Did anyone find fix for this problem? i have same problem with interfaces..
snmpawlk finds them but they are not shown in snmp\interface tab. Is there any way to add them manualy? this is driving me crazy :)))
 
excession
just joined
Posts: 18
Joined: Mon May 11, 2015 8:16 pm

Re: Dude 6.41.2 lost SNMP interfaces

Wed Nov 07, 2018 7:35 pm

Quitting the Dude client then re-opening it and waiting normally works for me.
 
ExtraNET
just joined
Posts: 2
Joined: Sat Oct 20, 2018 9:41 pm

Re: Dude 6.41.2 lost SNMP interfaces

Tue Nov 13, 2018 9:23 am

Hello guys, I am running v6.43.2 and the problem is still there. The interfaces are found in SNMPwalk, but I am not able to find it when adding charts.
I have tried everything, including the command "dude vacuum-db" with no luck.

Any idea?
 
xxiii
Member Candidate
Member Candidate
Posts: 225
Joined: Wed May 31, 2006 12:55 am

Re: Dude 6.41.2 lost SNMP interfaces

Wed Nov 14, 2018 1:26 am

Experiencing the same problem here, currently on version 6.42.6.
 
User avatar
43north
Member Candidate
Member Candidate
Posts: 194
Joined: Fri Nov 14, 2014 7:06 am

Re: Dude 6.41.2 lost SNMP interfaces

Tue Nov 20, 2018 5:01 am

Migrated from an old Version 4.0beta3 to 6.42.9 and no SNMP interfaces anywhere. Tagging this to track for any updates.
 
User avatar
43north
Member Candidate
Member Candidate
Posts: 194
Joined: Fri Nov 14, 2014 7:06 am

Re: Dude 6.41.2 lost SNMP interfaces

Tue Nov 20, 2018 10:33 pm

Just an update..... Switching to SNMP v2 fixed all my links in the newer Dude.

Who is online

Users browsing this forum: No registered users and 11 guests