Community discussions

MUM Europe 2020
 
User avatar
mbfound
Member Candidate
Member Candidate
Topic Author
Posts: 134
Joined: Tue Jul 01, 2014 1:18 pm
Location: South Africa

[solved] The Dude - Router OS option bug

Mon Jan 16, 2017 5:18 pm

HI

Just moved to Dude 6.38 from 3.6, everything working smoothly so far except one issue,

On some devices, if I select the Router OS option, I get the following error:

recv failed: Connection reset by peer(104) (6), next attempt at 15:08:42

This only happens on some devices, I've ofc made sure password, services, no firewall, etc. is correct. In the log I see NO log in attempt at all.

The device I'm testing with is just a Dynadish that is bridged, it has internet, I can ping the device (with udp on any port), I can Winbox to it, and it's working fine in the network.

Google doesn't really reveal anything other than nginx errors.

Any one else with a similar issue or know how to solve it?

Regards,
mb
Last edited by mbfound on Fri Jan 27, 2017 9:19 pm, edited 1 time in total.
 
User avatar
PaulsMT
MikroTik Support
MikroTik Support
Posts: 283
Joined: Tue Feb 10, 2015 3:21 pm

Re: The Dude - Router OS option bug

Tue Jan 17, 2017 9:32 am

HI

Just moved to Dude 6.38 from 3.6, everything working smoothly so far except one issue,

On some devices, if I select the Router OS option, I get the following error:

recv failed: Connection reset by peer(104) (6), next attempt at 15:08:42

This only happens on some devices, I've ofc made sure password, services, no firewall, etc. is correct. In the log I see NO log in attempt at all.

The device I'm testing with is just a Dynadish that is bridged, it has internet, I can ping the device (with udp on any port), I can Winbox to it, and it's working fine in the network.

Google doesn't really reveal anything other than nginx errors.

Any one else with a similar issue or know how to solve it?

Regards,
mb
Are you using default service ports ? Are you sure there is no firewall restrict rules in both - Dude/host device ?
 
User avatar
mbfound
Member Candidate
Member Candidate
Topic Author
Posts: 134
Joined: Tue Jul 01, 2014 1:18 pm
Location: South Africa

Re: The Dude - Router OS option bug

Tue Jan 17, 2017 2:54 pm

HI

Just moved to Dude 6.38 from 3.6, everything working smoothly so far except one issue,

On some devices, if I select the Router OS option, I get the following error:

recv failed: Connection reset by peer(104) (6), next attempt at 15:08:42

This only happens on some devices, I've ofc made sure password, services, no firewall, etc. is correct. In the log I see NO log in attempt at all.

The device I'm testing with is just a Dynadish that is bridged, it has internet, I can ping the device (with udp on any port), I can Winbox to it, and it's working fine in the network.

Google doesn't really reveal anything other than nginx errors.

Any one else with a similar issue or know how to solve it?

Regards,
mb
Are you using default service ports ? Are you sure there is no firewall restrict rules in both - Dude/host device ?
Hi,

IP services on the Dynadish xx.xx.1.121 are all standard, the device is bridged and there are no firewall or NAT rules.

I had a look on our dude server and there aren't any firewall rules that target the IP services ports or the IP range.

A few other devices on the range do have the same issue but others in the range do not.

I also have a sector with IP xx.xx.2.2 that has the same issue.

The devices are functioning normally in our network except for this error.

Regards,
mb
 
JEE
just joined
Posts: 1
Joined: Thu Jan 26, 2017 4:17 am

Re: The Dude - Router OS option bug

Thu Jan 26, 2017 4:28 am

Hi All,
can anyone help me to setup the new version of dude on RouterOS? what kind of utility I can use and which package I need to upload on RouterOS . I know MK just removed windows based server so please help me to setup as new one. I am using RouterBOARD 3011U Series
thanks
 
User avatar
mbfound
Member Candidate
Member Candidate
Topic Author
Posts: 134
Joined: Tue Jul 01, 2014 1:18 pm
Location: South Africa

Re: The Dude - Router OS option bug

Fri Jan 27, 2017 9:17 pm

Hi All,
can anyone help me to setup the new version of dude on RouterOS? what kind of utility I can use and which package I need to upload on RouterOS . I know MK just removed windows based server so please help me to setup as new one. I am using RouterBOARD 3011U Series
thanks
Just grab the all-package on the downloads site, unzip it and put dude.npk on your device and reboot. make sure the version is the same as your routeros version.
 
User avatar
mbfound
Member Candidate
Member Candidate
Topic Author
Posts: 134
Joined: Tue Jul 01, 2014 1:18 pm
Location: South Africa

Re: The Dude - Router OS option bug

Fri Jan 27, 2017 9:18 pm

my problem was sorted btw, someone put a stray ip address on a interface on a neighbouring board. after i removed everything started working.

Who is online

Users browsing this forum: MSN [Bot] and 7 guests