Community discussions

MUM Europe 2020
 
apiel1
newbie
Topic Author
Posts: 29
Joined: Fri Apr 28, 2017 6:50 pm

The Dude 6.39.2 Log Files

Fri Jun 23, 2017 5:38 pm

WE have ran the dude 4.0b3 for quite some time to monitor our network. We recently deployed a VM with CHR 6.39.2 and have migrated the Dude to this instance and have de-commissioned the old 4.0b3 server. One thing that I notice is in the 6.39.2 instance, there is only one log file built in now. Before there used to be 4 log files (syslog, event, etc., etc.) it also appears that I have no way to add any custom log files, or to adjust the retention settings of the log files. Does anyone have any information on how I can fix this,.

Thanks
 
slech
Long time Member
Long time Member
Posts: 534
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: The Dude 6.39.2 Log Files

Fri Jun 23, 2017 10:42 pm

apiel1,

As you, we also have same issue with Dude v6.

I have contacted Mikrotik support about this. Their reply was that they have plans to improve syslog, but how and when I don't know.

Thank you!
sorry for my english
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: The Dude 6.39.2 Log Files

Fri Jun 23, 2017 10:46 pm

At least something... At the moment you can save in system logging the dude event into separate file to get the dude log saved.
I am also waiting for returning the syslog functionality known in 4b3 to 6.x.
 
apiel1
newbie
Topic Author
Posts: 29
Joined: Fri Apr 28, 2017 6:50 pm

Re: The Dude 6.39.2 Log Files

Sat Jun 24, 2017 12:08 am

Thanks for the replies. I will eagerly await these enhancements in V6
 
slech
Long time Member
Long time Member
Posts: 534
Joined: Thu Feb 14, 2008 4:03 pm
Location: Moldova, Chisinau

Re: The Dude 6.39.2 Log Files

Sat Jun 24, 2017 9:15 am

At the moment, we also send all Dude v6 logs to remote syslog server where we have separate display for them and colorise them with corresponding rules.

Thank you!
sorry for my english
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: The Dude 6.39.2 Log Files

Tue Jun 27, 2017 9:45 pm

It would be nice not to have to do this. The logging at the moment within the dude is very unmanageable.
 
maxkrok
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Tue Aug 28, 2012 9:09 pm

Re: The Dude 6.39.2 Log Files

Sun Jul 16, 2017 6:24 pm

I join others for separate files syslog facility.. Logs cannot be saved now after reboot as well
 
eriitguy
Member Candidate
Member Candidate
Posts: 197
Joined: Thu Jan 26, 2017 1:16 pm

Re: The Dude 6.39.2 Log Files

Sun Jul 16, 2017 6:43 pm

maxkrok,

As a workaround, to save logs into a file on ROS, we can:
/system logging action add name=dudedisk target=disk disk-file-name="dude-log.txt" disk-lines-per-file=10000 disk-file-count=100 disk-stop-on-full=no
/system logging add topics=dude action=dudedisk
Thank you!
 
manuelm
newbie
Posts: 36
Joined: Sat Feb 15, 2014 10:37 pm

Re: The Dude 6.39.2 Log Files

Sat Jul 29, 2017 10:50 pm

I don't see a retention policy ether. Was this remove on the new version and when can we get it back?
 
eriitguy
Member Candidate
Member Candidate
Posts: 197
Joined: Thu Jan 26, 2017 1:16 pm

Re: The Dude 6.39.2 Log Files

Sat Jul 29, 2017 11:43 pm

manuelm,

What do you mean by retention policy?

In Dude v6 a ROS logging system is used and we can't configure multiple logs with their policy.

One workaround is described above.

Thank you!
 
simogere
newbie
Posts: 40
Joined: Fri May 24, 2013 11:54 am

Re: The Dude 6.39.2 Log Files

Thu Aug 03, 2017 2:18 am

Waiting for the "old style" syslog... :-(
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: The Dude 6.39.2 Log Files

Sat Aug 05, 2017 8:26 am

Me too.
 
Jightning
just joined
Posts: 9
Joined: Sat Jun 25, 2016 3:18 am

Re: The Dude 6.39.2 Log Files

Wed Oct 18, 2017 6:35 pm

I also need this. Hope it comes out soon :)
 
hengst
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Sun Jan 03, 2010 3:04 pm

Re: The Dude 6.39.2 Log Files

Thu Oct 19, 2017 2:08 pm

+1 for the old Syslog settings, and bring back the little Flags as in 6.36.4 ... Please.
 
pkelly1603
Frequent Visitor
Frequent Visitor
Posts: 78
Joined: Mon Jun 15, 2009 11:13 pm

Re: The Dude 6.39.2 Log Files

Mon Sep 24, 2018 11:56 pm

Why is this thread marked, "Solved"? As far as I can tell, dude logging is still a mess.

Who is online

Users browsing this forum: No registered users and 7 guests