Community discussions

MUM Europe 2020
 
eriitguy
Member Candidate
Member Candidate
Topic Author
Posts: 197
Joined: Thu Jan 26, 2017 1:16 pm

Feature request - Multiple logs instances

Mon Oct 23, 2017 5:33 pm

Dear Mikrotik team,

Please review a possibility to add multiple separate log instances, like it was in earlier Dude versions.
This may help us to log different events in appropriate instance in order to group them.
[attachment=0]Dude-v6-Feature-request-Multiple-logs-instances-20171023-01.png[/attachment]

Thank you!

Related topics on the forum
1. The Dude 6.39.2 Log Files
2. Logging management

----
Feature request list for Dude v6
You do not have the required permissions to view the files attached to this post.
 
hjoelr
newbie
Posts: 29
Joined: Mon Apr 28, 2008 11:29 pm

Re: Feature request - Multiple logs instances

Fri Jul 20, 2018 6:09 pm

I've been in the process of migrating from The Dude v4 to v6.42.2. I quickly realized that the logging capability is limited to send all syslog events to a single log file. I would like to be able to define multiple notifications of type 'log' and each of these show up as logging 'topics' in RouterOS. I could then utilize the Regexp filter in The Dude Settings > Syslog screen to send different types of logs to different files:

The Dude syslog improvements.png

Since the 'log'-type notifications would show up as topics in RouterOS, I could send them to different files this way:

/system logging action add disk-file-name=webfilter.log name=webfilter target=disk
/system logging action add disk-file-name=WAP.log name=WAPs target=disk
/system logging add action=webfilter topics=dude,"log web traffic"
/system logging add action=WAPs topics=dude,"log WAP events"
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 6 guests