Community discussions

MikroTik App
 
Acerot
just joined
Topic Author
Posts: 5
Joined: Tue Feb 13, 2007 10:31 pm

Lookup "Name to address" doesn't work

Wed Feb 14, 2007 6:12 pm

Hi
We have LAN, all computers in domain XXX.YYY so they have fully qualified names SOMECOMPUTER.XXX.YYY, IP addresses assigned by DHCP, so I have lookup type of the device set to "name to address".

I manually add new device, enter the name SOMECOMPUTER.XXX.YYY and add PING and NETBIOS services to probe. Then click OK.

The basic problem is, that no address is never resolved by the lookup process, there is still a gray box and services PING and NETBIOS are both in the state could not probe because of local problem. I guess it's because of missing IP address.

Now I display the device settings. The field Addresses is written in red color and no address is there, the field for address entering is grayed. Then I click OK to close the dialog window and a message pops out saying Error in addresses - Too few elements. Of course, there is no address at all. Moreover, I cannot shorten the lookup interval, because the OK button cannot be pressed.

What should I do now? Shall I click the black little arrow in Addresses field to enter at least one address of 0.0.0.0 and close the dialog to let The Dude to resolve the address at the next lookup? I did so but lookup never resolved anything for days.

Maybe there is some error at my configuration: If I ping at MSDOS prompt PING SOMECOMPUTER.XXX.YYY, it says something like PING command could not find the host SOMECOMPUTER.XXX.YYY. But if I ping only the computer name: PING SOMECOMPUTER, ping works.

I tried add new devices with both names SOMECOMPUTER.XXX.YYY and SOMECOMPUTER only. Neither worked.

Shortly, lookup doesn't work at all, it's never resolved any address.

Any idea where I should start to look for a problem? Maybe it's not The Dude problem. Maybe our LAN is improperly configured :wink:.

Thanx
 
winkelman
Member Candidate
Member Candidate
Posts: 235
Joined: Wed Aug 16, 2006 5:00 pm
Location: Amsterdam, The Netherlands

Wed Feb 14, 2007 6:40 pm

Basically The Dude send a DNS lookup to your DNS server. So if your DNS server does not know which IP address belongs to a certain hostname at a specific moment (for example because your DNS server can't look things up in your DCHP server's lease table), then there's your problem.
 
jma_sp
just joined
Posts: 19
Joined: Fri Feb 16, 2007 1:40 pm
Location: Madrid (Spain) / Madrid (España)

Wed Feb 21, 2007 3:59 pm

The function name to address doesn work in my network, everyday when computers start and some receive a new IP dude is unable to translate from name to ip so they appear to be down.
I was set lookup address to name in settings.
DNS isworking OK in the network so if i realiced a ping to a name in the console the response to tje echo is correct.
Any idea, Please.
P.D.: I have set the options in server configuration (primary DNS and secondary DNS).

Tranks from Spain
 
winkelman
Member Candidate
Member Candidate
Posts: 235
Joined: Wed Aug 16, 2006 5:00 pm
Location: Amsterdam, The Netherlands

Wed Feb 21, 2007 8:08 pm

Being able to ping by host name does not imply your DNS is setup properly. Your PC has several ways to resolve IP addresses, only one of which is to ask the DNS server.

Under Windows you could go to a command prompt and try the 'nslookup' command to actually query the DNS server. (Well, I think nslookup limits itself to querying name servers...)
 
txtanks
just joined
Posts: 1
Joined: Mon Dec 23, 2013 8:18 pm

Re: Lookup "Name to address" doesn't work

Mon Dec 23, 2013 8:37 pm

VERY tired of looking to the solution for this problem. DNS is working properly on the Dude Server host for both internal and external lookups. CLEARLY the Dude "name to IP" lookup is not working as intended.

Would greatly appreciate any further details or suggestions here.
 
lebowski
Forum Guru
Forum Guru
Posts: 1616
Joined: Wed Aug 27, 2008 5:17 pm

Re: Lookup "Name to address" doesn't work

Mon Jan 06, 2014 5:33 pm

The dude needs the fully qualified domain name to work.

If you can not "ping computer.xxx.yyy" but you can "ping computer" The dude's DNS will not resolve the address.
Either your dude server is not in the correct domain or your DNS is not configured correctly.

When you click add and type the name "computer.xxx.yyy" the address field should auto populate. When adding a device you can't add "computer" you must add "computer.xxx.yyy" and the name must be fully qualified and resolve correctly the first time otherwise the device will not populate the ip address and will not work correctly.

If the first DNS lookup fails you manually have to give the device an IP Address, if DNS is correct later it will automatically update...

Lebowski
 
drax
just joined
Posts: 1
Joined: Wed Jan 08, 2014 2:50 pm

Re: Lookup "Name to address" doesn't work

Wed Jan 08, 2014 3:07 pm

The Dude and ping/nslookup don't necessarily use the same DNS server, so if ping computer.xxx.yyy works, this doesn't imply the Dude will resolve the same name.

The Dude uses the DNS servers specified in the 'settings' page, and this server must support recursive dns queries. The way I found to test this is to use nslookup and use the command
server 111.222.333.444
to set the server, where 111.222.333.44 is the DNS server IP used in the Dude Settings

then you can test the DNS query for computer.xxx.yyy. If it works, then the Dude should be able to resolve. Recursive queries must be supported by the DNS server because otherwise the DNS server will not be able to respond to queries for foreign domains.

Also remember to set the DNS lookup interval to 1 (min)

Drax
 
silversword
newbie
Posts: 43
Joined: Tue Jul 23, 2013 3:36 pm

Re: Lookup "Name to address" doesn't work

Tue May 03, 2016 11:36 pm

The Dude uses the DNS servers specified in the 'settings' page, and this server must support recursive dns queries.
Does anyone know where these settings are in the newer Dude v6.x+? I see it in the 4.x version, but not the newest one that interfaces with the CHR dude.

Who is online

Users browsing this forum: No registered users and 10 guests