Page 1 of 1

Dude 6.44.6 on CCR (shared) : can not connect to agent - corrupted database?

Posted: Mon Dec 16, 2019 5:48 pm
by eles
Hi,
on my (shared, as in, not dedicated to Dude tasking only) CCR Dude installation, (CCR1036-12G-4S)

previously, on 6.,44.5 all seemed to work fine;

Upgraded to 6.44.6, all RouterOS devices can not connect to agent (including the device on which the Dude server runs).

(all devices give status
"connection to agent (agent-device name here) not ready (not connected, next attempt at xxxxxx), next attempt at xxxxxx" (xxxxxx are the time of next connection)

Tried unsuccessfully:
- copying dude/files and dude/dude.db using FZ out to PC, deleting or renaming dude/files/default dir, restoring dude/files/default and db from PC
- deleting the entire dude dir and re-enabling dude to re-create dir structure, then stopping dude to copy the db back in

In both above cases, devices are remembered, but can't connect to agent.

What worked:
- deleting dude db (I have a copy) and re-creating content by hand

So it looks like it corrupted its database?

Is there a way to un-break the database file so it's accepted on new version again?

Kind Regards
el es

Re: Dude 6.44.6 on CCR (shared) : can not connect to agent - corrupted database?

Posted: Sun Jan 17, 2021 5:33 pm
by ashjones
*nudge*
I am having the same issue on a CCR-1036-12G-4S also. v6.48. I've spent AGES building network maps - can't bring myself to scrap it (27 remote sites), and start again!!! Please, can anyone help?