Community discussions

MUM Europe 2020
 
matt7522
just joined
Topic Author
Posts: 4
Joined: Fri Sep 01, 2006 8:20 pm
Location: Estes Park, CO

No dude in linux using wine for me...

Fri May 04, 2007 12:04 am

I'm running simplyMEPIS (ubuntu-based) linux with the current version of wine. Wine runs some simple windows apps ok; however, when I run the dude (v. 2.2 and 3.x beta), it only makes it as far as letting me log in to the remote host 127.0.0.1 before crashing and closing. I see a few buttons on the left, as though the login were successful, then, suddenly, the crash. The dude then generates a little report that says "ACCESS VIOLATION" followed by a lengthy list of hexadecimal numbers.

Wasn't sure how to debug this. I ran WINEDEBUG using the relay channel per the advice of winehq.com, but the output appeared error-free, and incredibly verbose (the output file was 1GB!). I have another linux PC also with simplyMEPIS, and I see identical behavior on it.

I tried running winbox to see if the scope of the problem was limited to the dude. These PCs won't run winbox properly either - the window comes up, but there's no writing, even though the mstcorefonts package is installed.

Thought I would see if anybody has seen this. Mostly in these forums it looks like people successfully run dude+winbox on wine; alternatively I would consider running a different linux distro that people have had luck with in running the dude.
 
versa
just joined
Posts: 2
Joined: Fri May 04, 2007 1:18 am

Fri May 04, 2007 1:24 am

Not sure about the dude but I have had no problems running winbox with wine on PcLinuxOs http://pclinuxos.com/
Live cd so you can test it before installing
 
matt7522
just joined
Topic Author
Posts: 4
Joined: Fri Sep 01, 2006 8:20 pm
Location: Estes Park, CO

Fri May 04, 2007 9:57 pm

I like that suggestion--running linux on live cd--that will save me some time! So I tried pclinuxos in live cd mode. Winbox worked for me too! Alas, the dude failed to connect to remote host 127.0.0.1 again, though this time it did not generate an error report. It simply says: "Error: connection closed" and brings me back to the dude window.

So unless there's a way to troubleshoot this, I guess I'm in search of another distro that is dude-friendly...incidentally I tried it on an old suse 9.2 box I have, dude ran as user me just fine, but it would not run as root, which it needs to in order to successfully ping clients...
 
stealthwave
just joined
Posts: 22
Joined: Fri May 27, 2005 3:00 am
Location: Texas

Fri May 18, 2007 8:26 am

Haven't tried the dude, but winbox works fine for me on Ubuntu and Fedore Core 6.
 
versa
just joined
Posts: 2
Joined: Fri May 04, 2007 1:18 am

Sat May 19, 2007 2:02 am

I see there is a dude server package that runs on the new V3b7, however dont even bother to try it on a routerboard, well a RB150 or a RB532 there just is not enough processor power to run it, it can be configured either with the dude client or via the web interface. I will have to give it a go on a PC with routeros installed on it but I imagine it should be ok. It will be interesting to see if the new RB333 an RB1000's will be able to handle it
 
kvan64
Member Candidate
Member Candidate
Posts: 186
Joined: Tue Apr 10, 2007 1:54 pm
Location: Brisbane Australia
Contact:

Re: No dude in linux using wine for me...

Sun Nov 04, 2007 12:53 am

Hi guys, Could your version of liveCD be used to generate a self-signed certificate?

Who is online

Users browsing this forum: No registered users and 7 guests