Community discussions

MikroTik App
 
User avatar
NAB
Trainer
Trainer
Topic Author
Posts: 507
Joined: Tue Feb 10, 2009 4:08 pm
Location: UK
Contact:

Scan of remote network doesn't show all hosts

Wed Jun 24, 2020 2:13 pm

I'm setting up a The Dude test machine and have found a problem - Setting up a simple scan of a remote network only displays some of the hosts on the network.

Running on a RB100AHx4, ROS version 6.47.

In the following examples, real IP addresses are replaced with TEST-NET-x networks.

The IP address of the ROS/Dude server is 192.0.2.10/24 and I am trying to scan the network 198.51.100.0/24.
  • The appropriate routes are in place and there are no firewall rules blocking traffic.
  • I know there are 33 hosts in the network 198.51.100.0/24.
  • If The Dude does a fast scan, it shows 2 hosts in the network.
  • If The Dude does a reliable scan, it shows 10 hosts in the network.
  • I can manually ping all 33 of the hosts on the remote network from the command line on The Dude server.
  • If I change the scan to only look for one IP address for a host I can ping manually - 198.51.100.106/32, The Dude says it doesn't exist.
  • If I run the same scan to 198.51.100.106 and packet trace, then I see: An outbound ping, a reply. Immediately the reply is received, The Dude sends out udp/137 and tcp/8291 and receives replies (port unreachable and RST,ACK respectively). It then sends out two more pings which are both replied to.
  • If I run a scan on an unused IP, I only see three pings go out (obviously with no replies) and that's it.
As far as I can see, The Dude is seeing the remote hosts - it wouldn't try to connect to udp/137 ot tcp/8291 if it did't, it's just not putting them in its database or displaying them to me.

Does anybody have any ideas?

Who is online

Users browsing this forum: No registered users and 9 guests