Page 1 of 1

Dude VM Licensing Issue

Posted: Wed Aug 05, 2020 1:42 am
by jwatson
We have been using an x86 version 6.42.1 (stable) for hosting The Dude. It runs on a virtual machine. About a month ago it started having an issue
with its license. Now it boots up to the console login prompt and then shuts down. I have a backup that I tried restoring to a VM that I loaded 6.47 on,
but The Dude comes up blank, all of our devices and maps are gone. Any ideas? I'm going to try building up a new 6.42 VM to restore to to see if that
helps.

Re: Dude VM Licensing Issue

Posted: Wed Aug 05, 2020 1:13 pm
by Cha0s
RouterOS backups do not include the Dude data.

You need to backup the dude database separately using the following command:
/dude export-db dude.db

Re: Dude VM Licensing Issue

Posted: Wed Aug 05, 2020 3:43 pm
by jwatson
Okay, thanks. That's good to know. Is there a secret to getting it out of this "Demo Licensee Expired" shutdown mode so that I can apply a license to it? I only needed the backup because I couldn't figure out how to get it back going. It is running on a VM and has been for years without issue. Then it suddenly became unlicensed, without warning.

Re: Dude VM Licensing Issue

Posted: Thu Aug 06, 2020 12:22 am
by Sob
License for x86 version depends on software ID, which is computed from how disk identifies itself in system (I think model and serial number) and some random (probably) data on disk.

The former can be reason why your license was lost, if the virtual disk changed its identification for some reason. It happens for sure when you move it from one virtualization environment to another (e.g. VMware to VirtualBox). Upgrades of VM host could probably change it to, although normally it doesn't happen.

Try to remember if you did some upgrades that could cause it. If so, try to install older version of virtualization software somewhere and see if RouterOS VM works correctly under it. If it does, examine how disk identifies itself in old and new version. If it differs, it could be possible to override it.

For example: viewtopic.php?f=15&t=99865 (you'd need something like this for whatever you use)

Re: Dude VM Licensing Issue

Posted: Tue Aug 18, 2020 1:10 pm
by FeDoR88
License for x86 version depends on software ID, which is computed from how disk identifies itself in system (I think model and serial number) and some random (probably) data on disk.

The former can be reason why your license was lost, if the virtual disk changed its identification for some reason. It happens for sure when you move it from one virtualization environment to another (e.g. VMware to VirtualBox). Upgrades of VM host could probably change it to, although normally it doesn't happen.

Try to remember if you did some upgrades that could cause it. If so, try to install older version of virtualization software somewhere and see if RouterOS VM works correctly under it. If it does, examine how disk identifies itself in old and new version. If it differs, it could be possible to override it.

For example: viewtopic.php?f=15&t=99865 (you'd need something like this for whatever you use)
We have a mirror server (that's what we call it in Spain) where a copy is made every 24 hours, we have had similar license problems but when restoring everything correct.