Page 1 of 1

Web Access in Dude Server 6.45.7

Posted: Mon Sep 21, 2020 12:02 pm
by XenosTh
Hello everyone,
I would like to know if there is a way to have-setup Web Access in Dude Server 6.45.7.
I have it on a RB750gr3 Hex device and i want to be able to access it from any network for monitoring purposes.
Any help is appreciated!!!

Re: Web Access in Dude Server 6.45.7

Posted: Mon Sep 21, 2020 1:54 pm
by cdiedrich
Web access to the dude is pretty limited, but possible.
Just log into webfig of your hEX and navigate to Dude.
It's totally OK to view network maps which already have been created - but not much more.

It might be a good idea to create a separate user for this together with a custom skin.

-Chris

Re: Web Access in Dude Server 6.45.7

Posted: Mon Sep 21, 2020 3:04 pm
by XenosTh
cdiedrich i got the idea, thank you for your reply.
I did that and made a user with only read permission.
Is there a way to only show the network maps and not all the other features?

Re: Web Access in Dude Server 6.45.7

Posted: Tue Apr 06, 2021 8:48 pm
by kennnnnnnneth
How is this done? I have installed dude, enabled it, it is running, but there is absolutely no way to access it from webfig. I even navigate to https://myrouter/webfig/#Dude and it just takes me to the quick setup page.

Dude is 100% running, but also apparently doesn't work in webfig??

Re: Web Access in Dude Server 6.45.7

Posted: Wed Apr 07, 2021 4:56 am
by 2frogs
Screenshot_20210406-204552_Opera.jpg
Maybe you have a custom skin and have Dude menu blocked. https://myrouter/webfig/#Dude will return you to the Quickset, you have include :Menu_Name. Such as https://myrouter/webfig/#Dude:Network_Maps

Re: Web Access in Dude Server 6.45.7

Posted: Wed Apr 07, 2021 10:04 pm
by kennnnnnnneth
I did check that out, but I have never used a custom skin, I like being able to see absolutely everything.

I did attempt to navigate to https://myrouter/webfig/#Dude:Network_Maps and a few others i see in your screenshot (with myrouter replaced with my router's IP), but each time I get bounced back to quickset.

I went to the terminal and ran /dude print and it came back running.

Disabled/rebooted, renabled/rebooted, tried again, still nothing, dude is still running. I reinstalled it again earlier this morning just for kicks and that did not help.

Screenshots attached

Re: Web Access in Dude Server 6.45.7

Posted: Thu Apr 08, 2021 8:13 am
by oskarsk
Screenshots attached
kennnnnnnneth, please let us know the device model you are using here.

Re: Web Access in Dude Server 6.45.7

Posted: Thu Apr 08, 2021 10:50 pm
by kennnnnnnneth
kennnnnnnneth, please let us know the device model you are using here.
I am using a RB760iGS hEX S running 6.47.9 (long-term).

I finally broke down last night and nuked my configuration and rebuilt it and still could not get Dude to show up. It's generating files and is "running" but inaccessible.

Re: Web Access in Dude Server 6.45.7

Posted: Fri Apr 09, 2021 5:50 am
by kennnnnnnneth
update:

I have resorted to spinning up an unlicensed Windows 10 VM to run Winbox and Dude software client and it's working (I think). At the very least it's showing up now. Still nothing in webfig though. I'll freely admit I'm a linux snob and just hate having to use Windows for anything, and while I'm normally okay with resorting to a VM, in this case it makes me uncomfortable; if I'm going to be using something to monitor and administer networks, it really needs to be platform-neutral. Can we say this is a bug, or am I missing something here to enable Dude via webfig?

Re: Web Access in Dude Server 6.45.7

Posted: Fri Apr 09, 2021 6:18 am
by 2frogs
Maybe you should a netinstall. I had a new hEX S that was in a boot loop from the box. I preformed a netinstall and it has been fine since.

Re: Web Access in Dude Server 6.45.7

Posted: Fri Apr 09, 2021 7:49 am
by kennnnnnnneth
Was just about to try a netinstall when it started working! after having mostly configured my Dude server in the Windows client, it started showing up in webfig. No reboot, no reinstall, just started showing up. So, so weird.