Community discussions

MikroTik App
 
nsprangers
just joined
Topic Author
Posts: 1
Joined: Wed Feb 13, 2008 7:26 pm

The Dude in WINE - cannot connect to remote server

Wed Feb 13, 2008 8:08 pm

I'm attempting to run the Dude in an Ubuntu 7.10 VM. With 2.2 it says "Error: connection closed". I tried 3.0 and was only marginally more successful: it said "Getting Stuff" (I got excited there!) but then asked if I wanted to "upgrade" to 2.2. First I said no, and it disconnected, then I said yes and it still disconnected.

If anyone else has similar experiences, please let me know.
 
Johann
just joined
Posts: 10
Joined: Wed Jan 23, 2008 2:43 pm
Location: Germany

Re: The Dude in WINE - cannot connect to remote server

Wed Feb 20, 2008 4:35 pm

Hello,
successfully work with 3.0beta7 on OpenSuse 10.1 with XVNC and wine.
See comments arround ping and non root users at the FAQ.
On the server connect to the LAN address instead of 127.0.0.1 .
Also enable tcp ports 2210 and 2211 at your servers firewall.
How to ebug at linux server:
ps xfu |grep bin/wine
Should show a process named ....drive_c/Program Files/Dude/dude.exe --server
Note that Process ID
lsof -p ProcessID |grep -e UDP -e TCP

If your network has high latency or you are working remotely the link between Server and client
does not work stable.
Johann
 
RouterPimp
just joined
Posts: 11
Joined: Wed Nov 22, 2006 7:18 pm
Location: Wilmington, NC

Re: The Dude in WINE - cannot connect to remote server

Thu Mar 06, 2008 6:26 pm

Greetings,

I am also running Ubuntu 7.10, and getting the "Error: connection closed" message. I have issued the ps xfu |grep bin/wine command, and get the following output:

1000 8879 0.0 0.2 2976 752 pts/1 S+ 11:14 0:00 \_ grep bin/wine
1000 8764 0.2 0.7 4360 1900 ? Ss 10:55 0:02 /usr/bin/../lib/../bin/wineserver

I have the Dude client opened on the desktop, but do not see the process named ....drive_c/Program Files/Dude/dude.exe --server

It is possible to connect a Linux Dude client to a Windows server, correct?

Any recommendations would be greatly appreciated.

Thanks!
 
riza
newbie
Posts: 30
Joined: Fri May 28, 2004 7:15 pm

Re: The Dude in WINE - cannot connect to remote server

Sun Mar 09, 2008 6:10 am

If you want to connect using dude client normally, you can try to limit your dude client downlink traffic to 256k (max). I have difficulty to connect dude server under wine, specially if i use wireless connection to remote our dude server.

Using PCQ connection with dst-address classifier and rate=256k, i can remote my dude server.

My conclusion about this case was dude server using wine need more than 3 Mbps to passthrough all data to dude client. That's why you got "connection closed" after several seconds you can connect using dude server.
 
gacopl
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Sun Jul 29, 2007 5:11 pm
Location: Poland

Re: The Dude in WINE - cannot connect to remote server

Tue Apr 01, 2008 4:26 pm

Hello in order to make your server run correctly under ubuntu 7.10 all you have to do is just not to start whole Dude, but just dude.exe --server and then connect to it from other machine. Normal start of dude.exe does not bring up the server !!

cheers

Michal
 
calarndt
just joined
Posts: 1
Joined: Sun Apr 13, 2008 4:47 am

Re: The Dude in WINE - cannot connect to remote server

Sun Apr 13, 2008 4:54 am

On dapper do as suggested above however the server needs to be root ie
do this...

sudo wine .wine/drive_c/Program\ Files/Dude/dude.exe --server &

When you run the GUI tell it to look for a remote server but use the local ip!

That's it! Runs mostly perfect. (I got an exception when I tried to import images)
 
pnti
just joined
Posts: 1
Joined: Mon Aug 04, 2008 5:50 pm

The Dude v3 works fine with Ubuntu 8.04

Mon Aug 04, 2008 6:02 pm

I couldn't connect to the server using The Dude v2 on Ubuntu 8.04. I tried your advices without success.

Then I removed version 2 and installed v3. Everything works fine.
 
User avatar
cybernet
newbie
Posts: 25
Joined: Wed Jan 23, 2008 6:48 pm
Location: Jakarta, Indonesia

Re: The Dude in WINE - cannot connect to remote server

Wed Aug 06, 2008 1:50 pm

yup work fine with me, i use 3.0beta8 as server on windows XP, and 3.0beta8 as client on Ubuntu 7.10 work with wine.

before, i have problem with remote 3.0beta7 on Ubuntu 7.10 (can not connect to the server/ping from dude time out), then i upgrade with the same version dude 3.0beta8, it's work good.

Who is online

Users browsing this forum: No registered users and 14 guests