Page 1 of 1

dude 4.0beta2 web access under wine

Posted: Fri Aug 06, 2010 8:54 am
by cobassc
I have dude 4.0beta2 setup under wine. Everything is working fine apart from the web access. this is the netstat results:

tcp 0 0 *:ssh *:* LISTEN
tcp 0 0 *:2210 *:* LISTEN
tcp 0 0 *:2211 *:* LISTEN
tcp6 0 0 [::]:ssh [::]:* LISTEN

as you can see no web access running on port 80. it is activated in the dude server configuration.

Re: dude 4.0beta2 web access under wine

Posted: Fri Aug 06, 2010 11:46 am
by cobassc
Please help. I am waiting for the answer to see if i have to format the pc and install windows os because i really want to use the web access for network troubleshooting

Re: dude 4.0beta2 web access under wine

Posted: Tue Aug 10, 2010 9:20 am
by cobassc
ok still no reply on this only views. I guess i will have to format the machine and install windows.

thanks anyway.

Re: dude 4.0beta2 web access under wine

Posted: Thu Feb 24, 2011 1:27 pm
by jtroybailey
Sorry to dig up an old thread but i have just come across the same issue. The Dude 4 Beta 2. I have tried changing the default port. Running under WINE.

Re: dude 4.0beta2 web access under wine

Posted: Thu Feb 24, 2011 4:41 pm
by lebowski
In regular windows the web browser portion is started as another thread. I would bet that the method used to start the web server is not handled correctly.

Re: dude 4.0beta2 web access under wine

Posted: Sun Mar 20, 2011 3:34 am
by stepw
It's actually another process, not thread that web-server starts in. Web-server instance seems to be using named pipes to communicate with the local server instance, which doesn't work well under wine.

I submitted a feature request a while ago to allow web-server instance to communicate via TCP/IP like client instance does. That would also allow having web-server on a host other than server main node.