Community discussions

 
goriem
just joined
Topic Author
Posts: 2
Joined: Thu Sep 02, 2010 1:15 pm

Client crash when adding static network element

Thu Sep 02, 2010 1:53 pm

Hi
first of - great program - love it!

I have been using The Dude since ver. 3 - something, lately i upgraded to 4.4 beta and everything worked ok - until now

I am no longer able to add a static network element to any maps in the dude, all other things work as expected.

everytime i try and add a static element the program crashes with a visual c error or this trace:

4.0beta2 ACCESS VIOLATION at: 5e8034
eip=5e8034 eflags=210206
edi=4d1dc30 esi=ffffff58 ebp=22f360 esp=22f328
eax=4d1dc30 ebx=22f438 ecx=1a7 edx=1a7
log:
cw: 1407 41a420
sm: 573304
backtrace:
5e81c1
450d66
450aad
51d5e1
51d6e6
51e335
568af6
5ae28a
573c1c
5742d4
41b715
4061ef
406c9d
40f03b
40f088
75eafd72
75eafe4a
75eb018d
75eb022b
414cec
43f2b5
5adc24
709c98
40124b
4012b8
760dd0e9
775519bb
7755198e
modules:
400000 dude.exe
75e90000 USER32
76090000 kernel32
77510000 ntdll
stack: 0 6447268
38f42200 a7010000 70f32200 2b805e00
00000000 10000000 60f32200 a7010000
00003e00 00000000 01000000 38f42200
180fb601 80f89f04 80f32200 c1815e00
38f42200 58ffffff ff000000 38f42200
44f42200 00000000 a0f32200 660d4500
38f42200 805d7004 76090000 01000000
44f42200 38f42200 c0f32200 ad0a4500
38f42200 805d7004 ea665777 44f42200
180fb601 38f42200 20f42200 e1d55100
38f42200 2823b601 905c7004 20f42200
039c5e76 00003e00 00f42200 660d4500
44f42200 80108e04 b80eb601 900f8e04
e00db601 44f42200 20f42200 ad0a4500
44f42200 80108e04 14f92200 900f8e04
180fb601 5c7b8600 70f42200 e6d65100
38f42200 80f89f04 2823b601 44f42200
30dcd104 30dcd104 d7ddd104 28d0cf04
28d0cf04 28d0cf04 28933e00 d0c5b501
900f8e04 50055a0b f2ea0000 80f89f04
0020bc01 98ebc804 f0f42200 35e35100
80f89f04 900f8e04 00000000 14f92200
fa995177 93f4d800 feffffff fd685777
1f6


using the dude on windows server

anyone have any ideas?

thanks!
 
lebowski
Forum Guru
Forum Guru
Posts: 1616
Joined: Wed Aug 27, 2008 5:17 pm

Re: Client crash when adding static network element

Thu Sep 02, 2010 5:27 pm

A quick work around is to copy one of your static elements and paste it (try to use one that doesn't have active links connected to it, active links get pasted too and wind up not connected to anything and stuffed way up in the top left corner of the map (another bug)).

I have the same issue and submitted it to support. I suppose they will fix it soon enough.
 
goriem
just joined
Topic Author
Posts: 2
Joined: Thu Sep 02, 2010 1:15 pm

Re: Client crash when adding static network element

Fri Sep 03, 2010 9:59 am

Hi lebowski

Thanks - your suggestion works, luckely, i wonder why i havent tried that my self - dooh

well we await a bug fix then.
 
lebowski
Forum Guru
Forum Guru
Posts: 1616
Joined: Wed Aug 27, 2008 5:17 pm

Re: Client crash when adding static network element

Fri Sep 03, 2010 5:07 pm

Yeah that one is particularly nasty... client exit crash button just click HERE :)
 
ryz
just joined
Posts: 13
Joined: Sun May 27, 2007 5:10 pm

Re: Client crash when adding static network element

Wed Sep 22, 2010 6:38 pm

I have the same problem. It's hard because I don't have any object so I can't copy and paste it :(

I'm waiting for the next dude update :)

Ryz
 
lebowski
Forum Guru
Forum Guru
Posts: 1616
Joined: Wed Aug 27, 2008 5:17 pm

Re: Client crash when adding static network element

Wed Sep 22, 2010 7:08 pm

Proceed with caution and backup your dude server before you paste anything into your dude server.

The below xml will add a static object named Mead.

<?xml version="1.0" ?>
<dude version="4.0beta2">
<NetworkMapElement>
<sys-type>1668</sys-type>
<sys-id>29590997</sys-id>
<sys-name>Mead</sys-name>
<itemType>static</itemType>
<itemX>98</itemX>
<itemY>123</itemY>
<itemUseUpColor>yes</itemUseUpColor>
<itemUseShape>yes</itemUseShape>
<itemUseFont>yes</itemUseFont>
<itemUpColor>05A5FA</itemUpColor>
<itemFont>0C00000000000000000000000000000000000000000000010000000042697473747265616D20566572612053616E7300000000000000000000000000</itemFont>
</NetworkMapElement>
</dude>
 
rnorthgs
just joined
Posts: 1
Joined: Wed Oct 13, 2010 5:05 pm

Re: Client crash when adding static network element

Wed Oct 13, 2010 5:18 pm

Has anyone gotten this to work?
I don't have any static elements yet and I can't paste this xml in either.
I have even tried copying a device element and pasting it into notepad and then modifying it to match lebowski's xml and then re-copy/paste into dude - I get nothing. The paste icon is available, but nothing ends up on the screen.
I have shut the client down and re-started it - I just can't make a static element.

any other ideas?

-gs
 
lebowski
Forum Guru
Forum Guru
Posts: 1616
Joined: Wed Aug 27, 2008 5:17 pm

Re: Client crash when adding static network element

Thu Oct 14, 2010 11:02 pm

I came here to grab the object and sure enough when I went to paste it, I could not. I restarted the client and then I was able to paste it.

Who is online

Users browsing this forum: No registered users and 9 guests