Community discussions

MikroTik App
 
mpaluck
just joined
Topic Author
Posts: 6
Joined: Fri Apr 03, 2009 5:14 pm

Problems in 3 and 4 going bnack to 2.2

Fri Jul 08, 2011 7:31 pm

2.2 worked great but lacked some of the newer features, like copy and paste but it was extreamly reliable.

I upgraded to 3.5 it has just not worked out. It has proven to be untrustworthy. I have a lot of problems with polling. Items go down but the icons stay green. SNMP text is not updated on the icons. If an item goes down then gets acknowledged, it will go straight to acknowledged the next time it goes down.

I upgraded to the latest 4 beta and I find the same issues and now the executable function does not work.

One on the greatest things about the Dude is the ability to make your own external pollers.

Please let me know if it sounds like I just have something misconfigured. I have been using the Dude for years.
 
lebowski
Forum Guru
Forum Guru
Posts: 1616
Joined: Wed Aug 27, 2008 5:17 pm

Re: Problems in 3 and 4 going bnack to 2.2

Mon Jul 11, 2011 9:50 pm

I found that in windows you should disable UAC on any newer version of windows i.e. win7 and server 2k8 also trim any logging you are doing to get fewer false positives. In notification disable log to syslog. Remove any logging you don't absolutely need.

The IO routine is certainly busy and disk access seems to use the same routine so it seems heavy disk access can cause a false positive.
 
mpaluck
just joined
Topic Author
Posts: 6
Joined: Fri Apr 03, 2009 5:14 pm

Re: Problems in 3 and 4 going bnack to 2.2

Tue Jul 12, 2011 5:20 pm

By removing logging do you mean graphing the history? I understand the syslog part. I am running it on 2003 Ent so the UAC is not my problem, but that is good to know.

Thanks,
Mike
 
lebowski
Forum Guru
Forum Guru
Posts: 1616
Joined: Wed Aug 27, 2008 5:17 pm

Re: Problems in 3 and 4 going bnack to 2.2

Tue Jul 12, 2011 11:05 pm

I mean syslog, one under "notification" in settings and under "Logs" just disable whatever logging you won't use.
 
earljack
newbie
Posts: 40
Joined: Thu Jan 22, 2009 7:34 pm

Re: Problems in 3 and 4 going bnack to 2.2

Wed Jul 20, 2011 9:57 pm

I have had the same issue with the ACK bug ever since v3. If a device goes down and you acknowledge it, then it comes back up, then it goes down again it will show acknowledged as soon as it goes down. It should show red whenever a device goes from up to down even if you have previously acknowledged it. It is obvious to me that this is how it SHOULD work. This SHOULD be considered a bug, but at this point I'm starting to think that this is how Mikrotik intends it to work. This bug has been reported several times and has existed now for 2 versions. This should be an easy bug for them to fix, but they seemingly refuse to. Or maybe they are still just unaware. Haha maybe Mikrotik just never has any devices go down at their office so they have never seen this bug.

I'm also having other problems in v4b3. It seems like several of the built in probes don't work properly. The memory probe has been especially troublesome. It basically won't work on any of my Mikrotik devices. I just consider it broken. The disk probe has been unstable as well. It randomly shows down. Today the CPU probe has also started randomly showing down. Basically the only probe that is reliable is the ping probe. If the ping probe ever stops working the Dude will be 100% useless to me.

I love the Dude, but I'm about fed up with it because it's starting to seem like it's being abandoned by Mikrotik. I wish they would devote more development time to it. It could seriously be a valuable tool. I know v4 is still in beta, but I feel like I have to complain because if these problems go unnoticed they will exist all throughout v4 like the v3/v4 ACK bug. I'm anxious to use some of the new features in v4. I hope you guys can figure out how to get these problems fixed!
 
User avatar
geoffsmith31
Member Candidate
Member Candidate
Posts: 151
Joined: Fri Nov 05, 2010 6:08 am
Location: Toowoomba, Australia

Re: Problems in 3 and 4 going bnack to 2.2

Sun Jul 24, 2011 12:16 am

I have not found versions 3 & 4 to be unusable, but there are a few things that don't quite work the way I'd like them to. In most cases I have found ways around these "limitations", however the ACK/UNACK issue described is annoying and I'm still having to manually UNACK things when the problem is resolved to prevent future problems from being masked.

I have some devices that I would prefer to be permenantly ACK-ed as they are turned on and off as part of the normal operation but I would like to have them on the maps so we can easily see how they are performing when they are on. Most devices though, are permenantly on and when something goes wrong I will ACK that device to stop its "down" state from masking other issues that may occur on that sub-map. The problem is then that I need to remember to UNACK the device when it comes back up, otherwise I may not see that it has gone down again later. I am not the only one that uses The Dude either so knowing what needs to be UNACKED is very difficult to track.

It would be good to have an option to either ACK permenantly, or ACK until the device/probe comes back up at which time the status reverts to UNACK automatically. Alternatively, is there a way to programatically UNACK a device or probe? That way a notification could be created to UNACK on transition from ACK -> UP and then applied to those devices that need that function.

Who is online

Users browsing this forum: No registered users and 8 guests