Page 1 of 1

Dude has stopped email notification on service down change

Posted: Wed Jul 18, 2012 3:53 am
by Scott
Greetings,

I'm running the dude 3.6 and haven't made any significant config change for quite some time. Recently I put a new ADSL router in and changed the SNMP OID it used by a probe to check the link speed. I use the probe to watch that OID to see if the link goes down (=0)

I don't know what has happened, but it was working fine but for the last few weeks now I only get email notifications when the service changes from down->up. I'm not getting notifications when it changes to unstable or down anymore. I've checked the notifications settings and it's ticked to notify on all actions, I tried unticking and retacking them all to "reset" the config, but it still doesn't notify. The email config works because I get the change to up emails no problems.

If link goes down, I see the device colour on the Map change to blue, but no notification until the service comes back up again.

I guess I've made some other change without realising it, but I can't figure out how to reset it or what to change to get it working again.

Re: Dude has stopped email notification on service down chan

Posted: Wed Jul 18, 2012 9:25 pm
by lebowski
Create a new notification and put unstable->down, up->down and down->up then assign it to this device only.

Re: Dude has stopped email notification on service down chan

Posted: Thu Jul 19, 2012 6:09 am
by geoffsmith31
If the device goes blue when the link goes down then it must have been "Acked" at some stage. This is most likely causing the problem as you probably do not have a notification for when it goes from unstable->acked.

Either UNack the device/probe or tick the notification for unstable->acked

Re: Dude has stopped email notification on service down chan

Posted: Fri Jul 20, 2012 1:34 am
by lebowski
shazam - geoffsmith31 I bet you are correct! Since it should go yellow (some probes down) or red(all probes down).