Community discussions

 
baczan
newbie
Topic Author
Posts: 49
Joined: Wed Aug 17, 2005 12:12 pm

Remove "unknown" interface

Tue May 13, 2008 10:20 am

How to remove "unknown" interface in wireless access-list without removing all lines ?
 
User avatar
krigevr
Member Candidate
Member Candidate
Posts: 155
Joined: Mon Aug 20, 2007 7:02 pm
Location: South Africa

Re: Remove "unknown" interface

Tue May 13, 2008 11:23 am

Give me some more information please,
like the output of your Access List, clearly showing which one you want to remove?

-K
 
baczan
newbie
Topic Author
Posts: 49
Joined: Wed Aug 17, 2005 12:12 pm

Re: Remove "unknown" interface

Tue May 13, 2008 4:25 pm

When i remove interface from mikrotik i have situation:
mac-address=00:4F:62:03:25:5C interface=(unknown) signal-range=-120.120
authentication=yes forwarding=no ap-tx-limit=0 client-tx-limit=0
private-algo=none private-key="" private-pre-shared-key=""


/interface wireless access-list remove [/interface wireless access-list find interface="unknown"]
input does not match any value of interface
 
User avatar
krigevr
Member Candidate
Member Candidate
Posts: 155
Joined: Mon Aug 20, 2007 7:02 pm
Location: South Africa

Re: Remove "unknown" interface

Tue May 13, 2008 6:31 pm

See how this works for you:
:local name

/ip hotspot

:foreach i in=[/interface wireless access-list find authentication=yes] do={
    :set name [/interface wireless access-list get $i interface];
    :if ($name = "(unknown)") do={
            /ip hotspot remove $i;
            :log info "Wireless Access List Interface # $i Removed";
            };
}
Edit: This will only work for interfaces that use Authentication, which I chose as a 'common denominator'. You can change this to whatever common denominator you wish, but I'm sure that one will do fine.

Enjoy!
-Krige
 
asef
just joined
Posts: 2
Joined: Tue Feb 20, 2018 12:39 pm

Interface Problem

Mon Apr 16, 2018 1:25 pm

Hello dear friends
Can anyone help me please
I have a CCR1009-8G-1S-PC Mikrotik router
I have configured ether1 as WAN, ether2 LAN this IP address (192.168.1.1) DHCP Server is enabled and ether3 as a Hotspot (172.16.1.1)
After configuring of Hotspot my ether2 interface (LAN) which I configured automatically gets IP address of ether3 interface (Hotspot) 172.16.1.1 this IP address then i can not change it.
I did not create any bridge at all here
 
User avatar
ADahi
Member Candidate
Member Candidate
Posts: 114
Joined: Thu Sep 21, 2017 7:16 pm
Location: Iraq, Ninavah
Contact:

Re: Remove "unknown" interface

Mon Apr 16, 2018 7:07 pm

/interface wireless access-list remove numbers=[find where !interface]
try it
may help you
RB1100AHx2, CCR1009-8G-1S, CRS125-24G-1S-RM, RB44Ge, RB2011UiAS-RM, CCR1036-12G-4S, BaseBox 5, OmniTIK 5, Metal 2, SXT SA5, mAP, RB951G-2HnD, RB2011UiAS-2HnD-IN

Who is online

Users browsing this forum: telepro and 5 guests