Community discussions

 
asf23
just joined
Topic Author
Posts: 2
Joined: Sat Sep 12, 2015 6:42 pm

API to get info from LTE interface

Sat Sep 12, 2015 8:15 pm

Greetings,
mini-PCIe LTE modem
according to the wiki (http://wiki.mikrotik.com/wiki/API_command_notes):
in the section "CLI commands that are not in API" there is no mention of the CLI command "info".
Does API can handle this command ?
It works in the terminal (for example):
/interface lte info lte1
It works in the script (for example):
#LTE signal levels
/interface lte info lte1 once do={
:log info "RSSI:= $"rssi""
.....
:log info "SINR:= $"sinr" dB"
}
Unfortunately i can not manage this command ("info") by API.
Of course, i can try to set the global variables for signal levels in the script and then retrieve/parse its by sending API command like this:
"/system/script/environment/print"
But get those variables for monitoring signal levels in the user application in such way... :lol:
Any help will be appreciated.
P.S.: when LTE modem is in 3G network there is no critical signal parameters for UMTS such as RSCP and Ec/Io in UI - wish these parameters will be incluled in some next upgrades. :)
 
ShyLion
newbie
Posts: 40
Joined: Thu Sep 28, 2017 7:24 am

Re: API to get info from LTE interface

Thu Aug 15, 2019 12:41 pm

Any updates on the topic?
I also woul like to get "/interface/lte/info" via API.
 
ShyLion
newbie
Posts: 40
Joined: Thu Sep 28, 2017 7:24 am

Re: API to get info from LTE interface

Thu Aug 15, 2019 4:27 pm

On device:
/system script
add dont-require-permissions=no name=lteinfo owner=busadmin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
    ":global lteinfo [/interface lte info [find] once as-value]; :global lteinfotime [/system clock print as-value]"
/system scheduler
add interval=1m name=lteinfo_1min on-event=lteinfo
API call:
/system/script/environment/print
=.proplist=name,value
?name=lteinfo
?name=lteinfotime
?#|
Thankyou very much
 
gilester
just joined
Posts: 3
Joined: Sat Feb 01, 2014 1:07 pm

Re: API to get info from LTE interface

Fri Sep 20, 2019 4:58 pm

I found this thread when I was Googling for the same question and thought I'd post my answer in case it helps anyone else (I realise it's some years since the original post)

The info command (now) works via the API - tested with ROS 6.45.5.

The following API call returns the RSSI, session-uptime and registration-status for the first LTE connection.

/interface/lte/info
=number=0
=once
=.proplist=rssi,session-uptime,registration-status

Hope that helps,
Giles

Who is online

Users browsing this forum: No registered users and 5 guests