Community discussions

MikroTik App
 
mountainman
just joined
Topic Author
Posts: 5
Joined: Mon Mar 31, 2014 4:24 pm

get supported-bands not working in 6.33

Mon Jan 04, 2016 9:19 pm

I recently upgraded from 6.18 to 6.33 and have found that the command ":put [get wlan1 supported-bands]" from the "interface wireless info" menu no longer works! I get an error message "bad command name get ...". That command in 6.18 and lower used to show results like "2ghz-b;2ghz-g;2ghz-10mhz;2ghz-5mhz;2ghz-n;2ghz-n-10mhz;2ghz-n-5mhz". How do I get this information now in 6.33?
 
User avatar
PaulsMT
MikroTik Support
MikroTik Support
Posts: 283
Joined: Tue Feb 10, 2015 3:21 pm

Re: get supported-bands not working in 6.33

Tue Jan 05, 2016 8:13 am

You can use "hw-info" to see all possible bands, channel widths, and frequency ranges of device:

:put [interface wireless info hw-info wlan1]
 
mountainman
just joined
Topic Author
Posts: 5
Joined: Mon Mar 31, 2014 4:24 pm

Re: get supported-bands not working in 6.33

Tue Jan 05, 2016 4:37 pm

Ok! Thank you! When I issue that command, I get back "2200-2700/0.5/b,g,gn20,gn40". Can you tell me what the 0.5 represents shown between the frequency range and 802.11 mode list?
 
freakneck
just joined
Posts: 7
Joined: Thu Feb 05, 2015 10:32 pm

Re: get supported-bands not working in 6.33

Thu Feb 11, 2016 11:48 pm

You can use "hw-info" to see all possible bands, channel widths, and frequency ranges of device:

:put [interface wireless info hw-info wlan1]
We've just upgraded from 6.11 to 6.3x.x and this change is bad.

Listing "allowed channels" doesn't list all the possible channels. It lists what the allowed channels are for the current configuration.

ex - If you are using (what used to be called) 20/40Mhz-ht-above, the list does not include 5825 mhz, as that's the extension channel for ht-above.

The list is like: ...5805/20/a,5810/20/a,5815/20/a,5820/20/a,5825/20/a ...which only pertains to the current configuration.
 
User avatar
PaulsMT
MikroTik Support
MikroTik Support
Posts: 283
Joined: Tue Feb 10, 2015 3:21 pm

Re: get supported-bands not working in 6.33

Fri Feb 12, 2016 11:51 am

/interface wireless info allowed-channels <Wlan iface>

Will show you all available settings depending on your current configuration, but
/interface wireless info hw-info <Wlan iface>

Will show all possible settings allowed by hardware, the output will be:

ranges: 2312-2732/5/b,g,gn20,gn40

Where "2312-2732" is available frequency range.
5 = step between frequencies.
b,g,gn20 = wireless standard and channel-width.
 
eigenstate
just joined
Posts: 6
Joined: Sat Dec 01, 2012 12:33 am

Re: get supported-bands not working in 6.33

Fri Aug 05, 2016 3:15 am

The problem is that the output from this command can't be captured by a script. We used to be able to to this:
	:local foo [/interface wireless info get wlan1 supported-bands];
	:local fooArray [:toarray $foo];
	:local supportedband [:pick $fooArray 0 1];
		or
	:foreach b in=$fooArray do={ . . .
But I find that in 6.34.6, the following:
	:local foo [/interface wireless info hw-info wlan1];
	:local fooArray [:toarray $foo];
leaves fooArray empty! How can we capture output from hw-info for use in scripts?

Who is online

Users browsing this forum: No registered users and 22 guests