Community discussions

MUM Europe 2020
 
jarda
Forum Guru
Forum Guru
Topic Author
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

DNS Exit script

Sat Feb 06, 2016 9:16 am

I was asked to publish my ddns script. As I am using DNS Exit, it is tailored to it, but it was derived very long time ago from some other ddns script found somewhere probably on this forum. Running actually on 6.32.3 without any problems...
# Set needed variables
:local username "my.user.name"
:local password "my.user.password"
:local hostname "my.ddns.domain.name.tld"

:global dyndnsForce
:global previousIP
#:global currentIP

# print some debug info
#:log info ("UpdateDnsExit: username = $username")
#:log info ("UpdateDnsExit: password = $password")
#:log info ("UpdateDnsExit: hostname = $hostname")
#:log info ("UpdateDnsExit: previousIP = $previousIP")

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="api.ipify.org" src-path="/" dst-path="disk1/dnsexit.tmp" port=80 host=api.ipify.org
:delay 2s
:local result [/file get [/file find name=disk1/dnsexit.tmp] contents]

# parse the current IP result
:local resultLen [:len $result]
:global currentIP [:pick $result 0 ($resultLen-0)]
#:log info "UpdateDnsExit: result =$result"
#:log info "UpdateDnsExit: currentIP =$currentIP"

# Remove the # on next line to force an update every single time - useful for debugging,
# but you could end up getting blacklisted by DnsExit!

#:set dyndnsForce true

# Determine if dyndns update is needed
# more dyndns updater request details on DnsExit.com 

:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
:set dyndnsForce false
:log info "UpdateDnsExit: Current IP $currentIP"
:log info "UpdateDnsExit: Previous IP $previousIP"
:set previousIP $currentIP
/tool fetch mode=http address="www.dnsexit.com" \
src-path="RemoteUpdate.sv?login=$username&password=$password&host=$hostname&myip=$currentIP" \
dst-path="disk1/dnsexit.txt" port=80 host=www.dnsexit.com
:local result [/file get disk1/dnsexit.txt contents]
:log info "UpdateDnsExit: previousIP = $previousIP"
:log info ("DnsExit: DnsExit update needed")
:log info ("UpdateDnsExit: DnsExit Update Result: ".$result)
:log info ("DnsExit Update Result: ".$result)
} else={
:log info ("UpdateDnsExit: No DnsExit update needed")
}
 
ialcantara
just joined
Posts: 18
Joined: Tue Apr 16, 2013 6:12 am

Re: DNS Exit script

Tue Feb 09, 2016 7:22 am

Hi Everybody :)

Can some one please help me modify this script to get the IP Address from my VPN Interface instead of my WAN IP address? I am using a Smart Proxy Tool and I need to parse the VPN Address because I use a combination of VPN and SmartDNS.

The IP address of my VPN shows in the IP ADDRESS PRINT list, but I don't understand what to change in this script to pull the address.

thank you!

Ivan
 
ialcantara
just joined
Posts: 18
Joined: Tue Apr 16, 2013 6:12 am

Re: DNS Exit script

Sat Feb 20, 2016 9:56 am

Hi Everybody :)

Can some one please help me modify this script to get the IP Address from my VPN Interface instead of my WAN IP address? I am using a Smart Proxy Tool and I need to parse the VPN Address because I use a combination of VPN and SmartDNS.

The IP address of my VPN shows in the IP ADDRESS PRINT list, but I don't understand what to change in this script to pull the address.

thank you!

Ivan

Hi, how can I fetch every minute an api url that updates my active IP Address on my SmartDNS account so I can fool Netflix and others to think that I am back home, fucking idiots think that we all need to be in our country to watch the shit we paid tax money to develop, take PBS for example, CSPAN, Public Domain etc.
 
jarda
Forum Guru
Forum Guru
Topic Author
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: DNS Exit script

Sat Feb 20, 2016 11:02 am

Your questions have nothing to do with this script. You need to route the traffic through your vpn to ensure the applications where you are sitting. And that is other topic.

Who is online

Users browsing this forum: No registered users and 10 guests