Community discussions

MikroTik App
 
User avatar
ariosvelez
newbie
Topic Author
Posts: 29
Joined: Mon Mar 11, 2013 5:39 pm
Location: Ocala, FL
Contact:

Error sending email <filename.rsc>:error handling file

Thu May 18, 2017 4:20 pm

RB2011UiAS and any other RB. v6.38.1 or current v6.39.1 it worked on v6.30 I have created a script to export compact file=filename.rsc it create the file and I can send the file on an email manually on email tool. But when it runs automatically from the script and the scheduler it always gives the error handling file. Tools email work perfectly sending the file manually using send email button Here is the copy of the script:

/system script
add name="e-script" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon,dude \
source="/export compact file=([/system identity get name]); /tool \
e-mail send to= \"netadmin@lightningspeed.net\" subject=([/system identity get \
name] . \" rsc\") file=([/system identity get name] . \".rsc\")"

/system scheduler
add comment="" disabled=no interval=1d name="email-script" on-event=e-script \
start-date=jan/01/1970 start-time=08:45:30
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
MTCNA, MTCRE, MTCINE
 
gustavomam
Trainer
Trainer
Posts: 289
Joined: Tue Jul 23, 2013 6:29 pm
Location: Spain
Contact:

Re: Error sending email <filename.rsc>:error handling file

Thu May 18, 2017 5:17 pm

Hi.

I test your code and works for me, please tell me what is exactly the error to help you better.

Maybe your filename.rsc has to many words or especial characters.
-
Eng. Gustavo Angulo
Academy Xperts Spain
Mikrotik Certified Trainer
https://www.youtube.com/watch?v=Cbt2HVYwjYU
 
User avatar
ariosvelez
newbie
Topic Author
Posts: 29
Joined: Mon Mar 11, 2013 5:39 pm
Location: Ocala, FL
Contact:

Re: Error sending email <filename.rsc>:error handling file

Thu May 18, 2017 7:40 pm

This is the error when I run it.
Image
That is a image of the error from the log but it says: Error sending e-mail <AbeTest.rsc>: error handling file

I did it it work one time and then when I run the script again it shows that error on the log.
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
MTCNA, MTCRE, MTCINE
 
gustavomam
Trainer
Trainer
Posts: 289
Joined: Tue Jul 23, 2013 6:29 pm
Location: Spain
Contact:

Re: Error sending email <filename.rsc>:error handling file

Fri May 19, 2017 3:38 pm

Try to use fliname without space.
-
Eng. Gustavo Angulo
Academy Xperts Spain
Mikrotik Certified Trainer
https://www.youtube.com/watch?v=Cbt2HVYwjYU
 
User avatar
ariosvelez
newbie
Topic Author
Posts: 29
Joined: Mon Mar 11, 2013 5:39 pm
Location: Ocala, FL
Contact:

Re: Error sending email <filename.rsc>:error handling file

Fri May 19, 2017 10:32 pm

Everything is workin the problem is when you tried several times same day it shows that error message.
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
MTCNA, MTCRE, MTCINE

Who is online

Users browsing this forum: No registered users and 20 guests