Page 1 of 1

send mail when ping is 200ms+

Posted: Fri May 26, 2017 12:52 pm
by tomislav91
Hi,

i am having a failover over mikrotik router, and want to send me an email when ping to 8.8.8.8 over ethernet 1 / gw 1 send me an email? I am having script to send me email when there is no ping.

Re: send mail when ping is 200ms+

Posted: Mon May 29, 2017 11:47 am
by gustavomam
Hi.

This post could help you to fix it out.
viewtopic.php?t=82816

Re: send mail when ping is 200ms+

Posted: Tue Jun 06, 2017 9:14 pm
by OneDrive
#Mikrotik Ping more than 200ms to send mail
#https://ros.ac
#By:Ali
#From:China
:local Themes "Monitor IP delay to alarm threshold"
#Set the monitored IP address
:local addre 192.168.88.1;
#Set the delay
:local ms 200;
:local avgRtt;
/tool flood-ping $addre count=10 do={
  :if ($sent = 10) do={
    :set avgRtt $"avg-rtt"
}}
:if ($avgRtt >= $ms) do={
#Send mail
/tool e-mail send server=<Server IP> port=25 user=<user> password=<pass> to=to@mail.com from=from@mail.com subject=$Themes body=("Monitoring IP:$addre\ndelay:$avgRtt ms")
:log err "Message has been sent";
}

Re: send mail when ping is 200ms+

Posted: Sun Jun 11, 2017 5:58 pm
by tomislav91
Thanks all for reply. Just tell me, maybe here needs a space:

Re: send mail when ping is 200ms+

Posted: Sun Jun 11, 2017 6:25 pm
by OneDrive
Thanks all for reply. Just tell me, maybe here needs a space:
I have updated it

Re: send mail when ping is 200ms+

Posted: Sun Jun 11, 2017 6:45 pm
by tomislav91
Thanks all for reply. Just tell me, maybe here needs a space:
I have updated it
can you just tell me one thing. Server IP for email. What should I put here? If i want to send to gmail, i need to put gmail SMTP wan ip?

Re: send mail when ping is 200ms+

Posted: Mon Jun 12, 2017 4:05 pm
by OneDrive
Thanks all for reply. Just tell me, maybe here needs a space:
to=to@mail.comfrom=from@mail.com
I have updated it
can you just tell me one thing. Server IP for email. What should I put here? If i want to send to gmail, i need to put gmail SMTP wan ip?
#Mikrotik Ping more than 200ms to send mail
#https://ros.ac
#By:Ali
#From:China
:local Themes "Monitor IP delay to alarm threshold"
#Set the monitored IP address
:local addre 192.168.88.1;
#Parse the IP corresponding to the smtp mail server
:local smtps [:resolve smtp.gmail.com]
#Set the delay
:local ms 200;
:local avgRtt;
/tool flood-ping $addre count=10 do={
:if ($sent = 10) do={
:set avgRtt $"avg-rtt"
}}
:if ($avgRtt >= $ms) do={
#Send mail
/tool e-mail send server=$smtp port=25 user=<user> password=<pass> to=to@mail.com from=from@mail.com subject=$Themes body=("Monitoring IP:$addre\ndelay:$avgRtt ms")
:log err "Message has been sent";
}

Re: send mail when ping is 200ms+

Posted: Mon Jun 12, 2017 6:28 pm
by tomislav91
Thanks all for reply. Just tell me, maybe here needs a space:
I have updated it
can you just tell me one thing. Server IP for email. What should I put here? If i want to send to gmail, i need to put gmail SMTP wan ip?
#Mikrotik Ping more than 200ms to send mail
#https://ros.ac
#By:Ali
#From:China
:local Themes "Monitor IP delay to alarm threshold"
#Set the monitored IP address
:local addre 192.168.88.1;
#Parse the IP corresponding to the smtp mail server
:local smtps [:resolve smtp.gmail.com]
#Set the delay
:local ms 200;
:local avgRtt;
/tool flood-ping $addre count=10 do={
:if ($sent = 10) do={
:set avgRtt $"avg-rtt"
}}
:if ($avgRtt >= $ms) do={
#Send mail
/tool e-mail send server=$smtp port=25 user=<user> password=<pass> to=to@mail.com from=from@mail.com subject=$Themes body=("Monitoring IP:$addre\ndelay:$avgRtt ms")
:log err "Message has been sent";
}
Thanks for it.
Can you just tell me about Dude. Does it possible to get an alert for maybe ping to create alarms? Just ask because of much queries to router...

Re: send mail when ping is 200ms+

Posted: Mon Jun 12, 2017 7:23 pm
by Shadeofspirit
Can you just tell me about Dude. Does it possible to get an alert for maybe ping to create alarms? Just ask because of much queries to router...
yes, you can use it. for example i use it to send e-mail for warnings and not very critical events. and most important are also send to telegram.
but if you want to have a message when 200+ms then you have to make a probe for that
also you should remember that you will monitor "ping" from dude to your device, not between 2 devices. if you wont to monitor between 2 devices it will be more difficult to create a probe and all will depend an what devices you have

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 9:54 am
by nichky
well done

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 12:10 pm
by tomislav91
Can you just tell me about Dude. Does it possible to get an alert for maybe ping to create alarms? Just ask because of much queries to router...
yes, you can use it. for example i use it to send e-mail for warnings and not very critical events. and most important are also send to telegram.
but if you want to have a message when 200+ms then you have to make a probe for that
also you should remember that you will monitor "ping" from dude to your device, not between 2 devices. if you wont to monitor between 2 devices it will be more difficult to create a probe and all will depend an what devices you have
i only want to ping internet and to inform me when ping is big. I dont find that option, only when ping is lost. Any form of informing me will be ok...But in probe I cant find that option

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 1:10 pm
by Shadeofspirit
Can you just tell me about Dude. Does it possible to get an alert for maybe ping to create alarms? Just ask because of much queries to router...
yes, you can use it. for example i use it to send e-mail for warnings and not very critical events. and most important are also send to telegram.
but if you want to have a message when 200+ms then you have to make a probe for that
also you should remember that you will monitor "ping" from dude to your device, not between 2 devices. if you wont to monitor between 2 devices it will be more difficult to create a probe and all will depend an what devices you have
i only want to ping internet and to inform me when ping is big. I dont find that option, only when ping is lost. Any form of informing me will be ok...But in probe I cant find that option
there is information about these probe in dude
viewtopic.php?t=35520

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 2:02 pm
by tomislav91
Can you just tell me about Dude. Does it possible to get an alert for maybe ping to create alarms? Just ask because of much queries to router...
yes, you can use it. for example i use it to send e-mail for warnings and not very critical events. and most important are also send to telegram.
but if you want to have a message when 200+ms then you have to make a probe for that
also you should remember that you will monitor "ping" from dude to your device, not between 2 devices. if you wont to monitor between 2 devices it will be more difficult to create a probe and all will depend an what devices you have
i only want to ping internet and to inform me when ping is big. I dont find that option, only when ping is lost. Any form of informing me will be ok...But in probe I cant find that option
there is information about these probe in dude
viewtopic.php?t=35520
does it good like this? I change FirstDevice to my ip address of router which i want to ping.
dawww.jpg

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 2:10 pm
by Shadeofspirit
Can you just tell me about Dude. Does it possible to get an alert for maybe ping to create alarms? Just ask because of much queries to router...
yes, you can use it. for example i use it to send e-mail for warnings and not very critical events. and most important are also send to telegram.
but if you want to have a message when 200+ms then you have to make a probe for that
also you should remember that you will monitor "ping" from dude to your device, not between 2 devices. if you wont to monitor between 2 devices it will be more difficult to create a probe and all will depend an what devices you have
i only want to ping internet and to inform me when ping is big. I dont find that option, only when ping is lost. Any form of informing me will be ok...But in probe I cant find that option
there is information about these probe in dude
viewtopic.php?t=35520
does it good like this? I change FirstDevice to my ip address of router which i want to ping.
dawww.jpg
No! Device_property is function thar returns propertys of the device, firstaddress is subfunction - to get ip address.
if you want to monitor rtt to your device - just add this probe without changes to this device
if you want to monitor not your device you have 2 variants - change probe (without device_property), the second variant is to add new device (for example 8.8.8.8) and to it probe from post without changes.
than you can change alerts to device at all or to particular probe

look there fo my example with "new device" 8.8.8.8 https://drive.google.com/open?id=0Bxq9Y ... zJ2X1A1ZjQ

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 2:33 pm
by tomislav91
yes, you can use it. for example i use it to send e-mail for warnings and not very critical events. and most important are also send to telegram.
but if you want to have a message when 200+ms then you have to make a probe for that
also you should remember that you will monitor "ping" from dude to your device, not between 2 devices. if you wont to monitor between 2 devices it will be more difficult to create a probe and all will depend an what devices you have
i only want to ping internet and to inform me when ping is big. I dont find that option, only when ping is lost. Any form of informing me will be ok...But in probe I cant find that option
there is information about these probe in dude
viewtopic.php?t=35520
does it good like this? I change FirstDevice to my ip address of router which i want to ping.
dawww.jpg
No! Device_property is function thar returns propertys of the device, firstaddress is subfunction - to get ip address.
if you want to monitor rtt to your device - just add this probe without changes to this device
if you want to monitor not your device you have 2 variants - change probe (without device_property), the second variant is to add new device (for example 8.8.8.8) and to it probe from post without changes.
than you can change alerts to device at all or to particular probe

look there fo my example with "new device" 8.8.8.8 https://drive.google.com/open?id=0Bxq9Y ... zJ2X1A1ZjQ
problematics is next:
i am having failovers on most of my devices. So when internet in LAN1 for example is bad, ping is big i want to change internet to another port *for example port 2.
Failover will change it when there is no ping, but idea is that i got inform when ping is higher than 200ms and then i will change it by my self. Of course I will ping 8.8.8.8.
I add probe to my dude when I have more than 1 device
xxxxxxx.png
Is this that? How can I decide on which device this working? Or that work on all devices in Dude?

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 2:48 pm
by Shadeofspirit

Is this that? How can I decide on which device this working? Or that work on all devices in Dude?
look this: https://drive.google.com/open?id=0Bxq9Y ... XRXX2JCYkk
i modified this probe to your needs.
add it to all devices from which you want to monitor ping to 8.8.8.8
actually, i don,t know what to do if this devices are not RB or there are no RB in this site, but if it is mikrotik - as agent (when you add service to monitor) select this RB or other RB in this site
it is so, because this probe will monitor ping rtt from "agent" to 8.8.8.8

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 2:56 pm
by tomislav91

Is this that? How can I decide on which device this working? Or that work on all devices in Dude?
look this: https://drive.google.com/open?id=0Bxq9Y ... XRXX2JCYkk
i modified this probe to your needs.
add it to all devices from which you want to monitor ping to 8.8.8.8
actually, i don,t know what to do if this devices are not RB or there are no RB in this site, but if it is mikrotik - as agent (when you add service to monitor) select this RB or other RB in this site
it is so, because this probe will monitor ping rtt from "agent" to 8.8.8.8
so it will inform me when ping is more than 200ms ? I first add service (i am having services ping and routeros managment), so just add this with probe and thats it?

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 3:03 pm
by Shadeofspirit

Is this that? How can I decide on which device this working? Or that work on all devices in Dude?
look this: https://drive.google.com/open?id=0Bxq9Y ... XRXX2JCYkk
i modified this probe to your needs.
add it to all devices from which you want to monitor ping to 8.8.8.8
actually, i don,t know what to do if this devices are not RB or there are no RB in this site, but if it is mikrotik - as agent (when you add service to monitor) select this RB or other RB in this site
it is so, because this probe will monitor ping rtt from "agent" to 8.8.8.8
so it will inform me when ping is more than 200ms ? I first add service (i am having services ping and routeros managment), so just add this with probe and thats it?
if you want to monitor 200ms - change in probe 120 to 200 (i marked in screenshot)
than add this probe as service to your device
set notifications to this device or to this particular service

for testing you can change rtt to 10ms for example - you will see if you will get notification

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 3:11 pm
by tomislav91

Is this that? How can I decide on which device this working? Or that work on all devices in Dude?
look this: https://drive.google.com/open?id=0Bxq9Y ... XRXX2JCYkk
i modified this probe to your needs.
add it to all devices from which you want to monitor ping to 8.8.8.8
actually, i don,t know what to do if this devices are not RB or there are no RB in this site, but if it is mikrotik - as agent (when you add service to monitor) select this RB or other RB in this site
it is so, because this probe will monitor ping rtt from "agent" to 8.8.8.8
so it will inform me when ping is more than 200ms ? I first add service (i am having services ping and routeros managment), so just add this with probe and thats it?
if you want to monitor 200ms - change in probe 120 to 200 (i marked in screenshot)
than add this probe as service to your device
set notifications to this device or to this particular service

for testing you can change rtt to 10ms for example - you will see if you will get notification
i did it, but in services when i was add service it give me parse failed.

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 3:13 pm
by Shadeofspirit

Is this that? How can I decide on which device this working? Or that work on all devices in Dude?
look this: https://drive.google.com/open?id=0Bxq9Y ... XRXX2JCYkk
i modified this probe to your needs.
add it to all devices from which you want to monitor ping to 8.8.8.8
actually, i don,t know what to do if this devices are not RB or there are no RB in this site, but if it is mikrotik - as agent (when you add service to monitor) select this RB or other RB in this site
it is so, because this probe will monitor ping rtt from "agent" to 8.8.8.8
so it will inform me when ping is more than 200ms ? I first add service (i am having services ping and routeros managment), so just add this with probe and thats it?
if you want to monitor 200ms - change in probe 120 to 200 (i marked in screenshot)
than add this probe as service to your device
set notifications to this device or to this particular service

for testing you can change rtt to 10ms for example - you will see if you will get notification
i did it, but in services when i was add service it give me parse failed.
check - you deleted coma after 15

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 3:18 pm
by tomislav91
look this: https://drive.google.com/open?id=0Bxq9Y ... XRXX2JCYkk
i modified this probe to your needs.
add it to all devices from which you want to monitor ping to 8.8.8.8
actually, i don,t know what to do if this devices are not RB or there are no RB in this site, but if it is mikrotik - as agent (when you add service to monitor) select this RB or other RB in this site
it is so, because this probe will monitor ping rtt from "agent" to 8.8.8.8
so it will inform me when ping is more than 200ms ? I first add service (i am having services ping and routeros managment), so just add this with probe and thats it?
if you want to monitor 200ms - change in probe 120 to 200 (i marked in screenshot)
than add this probe as service to your device
set notifications to this device or to this particular service

for testing you can change rtt to 10ms for example - you will see if you will get notification
i did it, but in services when i was add service it give me parse failed.
check - you deleted coma after 15

sorry for that, but again parse error..

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 3:33 pm
by Shadeofspirit

sorry for that, but again parse error..
in error line - you deleted ) at the end

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 3:36 pm
by tomislav91

sorry for that, but again parse error..
in error line - you deleted ) at the end

i found it, and response with a bit delay notification popup. But it works. Thanks

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 3:40 pm
by Shadeofspirit

sorry for that, but again parse error..
in error line - you deleted ) at the end

i found it, and response with a bit delay notification popup. But it works. Thanks
glad to help
you can try to change "probe interval", "probe down count", "probe timeout" to have faster response
also notifications to telegram come faster than e-mail

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 4:39 pm
by tomislav91

sorry for that, but again parse error..
in error line - you deleted ) at the end

i found it, and response with a bit delay notification popup. But it works. Thanks
glad to help
you can try to change "probe interval", "probe down count", "probe timeout" to have faster response
also notifications to telegram come faster than e-mail
i putted notification pop up, but when put a 10ms it give me pop up, but when 100ms there is no pop up.

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 4:48 pm
by Shadeofspirit

sorry for that, but again parse error..
in error line - you deleted ) at the end

i found it, and response with a bit delay notification popup. But it works. Thanks
glad to help
you can try to change "probe interval", "probe down count", "probe timeout" to have faster response
also notifications to telegram come faster than e-mail
i putted notification pop up, but when put a 10ms it give me pop up, but when 100ms there is no pop up.
i don't use "popup", so i can't help with it
look what color is this service when you set 100ms - if it changes color from green when rtt is more then 100ms: all works good

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 4:55 pm
by tomislav91
in error line - you deleted ) at the end

i found it, and response with a bit delay notification popup. But it works. Thanks
glad to help
you can try to change "probe interval", "probe down count", "probe timeout" to have faster response
also notifications to telegram come faster than e-mail
i putted notification pop up, but when put a 10ms it give me pop up, but when 100ms there is no pop up.
i don't use "popup", so i can't help with it
look what color is this service when you set 100ms - if it changes color from green when rtt is more then 100ms: all works good
it wont me change color. Change when small to 10ms. When back to 100ms, there is no change. WHen i interval and timeout put to 1 than works, when back to 2, it didnt work. But when is set to 1, and internet is good, color is also orange, no change, but need to change to green again. It will back to green when set interval, timeout to 5.

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 5:13 pm
by tomislav91
Must I put an Agent to be like Device in drop down menu? It is a routers.

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 5:33 pm
by Shadeofspirit


i found it, and response with a bit delay notification popup. But it works. Thanks
glad to help
you can try to change "probe interval", "probe down count", "probe timeout" to have faster response
also notifications to telegram come faster than e-mail
i putted notification pop up, but when put a 10ms it give me pop up, but when 100ms there is no pop up.
i don't use "popup", so i can't help with it
look what color is this service when you set 100ms - if it changes color from green when rtt is more then 100ms: all works good
it wont me change color. Change when small to 10ms. When back to 100ms, there is no change. WHen i interval and timeout put to 1 than works, when back to 2, it didnt work. But when is set to 1, and internet is good, color is also orange, no change, but need to change to green again. It will back to green when set interval, timeout to 5.
i don't understand till the end what do you mean... what settings are made for your notifications? what state changes are marked to notify?

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 5:46 pm
by tomislav91
glad to help
you can try to change "probe interval", "probe down count", "probe timeout" to have faster response
also notifications to telegram come faster than e-mail
i putted notification pop up, but when put a 10ms it give me pop up, but when 100ms there is no pop up.
i don't use "popup", so i can't help with it
look what color is this service when you set 100ms - if it changes color from green when rtt is more then 100ms: all works good
it wont me change color. Change when small to 10ms. When back to 100ms, there is no change. WHen i interval and timeout put to 1 than works, when back to 2, it didnt work. But when is set to 1, and internet is good, color is also orange, no change, but need to change to green again. It will back to green when set interval, timeout to 5.
i don't understand till the end what do you mean... what settings are made for your notifications? what state changes are marked to notify?
When I put to 1 all values, it showes me that it is down, orange color. But you can see that ping is good. After I change to 3, it will make green again
dda.png
Untitled.png
And this is setup when ping is large than 100ms, nothing happend
ddd.png

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 6:05 pm
by Shadeofspirit
very strange. on history tab of the service you can see graph with values. what values does it get (when ping is > 100ms)?

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 6:09 pm
by tomislav91
very strange. on history tab of the service you can see graph with values. what values does it get (when ping is > 100ms)?
This is a graph
gra.png
I cant see there is more than 100ms?

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 6:11 pm
by Shadeofspirit
very strange. on history tab of the service you can see graph with values. what values does it get (when ping is > 100ms)?
This is a graphgra.png

I cant see there is more than 100ms?
ok. and our "default" agent is the mikrotik from that site (it also will have >100ms to 8.8.8.8) or it is dude server in other site?

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 6:15 pm
by tomislav91
very strange. on history tab of the service you can see graph with values. what values does it get (when ping is > 100ms)?
This is a graphgra.png

I cant see there is more than 100ms?
ok. and our "default" agent is the mikrotik from that site (it also will have >100ms to 8.8.8.8) or it is dude server in other site?
Untitled.png
I dont know what is default, i cant see where it is configured. But I tried to put there same as the Device, but again is the same

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 6:36 pm
by Shadeofspirit
very strange. on history tab of the service you can see graph with values. what values does it get (when ping is > 100ms)?
This is a graphgra.png

I cant see there is more than 100ms?
ok. and our "default" agent is the mikrotik from that site (it also will have >100ms to 8.8.8.8) or it is dude server in other site?

Untitled.png

I dont know what is default, i cant see where it is configured. But I tried to put there same as the Device, but again is the same
just tell is in this field:
1)open your device
2)on services tab find your service high_ping
3) open it and look what is in "agent"

the probe monitor ping rtt from device that is specified in field "agent" and 8.8.8.8

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 6:38 pm
by tomislav91
very strange. on history tab of the service you can see graph with values. what values does it get (when ping is > 100ms)?
This is a graphgra.png

I cant see there is more than 100ms?
ok. and our "default" agent is the mikrotik from that site (it also will have >100ms to 8.8.8.8) or it is dude server in other site?

Untitled.png

I dont know what is default, i cant see where it is configured. But I tried to put there same as the Device, but again is the same
just tell is in this field:
1)open your device
2)on services tab find your service high_ping
3) open it and look what is in "agent"

the probe monitor ping rtt from device that is specified in field "agent" and 8.8.8.8
in agent is only default.

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 6:42 pm
by Shadeofspirit

in agent is only default.
it means that you have only one ROS device in dude.
so, ping rtt from your dude server to 8.8.8.8 is also >100 when you test?

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 6:52 pm
by tomislav91

in agent is only default.
it means that you have only one ROS device in dude.
so, ping rtt from your dude server to 8.8.8.8 is also >100 when you test?
I can choose instead of default a device which is in the Device. But it is the same. to device. Problem is when server has higher ping. Dude server is on my main router

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 6:59 pm
by Shadeofspirit

in agent is only default.
it means that you have only one ROS device in dude.
so, ping rtt from your dude server to 8.8.8.8 is also >100 when you test?
I can choose instead of default a device which is in the Device. But it is the same. to device. Problem is when server has higher ping.
i can't test with values more than 20ms in my network. with all tests i had made it shows correct results.
you didn't answer (or i didn't understand) does your dude server in the same network from witch ping to 8.8.8.8 is >100 ?

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 7:16 pm
by tomislav91

in agent is only default.
it means that you have only one ROS device in dude.
so, ping rtt from your dude server to 8.8.8.8 is also >100 when you test?
I can choose instead of default a device which is in the Device. But it is the same. to device. Problem is when server has higher ping.
i can't test with values more than 20ms in my network. with all tests i had made it shows correct results.
you didn't answer (or i didn't understand) does your dude server in the same network from witch ping to 8.8.8.8 is >100 ?
From me working with lower ms. I dont understand why dont working like this. Maybe intervales is not good?
My dude server is on my main router from where any devices are connected and goes through.

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 7:25 pm
by Shadeofspirit

in agent is only default.
it means that you have only one ROS device in dude.
so, ping rtt from your dude server to 8.8.8.8 is also >100 when you test?
I can choose instead of default a device which is in the Device. But it is the same. to device. Problem is when server has higher ping.
i can't test with values more than 20ms in my network. with all tests i had made it shows correct results.
you didn't answer (or i didn't understand) does your dude server in the same network from witch ping to 8.8.8.8 is >100 ?
From me working with lower ms. I dont understand why dont working like this. Maybe intervales is not good?
My dude server is on my main router from where any devices are connected and goes through.
as i had written at the beginning - this probe can monitor only from RB device. no matter to what device you will add this probe - all depends what device is in agent field. as you had written - there are only 2 variants in your setup (default and your_device_name - i think it is dude server), so it shows ping rtt from your mikrotik to 8.8.8.8. if you need to monitor from particular device (not ROS) i can't help, it is possible, but i don't know exactly what probe to write

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 8:08 pm
by tomislav91
it means that you have only one ROS device in dude.
so, ping rtt from your dude server to 8.8.8.8 is also >100 when you test?
I can choose instead of default a device which is in the Device. But it is the same. to device. Problem is when server has higher ping.
i can't test with values more than 20ms in my network. with all tests i had made it shows correct results.
you didn't answer (or i didn't understand) does your dude server in the same network from witch ping to 8.8.8.8 is >100 ?
From me working with lower ms. I dont understand why dont working like this. Maybe intervales is not good?
My dude server is on my main router from where any devices are connected and goes through.
as i had written at the beginning - this probe can monitor only from RB device. no matter to what device you will add this probe - all depends what device is in agent field. as you had written - there are only 2 variants in your setup (default and your_device_name - i think it is dude server), so it shows ping rtt from your mikrotik to 8.8.8.8. if you need to monitor from particular device (not ROS) i can't help, it is possible, but i don't know exactly what probe to write

idea from begining was to ping from dude a router or a 8.8.8.8 from that router and where ping is more than 200ms to inform me.

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 8:14 pm
by Shadeofspirit
Can you just tell me about Dude. Does it possible to get an alert for maybe ping to create alarms? Just ask because of much queries to router...
yes, you can use it. for example i use it to send e-mail for warnings and not very critical events. and most important are also send to telegram.
but if you want to have a message when 200+ms then you have to make a probe for that
also you should remember that you will monitor "ping" from dude to your device, not between 2 devices. if you wont to monitor between 2 devices it will be more difficult to create a probe and all will depend an what devices you have

Is this that? How can I decide on which device this working? Or that work on all devices in Dude?
look this: https://drive.google.com/open?id=0Bxq9Y ... XRXX2JCYkk
i modified this probe to your needs.
add it to all devices from which you want to monitor ping to 8.8.8.8
actually, i don,t know what to do if this devices are not RB or there are no RB in this site, but if it is mikrotik - as agent (when you add service to monitor) select this RB or other RB in this site
it is so, because this probe will monitor ping rtt from "agent" to 8.8.8.8
that was at the beginning...

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 8:24 pm
by tomislav91
Can you just tell me about Dude. Does it possible to get an alert for maybe ping to create alarms? Just ask because of much queries to router...
yes, you can use it. for example i use it to send e-mail for warnings and not very critical events. and most important are also send to telegram.
but if you want to have a message when 200+ms then you have to make a probe for that
also you should remember that you will monitor "ping" from dude to your device, not between 2 devices. if you wont to monitor between 2 devices it will be more difficult to create a probe and all will depend an what devices you have

Is this that? How can I decide on which device this working? Or that work on all devices in Dude?
look this: https://drive.google.com/open?id=0Bxq9Y ... XRXX2JCYkk
i modified this probe to your needs.
add it to all devices from which you want to monitor ping to 8.8.8.8
actually, i don,t know what to do if this devices are not RB or there are no RB in this site, but if it is mikrotik - as agent (when you add service to monitor) select this RB or other RB in this site
it is so, because this probe will monitor ping rtt from "agent" to 8.8.8.8
that was at the beginning...
So, there is no help.... :oops:

Re: send mail when ping is 200ms+

Posted: Tue Jun 13, 2017 9:34 pm
by tomislav91
Or any other solution for my general problem, to get informed if router has bad ping to 8.8.8.8.
Yeah, I have internet, but when ping is 100,200,300ms it is slow and bad, and want to switch to another interface where is another isp provider. That's whole idea.

Re: send mail when ping is 200ms+

Posted: Fri Mar 01, 2019 7:00 pm
by mendocino
Hello, a question how can I do it so that I can do it on a specific WAN, I have 2 wan and I would like it to be indicated when there is latency in 2. Greetings