Community discussions

 
geronimo350
just joined
Topic Author
Posts: 6
Joined: Tue Jun 14, 2016 3:01 pm

Scrip permission error

Wed Jul 19, 2017 6:57 pm

Hi all,

I'm trying to use the following script taken from Mikrotik wiki page https://wiki.mikrotik.com/wiki/Wake_on_ ... te_Desktop :

:foreach A in=[/ip firewall address-list find name=wakeOnLan] do={
if ([/ip firewall address-list get $A list]="wakeOnLan") do={
/system script add name=pinging source={
if ([/ping $A count=2] = 0) do={
:log info "Sending WoL to $[/ip firewall address-list get $A address]"
/tool wol mac=11:22:33:44:55:66:77 interface=ether3
:log info "Removing IP $[/ip firewall address-list get $A address] from list"
/ip firewall address-list remove $A
}
}
}
}

But every time I try to execute it i get the "script error: not enough permissions (9)".

Version of RouterOS is: 6.39.2

Can someone provide some information on what could be causing the fault ?

BR,
Geronimo
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: Scrip permission error

Wed Jul 19, 2017 7:25 pm

Give the script full permissions. Also, make sure it's owned by a user with full access.
You do not have the required permissions to view the files attached to this post.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
geronimo350
just joined
Topic Author
Posts: 6
Joined: Tue Jun 14, 2016 3:01 pm

Re: Scrip permission error

Thu Jul 20, 2017 2:00 pm

Hi Dave

Thanks for the quick response, that did the trick. It's working now.
 
looka
newbie
Posts: 30
Joined: Sat Apr 14, 2018 3:33 pm

Re: Scrip permission error

Sun Feb 03, 2019 1:28 pm

...all you need to do now is post a sign somewhere, something like ~~ <3 Welcome to hackers' paradise €> ~~
whenever you hit the wall of your knowledge or boss's schedule, best thing you can do is to whore with good ol' yes to all.

/tool wol command requires "test" permissions, but note if your script also need to "read" some data or even "write" it.

Who is online

Users browsing this forum: No registered users and 7 guests