Community discussions

MikroTik App
 
muhamad90
newbie
Topic Author
Posts: 30
Joined: Fri Oct 13, 2017 9:28 pm

6 wan pcc way script #help

Tue Feb 06, 2018 12:12 pm

i have 6 lines 200mb each line total 1200 mb and i am using CCR1009-7G-1C-1S+PC

i wanna use pcc way how is my script ?? :)
do you have any comment :? :?

Code: Select all

/interface ethernet
set [find default-name=ether1] name=ether1
set [find default-name=ether2] name=ether2
set [find default-name=ether3] name=ether3
set [find default-name=ether4] name=ether4
set [find default-name=ether5] name=ether5
set [find default-name=ether6] name=ether6
set [find default-name=ether7] name=ether7

/ip address
add address=192.168.254.1/24 network=192.168.254.0 broadcast=192.168.254.255 interface=ether7
add address=192.168.1.10/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether1
add address=192.168.2.10/24 network=192.168.2.0 broadcast=192.168.2.255 interface=ether2
add address=192.168.3.10/24 network=192.168.3.0 broadcast=192.168.3.255 interface=ether3
add address=192.168.4.10/24 network=192.168.4.0 broadcast=192.168.4.255 interface=ether4
add address=192.168.5.10/24 network=192.168.5.0 broadcast=192.168.5.255 interface=ether5
add address=192.168.6.10/24 network=192.168.6.0 broadcast=192.168.6.255 interface=ether6

/ip firewall mangle
add chain=input in-interface=ether1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=ether2 action=mark-connection new-connection-mark=WAN2_conn
add chain=input in-interface=ether3 action=mark-connection new-connection-mark=WAN3_conn
add chain=input in-interface=ether4 action=mark-connection new-connection-mark=WAN4_conn
add chain=input in-interface=ether5 action=mark-connection new-connection-mark=WAN5_conn
add chain=input in-interface=ether6 action=mark-connection new-connection-mark=WAN6_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
add chain=output connection-mark=WAN3_conn action=mark-routing new-routing-mark=to_WAN3
add chain=output connection-mark=WAN4_conn action=mark-routing new-routing-mark=to_WAN4
add chain=output connection-mark=WAN5_conn action=mark-routing new-routing-mark=to_WAN5
add chain=output connection-mark=WAN6_conn action=mark-routing new-routing-mark=to_WAN6

add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=ether7
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=ether7
add chain=prerouting dst-address=192.168.3.0/24 action=accept in-interface=ether7
add chain=prerouting dst-address=192.168.4.0/24 action=accept in-interface=ether7
add chain=prerouting dst-address=192.168.5.0/24 action=accept in-interface=ether7
add chain=prerouting dst-address=192.168.6.0/24 action=accept in-interface=ether7

add chain=prerouting dst-address-type=!local in-interface=ether7 per-connection-classifier=both-addresses-and-ports:6/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether7 per-connection-classifier=both-addresses-and-ports:6/1 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether7 per-connection-classifier=both-addresses-and-ports:6/2 action=mark-connection new-connection-mark=ether3_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether7 per-connection-classifier=both-addresses-and-ports:6/3 action=mark-connection new-connection-mark=ether4_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether7 per-connection-classifier=both-addresses-and-ports:6/4 action=mark-connection new-connection-mark=ether5_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ether7 per-connection-classifier=both-addresses-and-ports:6/5 action=mark-connection new-connection-mark=ether6_conn passthrough=yes
add chain=prerouting connection-mark=ether1_conn in-interface=ether7 action=mark-routing new-routing-mark=to_ether1
add chain=prerouting connection-mark=ether2_conn in-interface=ether7 action=mark-routing new-routing-mark=to_ether2
add chain=prerouting connection-mark=ether3_conn in-interface=ether7 action=mark-routing new-routing-mark=to_ether3
add chain=prerouting connection-mark=ether4_conn in-interface=ether7 action=mark-routing new-routing-mark=to_ether4
add chain=prerouting connection-mark=ether5_conn in-interface=ether7 action=mark-routing new-routing-mark=to_ether5
add chain=prerouting connection-mark=ether6_conn in-interface=ether7 action=mark-routing new-routing-mark=to_ether6

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_ether1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_ether2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.1 routing-mark=to_ether3 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.4.1 routing-mark=to_ether4 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.5.1 routing-mark=to_ether5 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.6.1 routing-mark=to_ether6 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.1 distance=3 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.4.1 distance=4 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.5.1 distance=5 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.6.1 distance=6 check-gateway=ping

/ip firewall nat
add chain=srcnat out-interface=ether1 action=masquerade
add chain=srcnat out-interface=ether2 action=masquerade
add chain=srcnat out-interface=ether3 action=masquerade
add chain=srcnat out-interface=ether4 action=masquerade
add chain=srcnat out-interface=ether5 action=masquerade
add chain=srcnat out-interface=ether6 action=masquerade

/ip dns
set servers=8.8.8.8,8.8.4.4
 
User avatar
aacable
Member
Member
Posts: 435
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: 6 wan pcc way script #help

Mon Feb 12, 2018 10:29 am

seems ok, are you having any issue in it ? describe details.

Who is online

Users browsing this forum: ramin110 and 32 guests