Community discussions

MUM Europe 2020
 
ilja
newbie
Topic Author
Posts: 49
Joined: Thu Feb 22, 2018 1:15 pm

Script to copy directory

Wed Mar 21, 2018 11:00 am

Hey all.

I am trying to write a script, which could just copy a local directory "/flash/umfiles" to "/umfiles" by using fetch tool from localhost to localhost
:local LOCALfolder "flash/umfiles"
:local FTPserverAddress "192.168.88.1";
:local FTPuser "admin";
:local FTPpass "eplmmlsw";
:local FTPfolder "umfiles";
:foreach FILE in=[/file where name="$LOCALfolder"] do={
  /tool fetch address="$FTPserverAddress" src-path="($LOCALfolder . $name)" user="$FTPuser" mode=ftp password="$FTPpass" dst-path=($FTPfolder . "$name") upload=yes;
}
That's what i have so far, but it doesnt work. Can anyone help?
 
ilja
newbie
Topic Author
Posts: 49
Joined: Thu Feb 22, 2018 1:15 pm

Re: Script to copy directory

Sat Mar 24, 2018 10:16 am

any help?
 
ilja
newbie
Topic Author
Posts: 49
Joined: Thu Feb 22, 2018 1:15 pm

Re: Script to copy directory

Tue Mar 27, 2018 6:07 pm

Can anyone please help?
 
ilja
newbie
Topic Author
Posts: 49
Joined: Thu Feb 22, 2018 1:15 pm

Re: Script to copy directory

Thu Mar 29, 2018 9:08 am

C'mon, is there really no one who can help? :/ Even MikroTik support?
 
ilja
newbie
Topic Author
Posts: 49
Joined: Thu Feb 22, 2018 1:15 pm

Re: Script to copy directory

Tue Apr 03, 2018 10:26 am

--- Abandoned due to inactivity ---

Who is online

Users browsing this forum: No registered users and 18 guests