Community discussions

MikroTik App
 
billjellis
newbie
Topic Author
Posts: 37
Joined: Mon Dec 15, 2014 11:04 pm

Output to SSID/Passphrase/Identity

Tue May 22, 2018 4:10 am

Hello,

I want to output these these items:
:put [/interface ethernet get [/interface ethernet find default-name=ether1] mac-address ]
:put [/interface wireless get [/interface wireless find default-name=wlan1] mac-address ]
:put [/interface wireless get [/interface wireless find default-name=wlan2] mac-address ]
:put [/system routerboard get serial-number]

To something like this as a file:
ether1=XXXXXXXXX
wlan1=XXXXXXXXX
wlan2=XXXXXXXXX
SerialNumber=XXXXXXXX

and to change the SSID/Passphrase/Identity

ether1=abc(last 4 charaters of the macaddress)
wlan1=xyx (last 4 charaters of the macaddress)
wlan2=XXXXXXXXX
SerialNumber=DEF-XXXXXXXX

ether1 will get set to the passphrase guestabcd
wlan1 gets set to SSID=xyz-ABCD
SerialNumber get set to Identity DEF-XXXXXXXXX

This is to automate creating personalized wireless routers

Thanks
Bill

Who is online

Users browsing this forum: No registered users and 12 guests