Page 1 of 1

Output to SSID/Passphrase/Identity

Posted: Tue May 22, 2018 4:10 am
by billjellis
Hello,

I want to output these these items:
:put [/interface ethernet get [/interface ethernet find default-name=ether1] mac-address ]
:put [/interface wireless get [/interface wireless find default-name=wlan1] mac-address ]
:put [/interface wireless get [/interface wireless find default-name=wlan2] mac-address ]
:put [/system routerboard get serial-number]

To something like this as a file:
ether1=XXXXXXXXX
wlan1=XXXXXXXXX
wlan2=XXXXXXXXX
SerialNumber=XXXXXXXX

and to change the SSID/Passphrase/Identity

ether1=abc(last 4 charaters of the macaddress)
wlan1=xyx (last 4 charaters of the macaddress)
wlan2=XXXXXXXXX
SerialNumber=DEF-XXXXXXXX

ether1 will get set to the passphrase guestabcd
wlan1 gets set to SSID=xyz-ABCD
SerialNumber get set to Identity DEF-XXXXXXXXX

This is to automate creating personalized wireless routers

Thanks
Bill