Community discussions

 
runbound
newbie
Topic Author
Posts: 30
Joined: Fri Apr 19, 2013 9:28 am

wpa to wpa2 clone

Fri Sep 07, 2018 5:12 am

how to script cloning my password from wpa to wpa2
this is my simple script but not working
/interface wireless security-profiles set "default" wpa-pre-shared-key=wpa2-pre-shared-key
 
User avatar
BartoszP
Forum Guru
Forum Guru
Posts: 1715
Joined: Mon Jun 16, 2014 1:13 pm
Location: Poland

Re: wpa to wpa2 clone

Fri Sep 07, 2018 12:18 pm

Start from here: https://wiki.mikrotik.com/wiki/Manual:S ... g#Keywords

You need to read WPA2 property with "get". Property is not a traditional variable.
Setting property is also not so simple as you tried .. look here for example viewtopic.php?f=9&t=138893
Real admins use real keyboards.
 
User avatar
ADahi
Member Candidate
Member Candidate
Posts: 217
Joined: Thu Sep 21, 2017 7:16 pm
Location: Iraq, Ninavah
Contact:

Re: wpa to wpa2 clone

Fri Sep 07, 2018 4:15 pm

script for run one time only, do not schedule
:do {/interface wireless security-profiles 
set default wpa2-pre-shared-key=[get default wpa-pre-shared-key];
set default authentication-types=wpa-psk,wpa2-psk unicast-ciphers=aes-ccm group-ciphers=aes-ccm
} on-error={:log error message="operation failed..."}
Last edited by ADahi on Sat Sep 08, 2018 5:51 pm, edited 1 time in total.
 
runbound
newbie
Topic Author
Posts: 30
Joined: Fri Apr 19, 2013 9:28 am

Re: wpa to wpa2 clone

Sat Sep 08, 2018 11:09 am

@ADahi i have problem sir with the script. i set this interval to 1minute in schedule but everytime the time comes our celphone connected to mikritik wifi is on and off

Who is online

Users browsing this forum: No registered users and 9 guests