Page 1 of 1

wpa to wpa2 clone

Posted: Fri Sep 07, 2018 5:12 am
by runbound
how to script cloning my password from wpa to wpa2
this is my simple script but not working
/interface wireless security-profiles set "default" wpa-pre-shared-key=wpa2-pre-shared-key

Re: wpa to wpa2 clone

Posted: Fri Sep 07, 2018 12:18 pm
by BartoszP
Start from here: https://wiki.mikrotik.com/wiki/Manual:S ... g#Keywords

You need to read WPA2 property with "get". Property is not a traditional variable.
Setting property is also not so simple as you tried .. look here for example viewtopic.php?f=9&t=138893

Re: wpa to wpa2 clone

Posted: Fri Sep 07, 2018 4:15 pm
by ADahi
script for run one time only, do not schedule
:do {/interface wireless security-profiles 
set default wpa2-pre-shared-key=[get default wpa-pre-shared-key];
set default authentication-types=wpa-psk,wpa2-psk unicast-ciphers=aes-ccm group-ciphers=aes-ccm
} on-error={:log error message="operation failed..."}

Re: wpa to wpa2 clone

Posted: Sat Sep 08, 2018 11:09 am
by runbound
@ADahi i have problem sir with the script. i set this interval to 1minute in schedule but everytime the time comes our celphone connected to mikritik wifi is on and off