Community discussions

 
truefriendcz
just joined
Topic Author
Posts: 15
Joined: Mon Jun 05, 2017 11:07 am

Script ended

Fri Nov 09, 2018 4:29 am

Hi. I have script but ended on line set $item max-limit=($qtsmax);
I do not know what I'm doing or I'm wrong. Will you help me?

Script afterfirst running no abnormally, but after change :local averageDOWN 4000; to any other number no change item and script ended on line $item max-limit=($qtsmax);
How i can fix it?
:local maxlimitDOWN 5000;
:local averageDOWN 2000;

:local percentageDOWN 0;
:local levelDOWN;

:set percentageDOWN (($averageDOWN*100)/$maxlimitDOWN);
:set percentageDOWN (100-($percentageDOWN));
:set levelDOWN (($maxlimitDOWN/100)*$percentageDOWN);

:local qts do={
    /queue tree {
        :foreach item in=[find where name~($qtsname)] do={
            set $item max-limit=($qtsmax*1000);      # ended on this item
            set $item limit-at=($qtsmin*1000);
        };
    };
};

:log warning ("Values: " . (($levelDOWN/100)*95) . ", " . (($levelDOWN/100)*100));
:put [$qts qtsname=Rule305 qtsmin=(($levelDOWN/100)*95) qtsmax=(($levelDOWN/100)*100)];
Test 2: Same problem.
{
:local maxlimitDOWN 5000;
:local averageDOWN 1000;
:local levelDOWN;

:set levelDOWN (($maxlimitDOWN-$averageDOWN)*10);

:local qts do={
    :foreach item in=[/queue tree find name~($qtsname)] do={
	/queue tree set "$item" max-limit="$qtsmax";                         # ended on this item
	/queue tree set "$item" limit-at="$qtsmin";
    };

};
:put [$qts qtsname=Rule305 qtsmin=($levelDOWN*95) qtsmax=($levelDOWN*100)];
}
 
User avatar
Deantwo
Member
Member
Posts: 301
Joined: Tue Sep 30, 2014 4:07 pm

Re: Script ended

Fri Nov 16, 2018 5:09 pm

What is the error the script is giving?
I wish my FTP was FTL.

Who is online

Users browsing this forum: No registered users and 14 guests