Community discussions

 
viktorc
just joined
Topic Author
Posts: 17
Joined: Mon Jun 05, 2006 4:00 pm

Property "disabled" sometimes missing in print/getall results.

Thu Nov 15, 2018 10:34 am

Hello,

I noticed strange bug in 6.43.4. Some records returned by getall (or print) API command sometimes has and sometimes has not property "disabled".
Record which has not this property and are effectivelly enabled, are not returned if query ?disabled=false is set.

API commands
/ip/firewall/mangle/print
=.proplist=.id,src-address,dst-address,new-packet-mark,action,jump-target,disabled
?chain=man-10.11.2-i

!re
=.id=*B
=src-address=10.11.2.10
=new-packet-mark=11.2.10-i
=action=mark-packet

!re
=.id=*C
=src-address=10.11.2.11
=new-packet-mark=11.2.11-i
=action=mark-packet
=disabled=true

!re
=.id=*D
=src-address=10.11.2.12
=new-packet-mark=11.2.12-i
=action=mark-packet
=disabled=false
If record (firewall mangle rule) is created from terminal without explicit "disabled" property (effectively is enabled), API getall returns it without "disabled" (example: id *B).
If this record is disabled and enabled (from terminal, or winbox), API getall returns it with "disabled" property (example: id *D).

Correct behaviour is to return always "disabled" property, with true or false value.

With regards
viktorc
 
nescafe2002
Long time Member
Long time Member
Posts: 622
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: Property "disabled" sometimes missing in print/getall results.

Thu Nov 15, 2018 10:45 am

Can confirm this, but why don't you just report this to MT support?

Who is online

Users browsing this forum: No registered users and 9 guests