Community discussions

 
tentaralangit
just joined
Topic Author
Posts: 2
Joined: Tue Jan 22, 2019 2:41 pm

Urgent!! please help. how to make a script redirect login page ISP in mikrotik

Sat Jan 26, 2019 2:05 pm

Please help..

I have an ISP internet connection where to get an internet connection I have to connect to a hotspot and when connected, a login page will appear and must enter a username and password and a new login I get an internet connection after logging in. I use RB951Hap to connect to my ISP hotspot using the Wlan interfaces on Rb951.

My problem is to log in with a 1-month voucher. I have to edit the default url where the default url is "https://welcome2.wifi.id/wms/?gw_id=WAG ... Bu%20Yayun"

and I have to change to the url "https://welcome2.wifi.id/login/auth/aut ... Bu%20Yayun"

I previously used auto login script:

:log warning "."

:local ip [/ip address get [/ip address find interface="wlan1"] address];
:local ip [put [:pick $ip 0 [:find $ip "/"]]]

/tool fetch http-method=post http-data="username=username@freeMS&password=password" url=("https://welcome2.wifi.id/login/auth/aut ... Bu%20Yayun") keep-result=no

but this script can only point to the default login page

what script code, which can redirect from the default login page url to the url "https://welcome2.wifi.id/login/auth/aut ... Bu%20Yayun"
and mikrotik I can auto login.

thank you

Who is online

Users browsing this forum: No registered users and 4 guests