Page 1 of 1

MQTT client in routerOS

Posted: Thu May 16, 2019 3:27 pm
by doneware
I created an environment in routerOS, that enables IoT-like (i.e. the server doesn't talk to the router, but the router talks to the server) operation. it works in a reasonable way, but i'd think i'd be better of with a proper MQTT client implementation in the device, that enables subscribing and posting to topics:
- performance data, state, logs, idk - so in general "a routerOS variable"
- trigger a script / feed the input of an event that is sent to a subscribed topic

i might say, this shouldn't be a big performance issue as teeny-tiny micros can accommodate one and live on, so i thought i might ask the scripting community whether it would spark some ideas/interest on someone else's side, and create a demand so the next minor release of RouterOS (or maybe #RouterOS7) will suddenly include this functionality.
my explanation for it is that i don't want to track devices, i might not will be able to talk to them (behind nat, behind firewall), but in many cases they could just talk to my server. this would also enable some sort of ZTP/ZTO environment as well.

imagine something like
/system script
add name=handler1 source=":log info message=\"received: $mqtt_input on $mqtt_topic\""
/mqtt brokers
add name=broker1 server=fqdn.of.the.broker port=6969
add name=broker2 server=this.is.another.broker port=1183
/mqtt topics
add name=topic1 broker=broker1 mode=publish topic=topicname
add name=topic2 broker=broker2 mode=subscriber topic=controller script=handler1
and you'll be able to use a script to write a routerOS variable or just a string to a publish-mode topic:
/mqtt post topic="topic1" message=$myvar

Re: MQTT client in routerOS

Posted: Fri May 17, 2019 10:37 am
by GregW
MQTT support would be great. A definite requirement would be SSL/TLS connections for each broker.

Re: MQTT client in routerOS

Posted: Mon May 11, 2020 9:37 pm
by amouses
As a Smart Home user and possibly enthusiast and a multiple Mikrtik user this would be very useful. IE the ability to interact with my MQTT server running elsewhere and subscribe to topics that are being used in our Smart Home. Mikrotik anybody .... ?

Re: MQTT client in routerOS

Posted: Tue May 12, 2020 6:37 am
by Zebble
+1 for this feature. Would love to be able to have Mikrotik devices subscribe to a central MQTT server over TLS/SSL to trigger scripts on topic updates. Perfect for doing lightweight automation and control and not need to poke any inbound holes through firewalls! We currently do this through some script magic but it only checks for updates once a day to keep traffic low...

Re: MQTT client in routerOS

Posted: Sat Jun 27, 2020 12:27 pm
by xvo
+1 for MQTT client

Re: MQTT client in routerOS

Posted: Sun Aug 09, 2020 11:51 am
by imort
+1

/tool fetch which supports TLS 1.2 and can provide CA, public and private key will work for me too.

Re: MQTT client in routerOS

Posted: Thu Aug 13, 2020 10:15 pm
by Skunkworks
+1 for MQTT client

Re: MQTT client in routerOS

Posted: Wed Sep 23, 2020 10:30 pm
by stefan23
+1 for MQTT :-)
would also be interesting as transport protocol for LoRaWAN

Re: MQTT client in routerOS

Posted: Sat Oct 24, 2020 7:50 am
by Sajad2010
+1 for MQTT client

Re: MQTT client in routerOS

Posted: Sat Oct 24, 2020 11:04 am
by ab130kd
News about mqtt and mqtts?
Mikrotik could think develop a tool for iot and dedicating devices, exactly like years ago he started with the rb112 or rb532 when WiFi cards were only PCMCIA....

Re: MQTT client in routerOS

Posted: Sun Jan 10, 2021 8:04 pm
by hawkn
I do also have several Mikrotik units and more to come.
Also running MQTT servers and alot of "things" connected to openhab trough my WiFi.
Next on the list is LoRa for outdoor appliances, and if we get mqtt sub/pub on the unit, I can test several scenarios in my home.

Also HIGHLY supporting this request.

Re: MQTT client in routerOS

Posted: Mon Jan 11, 2021 4:17 pm
by pukkita
+1 for MQTT :-)
would also be interesting as transport protocol for LoRaWAN
Would be a perfect companion!

Re: MQTT client in routerOS

Posted: Tue Feb 02, 2021 10:44 pm
by hatching
+1 for MQTT client

Re: MQTT client in routerOS

Posted: Wed Feb 17, 2021 5:12 am
by Msosa
+1 Publish/Subscribe with encryption feature will be great!!