Community discussions

 
ianngrh
newbie
Topic Author
Posts: 26
Joined: Thu Aug 30, 2018 6:53 am

Cannot do "queue simple add place-before=0" on tile CCR

Fri Nov 01, 2019 6:34 pm

Hi All,

I just want to make sure is "place-before" is not supported by tile architecture when placed on system script, or is it bug, or is it my script that got wrong?
I have simple script command that will create new queue and that new queue should be placed on first queue simple.
This is the simple script command example
/queue simple add name="testing" target="10.0.0.254" max-limit="10M/10M" place-before=0;
The problem is when I put it on system script and run it on CCR it doesn't work. And when I remove "place-before=0" from the command, the queue is created but of course this queue is placed on the very bottom.
My CCR is 1009-8G-1S-1S+ with RouterOS 6.45.7 stable.

I have tried :
  1. Place the command on system script with all policy enabled and run it with full group user on my CCR. Result : No queue created
  2. Run the command on new terminal of my CCR. Result : Queue created and placed on top
  3. Place the command on system script with all policy enabled and run it with full group user on HAP lite, architecture smips and RouterOS version 6.45.7. Result : Queue simple created and placed on top
  4. Place the command on system script with all policy enabled and run it with full group user on RB951-2n, architecture mipsbe and RouterOS version 6.45.7. Result : Queue simple created and placed on top
  5. Place the command on system script with all policy enabled and run it with full group user on X86 machine and RouterOS version 6.45.7. Result : Queue simple created and placed on top
I do not test on the other architecture since I only have that router type. But from my test above my assumption is that parameter "place-before" is not supported by tile architecture or maybe it's a bug.

Please your advice, Mikrotik support and Mikrotik expert.

Thank you in advance. :)
Still trying to be better than before
 
Zacharias
Forum Veteran
Forum Veteran
Posts: 760
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Cannot do "queue simple add place-before=0" on tile CCR  [SOLVED]

Fri Nov 01, 2019 8:43 pm

Works just fine on a CCR1009-7G-1C-1S+ v6.45.6
 
ianngrh
newbie
Topic Author
Posts: 26
Joined: Thu Aug 30, 2018 6:53 am

Re: Cannot do "queue simple add place-before=0" on tile CCR

Sat Nov 02, 2019 7:31 pm

Thanks @Zacharias for your information.
I already downgrade my CCR to 6.45.6, test it, and it works like you said.
Just wonder if it new feature limitation or just a bug on tile v 6.45.7.
Hope the mikrotik support fix it on the next update
Still trying to be better than before
 
User avatar
eworm
Member
Member
Posts: 403
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: Cannot do "queue simple add place-before=0" on tile CCR

Tue Nov 05, 2019 9:46 pm

Ho about something like this?
/queue simple add name="testing" target="10.0.0.254" max-limit="10M/10M" place-before=([ find ]->0);
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
ditonet
Forum Veteran
Forum Veteran
Posts: 841
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: Cannot do "queue simple add place-before=0" on tile CCR

Thu Nov 07, 2019 12:58 am

@ianngrh
Just tested this:
/queue simple add name="testing" target="10.0.0.254" max-limit="10M/10M" place-before=0;
on CCR1036-12G-4S, ROS 6.45.7 and it works as expected.

Regards,
Grzegorz | MTCNA, MTCRE, MTCSE | konsultacje MikroTik Warszawa
It is a book about a Spanish guy called Manual. You should read it. - Dilbert

Who is online

Users browsing this forum: No registered users and 9 guests