Community discussions

MUM Europe 2020
 
creme0099
just joined
Topic Author
Posts: 2
Joined: Fri Jul 07, 2017 7:38 pm
Location: ZA

Adding Dynamic IP to Firewall Address-List

Mon Jan 13, 2020 8:44 pm

Hi All,

I'm struggling to add a dynamic /32 IP obtained either through VPN or PPP to an address-list. I have 3 WAN interfaces. All 3 are dynamic IP's. The first (PPPoE) is used for my primary connection with a default route. The second (3G PPP) is used only to dial-up a VPN (SSTP) to the third connection. So I want to route all the traffic from my only from one PC on my LAN through the second (3G PPP) to the third connection (L2TP) to access certain resources on the VPN.

My reason for wanting this is to use the Firewall to block certain subnets from accessing connection 2 & 3
.
I know can do this by using a separate Routerboard for the 3G connection to the VPN, and just route traffic from said LAN IP to the connection, but I don't have another one right now that has a USB port.

Is there a script to do this? Can someone please assist.
 
Zacharias
Forum Guru
Forum Guru
Posts: 1386
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Adding Dynamic IP to Firewall Address-List

Sun Jan 19, 2020 6:20 pm

You can use the Interface names instead...
 
sopyan0807
just joined
Posts: 18
Joined: Wed Jan 22, 2020 5:21 pm
Contact:

Re: Adding Dynamic IP to Firewall Address-List

Sun Jan 26, 2020 2:12 am

maybe you can add a script in the ppp profile
:local ips [/ppp active get [find name=$user] address];
/ip firewall address-list add address=$ips list=Name

Who is online

Users browsing this forum: Google [Bot], memphisgd and 21 guests