Community discussions

MikroTik App
 
MarcoIT
just joined
Topic Author
Posts: 2
Joined: Sat Dec 05, 2020 10:30 am

3 WAN Load Balancing

Thu Dec 10, 2020 5:11 pm

Hi,
i have 3 WAN static ip connected to Mikrotik 4011 this is my configuration :
# jan/02/1970 00:20:34 by RouterOS 6.47.8
# software id = 0JYA-D1NT
#
# model = RB4011iGS+
# serial number = D4440D9112F5
/interface ethernet
set [ find default-name=ether1 ] name=WAN1
set [ find default-name=ether2 ] comment=WAN2 name=WAN2
set [ find default-name=ether3 ] name=WAN3
/interface ethernet switch port
set 0 default-vlan-id=0
set 1 default-vlan-id=0
set 2 default-vlan-id=0
set 3 default-vlan-id=0
set 4 default-vlan-id=0
set 5 default-vlan-id=0
set 6 default-vlan-id=0
set 7 default-vlan-id=0
set 8 default-vlan-id=0
set 9 default-vlan-id=0
set 10 default-vlan-id=0
set 11 default-vlan-id=0
/interface list
add comment=WAN name=WAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.88.2-192.168.88.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=ether5 name=dhcp1
/interface list member
add comment=WAN1 interface=WAN1 list=WAN
add comment=WAN2 interface=WAN2 list=WAN
add comment=WAN3 interface=WAN3 list=WAN
/ip address
add address=192.168.88.1/24 comment=LAN interface=ether5 network=192.168.88.0
add address=192.168.100.1/24 comment=WAN1 interface=WAN1 network=192.168.100.0
add address=192.168.120.1/24 comment=WAN2 interface=WAN2 network=192.168.120.0
add address=192.168.130.1/24 comment=WAN3 interface=WAN3 network=192.168.130.0
/ip dhcp-server network
add address=192.168.88.0/24 dns-server=8.8.8.8 gateway=192.168.88.1
/ip firewall mangle
add action=mark-connection chain=prerouting connection-state=new in-interface=WAN2 new-connection-mark=WAN1_conn
add action=mark-connection chain=prerouting connection-state=new in-interface=WAN2 new-connection-mark=WAN2_conn
add action=mark-connection chain=prerouting connection-state=new in-interface=WAN3 new-connection-mark=WAN3_conn
add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2
add action=mark-routing chain=output connection-mark=WAN3_conn new-routing-mark=to_WAN3
add action=mark-connection chain=prerouting connection-state=new dst-address-type=!local in-interface=ether5 new-connection-mark=WAN1_conn per-connection-classifier=both-addresses-and-ports:3/0
add action=mark-connection chain=prerouting connection-state=new dst-address-type=!local in-interface=ether5 new-connection-mark=WAN2_conn per-connection-classifier=both-addresses-and-ports:3/1
add action=mark-connection chain=prerouting connection-state=new dst-address-type=!local in-interface=ether5 new-connection-mark=WAN3_conn per-connection-classifier=both-addresses-and-ports:3/2
add action=mark-connection chain=prerouting connection-state=new dst-address-type=!local in-interface=ether5 new-connection-mark=WAN3_conn per-connection-classifier=both-addresses-and-ports:3/3
add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface=ether5 new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface=ether5 new-routing-mark=to_WAN2
add action=mark-routing chain=prerouting connection-mark=WAN3_conn in-interface=ether5 new-routing-mark=to_WAN3
add action=mark-connection chain=forward connection-state=new in-interface=WAN1 new-connection-mark=port_forward_wan1 passthrough=no
add action=mark-connection chain=forward connection-state=new in-interface=WAN2 new-connection-mark=port_forward_wan2 passthrough=no
add action=mark-connection chain=forward connection-state=new in-interface=WAN3 new-connection-mark=port_forward_wan2 passthrough=no
add action=mark-routing chain=prerouting connection-mark=port_forward_wan1 in-interface=ether5 new-routing-mark=to_WAN1 passthrough=no
add action=mark-routing chain=prerouting connection-mark=port_forward_wan2 in-interface=ether5 new-routing-mark=to_WAN2 passthrough=no
add action=mark-routing chain=prerouting connection-mark=port_forward_wan3 in-interface=ether5 new-routing-mark=to_WAN3 passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1
add action=masquerade chain=srcnat out-interface=WAN2
add action=masquerade chain=srcnat out-interface=WAN3
/ip route
add check-gateway=ping comment="PCC Wan1" distance=1 gateway=WAN1 routing-mark=to_WAN1
add check-gateway=ping comment="PCC Wan1" distance=1 gateway=WAN1 routing-mark=to_WAN1
add check-gateway=ping comment="PCC Wan2" distance=1 gateway=WAN2 routing-mark=to_WAN2
add check-gateway=ping comment="PCC Wan2" distance=1 gateway=WAN2 routing-mark=to_WAN2
add check-gateway=ping comment="PCC Wan3" distance=1 gateway=WAN3 routing-mark=to_WAN3

so, my performance aren't optimal, the bandwidth are little and the navigation is slow eg.:

N. 3 sim about 30 kb/s * 3 = 90 teorically

but ny bandwidth is about 7-8 mb/s.
Can anyone help me?
Thanks

Who is online

Users browsing this forum: WiesiDeluxe and 21 guests